Tips and tricks. Unofficial guides and fixes. User edition.

Discussion in 'General - Guides and FAQ' started by HaoSs, Dec 7, 2016.

  1. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    As the title mention. This thread will be a unofficial user guide. Because allot of fixes are discovered by users, we need a place to put them in. I will maintain this thread but i need your help.
    PM ME ANY FIX YOU DISCOVER OR YOU HAVE SEEN POSTED ON THE FORUM BY OTHER USERS.
    Or you can replay with the fix here and i will add it to the list.
    X6 PRO:
    1. the x6pro FAQ list: http://forum.zidoo.tv/index.php?threads/zidoo-x6-faq.941/
    2. Sound sync fix: http://forum.zidoo.tv/index.php?posts/16212
    X9:
    1. Streaming server and player app: http://forum.zidoo.tv/index.php?posts/16114

    X9S/X8/X10:
    1. Guide to internal/UBS HDD : http://forum.zidoo.tv/index.php?thr...izes-2-tb-internal-or-via-usb-enclosure.3768/
    2. TRANSMISSION CONFIG LOAD FIX: http://forum.zidoo.tv/index.php?posts/14687/ ( should be fixed in firmware 2.1.14+)
    3. ARIA2 CONFIG AND SESSION FIX: http://forum.zidoo.tv/index.php?posts/17756 ( should be fixed in firmware 2.1.14+)

    4. Samba and FTP setup in OpenWRT: HERE (interface changed but the settings should still apply )
    5. SAMBA tweaks: http://forum.zidoo.tv/index.php?posts/18049
    6. Unofficial HDCP hack ( NOT WORKING ON LATEST FIRMWARES ) : http://forum.zidoo.tv/index.php?posts/16438
    7. Wireless/air mouse signal problem: http://forum.zidoo.tv/index.php?posts/18282/
    8. OpenWRT unofficial 4PDA repo: http://forum.zidoo.tv/index.php?threads/openwrt-repo-russian-edition.4168/
    9. Samba share and MAC: http://forum.zidoo.tv/index.php?threads/cant-connect-my-mac-via-smb.3996/
    10. Miracast guide: http://forum.zidoo.tv/index.php?threads/miracast-airplay-screenmirror-happycast.4440/
    11.DLNA over WI-FI: http://forum.zidoo.tv/index.php?posts/23420
    12. Send direct video links from a Mac or Linux PC to Kodi: http://forum.zidoo.tv/index.php?threads/tut-url-to-kodi-scripts-for-macos-and-linux.5543/
    13. Stuck at flash fix: http://forum.zidoo.tv/index.php?posts/28733 (make sure you search and use the .img for your box(x8 or x10, this guide has link for x9s .img firmware only)
    14. Zidoo remote control over ip http://forum.zidoo.tv/index.php?threads/web-remote-control.10809/#post-48687

    Topic will not include official guides from zidoo, those will remain here, make sure to read them : http://www.zidoo.tv/Support/faq.html

    Recomandations:
    How to flash the box ( all of them ): http://www.zidoo.tv/Support/faq/guide_target/knZnnclmVcI=.html
    Standard zidoo CVBS cable: http://www.zidoo.tv/Attached/image/20161101/20161101173752_86429.jpg
    Configure SAMBA on win10: HERE


    Last update 23.10.2018, this guide still applies for x8/x9s/x10.
     
    Last edited: Oct 23, 2018
    sjn01, budahom, Werner P. and 6 others like this.
  2. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    aria2 config and sesion fix:
    same as transmission fix. just sleep time is longer:
    connect to openwrt with putty
    "vi /etc/init.d/aria2"
    add sleep 60 in start script
    use keyboard arrows to navigate to the line. press "I" to enter insert mode. write "sleep 60" . press escape to exit insert mode. write ":wq" enter, to write the file and quit, reboot
     
    Last edited: Dec 8, 2016
  3. francishe

    francishe Member

    Good idea and good threads. Will help a lot to fix problems and learn tips. Thanks @HaoSs
     
    HaoSs likes this.
  4. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    topic will stay open untill we get it off the ground. Once we have a OK database of links. i will do a cleanup, only fixes will remain.
     
  5. spawn_lmg

    spawn_lmg Active Member Beta test group

    If add 'sleep' in config Transmission or Aria2 it becomes unavailable System->Startup :(
    Bad Gateway
    The process did not produce any response
     
  6. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    You added it like in the picture
     
  7. spawn_lmg

    spawn_lmg Active Member Beta test group

    Yes. you startup working? Have you checked?
     
  8. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    you must be doing something wrong, i'm using the sleep fix for over a month now.
     
  9. spawn_lmg

    spawn_lmg Active Member Beta test group

    Sleep is operating normally, but you can not at the same time go to the startup configuration
     
  10. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    make a video if you have time, so i can see exactly what you mean
     
  11. GoldBar

    GoldBar Member

    Hello, is there any confirmation from Zidoo for fixing the USB-out Audio problem for the next F/W?
    With some dongles connected to the USB port (such as the MINIX air mouse) it sends the Audio to the USB port, thus having No audio on the HDMI. The android setting do not work...very annoying.
     
    642095573 likes this.
  12. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Will add a switch option in next version
     
  13. GoldBar

    GoldBar Member

    Great...thank you!
    I think this is important for many people.
     
  14. spawn_lmg

    spawn_lmg Active Member Beta test group

    SAMBA Patch! Big thanks qqq1971 from 4PDA HiMedia Q10 PRO topic http://4pda.ru/forum/index.php?showtopic=734477

    1. TV-box starts seen in the network
    2. The increased upload / downlod speed
    3. Add the folder 'shara' with all the attached external storages

    Open WEB-interface OpenWRT
    NAS Services -> Samba -> Edit Templates
    Replace the entire text of this:

    [global]
    netbios name = |NAME|
    display charset = |CHARSET|
    # interfaces = |INTERFACES|
    server string = |DESCRIPTION|
    unix charset = |CHARSET|
    workgroup = |WORKGROUP|
    browseable = yes
    domain master = no
    encrypt passwords = true
    enable core files = no
    guest account = nobody
    guest ok = yes
    invalid users = root
    local master = no
    load printers = no
    map to guest = Bad User
    # max protocol = SMB2
    # min receivefile size = 16384
    null passwords = yes
    obey pam restrictions = yes
    os level = 20
    passdb backend = smbpasswd
    preferred master = no
    printable = no
    security = user
    smb encrypt = disabled
    smb passwd file = /etc/samba/smbpasswd
    # socket options = TCP_NODELAY IPTOS_LOWDELAY
    syslog = 2
    writeable = yes
    min receivefile size = 512
    use sendfile = true
    aio read size = 4096
    aio write size = 4096
    write cache size = 1024000
    read raw = yes
    write raw = yes
    getwd cache = yes
    oplocks = yes
    #max xmit = 65535
    max xmit = 131072
    dead time = 0
    large readwrite = yes

    [shara]
    path = /mnt
    read only = no
    guest ok = yes
     
    Last edited: Dec 21, 2016
    pirmas, pcristi, HaoSs and 1 other person like this.
  15. spawn_lmg

    spawn_lmg Active Member Beta test group

  16. pirmas

    pirmas New Member

    Well, it worked, drive mounted, but no files are seen from remote computer or phone. Any suggestions whats the problem? I have external ntfs hdd.
     
    Last edited by a moderator: Feb 5, 2018
  17. alexpopov78

    alexpopov78 New Member

    When inserted line "sleep 60"
    "System" - "Startup" menu (in Openwrt) does not accessible.
    Аnyone solve this problem??
     
    Last edited: Jan 13, 2017
  18. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    show me a screenshot with the file where you insert the sleep 60. So i can see if its OK
     
  19. alexpopov78

    alexpopov78 New Member

     

    Attached Files:

  20. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    that's correct, not sure why you are having this problem , working fine for me. its just a delay on a startup. should not brake anything. in 60 seconds aria should just start and thats that
     

Share This Page