New firmware v2.2.56 beta version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by mirror, Mar 30, 2019.

  1. ICU2018

    ICU2018 New Member

    unfortunately it's very bad update I'm facing issues that colors not good even all settings is AUTO & frozen pic.. so that I recommend back to FW 2.1.30.

    Goodlock zidoo.
     
  2. Reelyator

    Reelyator Active Member

    ...Thank you for your detailed feedback Nice Monkey!

    Have you found a way to import your SACD Database into Music Player 3.0 with correct detection of Album, Titel, Artist....?

    My experince with Music Player 3.0 was pretty disapointing: No matter how i structure folders, file names etc, not a single album was imported correctly. Therfore i am curious if anyboy made this work.
     
  3. xtripsnova

    xtripsnova Member

    Maybe on your unit. The Z9S has many problems, but not with the colors or the picture quality. Incidentally I am a professional video calibrator and I can attest that the PQ is fine.
     
  4. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    No this one and another zillion music players just look at the meta data directly and ignore the work one has done in structuring folders and albums. I have given up on that myself and just use a file-browser to zip through my own structure.

    @ICU2018
    No problems here with PQ either.

    @mirror
    With the HT2 update it seems to play movies stable again too. Viewing 2 movies thus far. This said till I tried to skip back. Locked up immediately and needed a movie restart (but Android still alive)
     
    Last edited: Apr 3, 2019
  5. Zigourney

    Zigourney Member

    I had the same issue when I tested a movie last night, couple of stutters then immediately the movie locked up (froze) and needed a movie restart, but the system (android) was still ok and responsive to remote commands.
    This beta firmware is a welcome improvement from the last, but definitely a lot of work is still needed to iron out the smaller stutters, glitches and movie lags, as well as overall system performance.
     
    gymnos likes this.
  6. antr

    antr New Member

  7. Zigourney

    Zigourney Member


    Thanks Mark, I would highlight my experience, similar to yours - however it is opposite in that my X9S on 2.1.22 performs absolutely perfectly with 4K MKV remuxes - flawless playback of any file 4K HDR, 1080p, everything. No skipped frames, no audio dropouts, no sparklies, no screen tearing.

    However I've only seen the "Black Screen Issue" as well as the audio dropouts on DTS codecs on the Z9S and the Z10 - so I am not inclined to believe it is a SOC issue, rather a firmware compatibility issue, and given the release of 2.2.56 it appears the blank screen issue has been resolved for some, as indicated above in the earlier comments, pointing to a problem that is now beginning to be resolved within the firmware.

    If Zidoo have purposely disabled 4k23 12-bit 444 and so even if you choose that mode, the output will still be 10-bit? Then why do we have a misleading menu setting inside the Zidoo player? and what about colour banding issues being introduced when using other combinations of settings other than the preferred 4k 10bit 444 for blurays?

    So yes I do agree with you that it is worth a try, but the real solution is got to be getting the firmware right for the 1296 series boxes.
     
  8. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    I'm not sure why 12-bit 444 isn't greyed out when you choose 4k23/24/30 - you're right, it is misleading. When I asked about it, I got this reply from Support:

    "Actually we could support 4K 23 12bit 444, but as some device don't support 4K 23 12bit 444 and will show no signal, which made lots of users confused, so we decide not to output 4K 23 12bit 444 finally after we think twice."

    However, if a device supports 4k23 10-bit 444, I can see no reason why it shouldn't support 12-bit - it's 13.4GHz as opposed to 10-bit's 11.1GHz, so as long as you have half decent cables you're not really stressing the HDMI chain either (my cable from amp to projector is 15M (50ft), was installed in 2006, is most definitely NOT certified and was made years before 4K was a twinkle in the BDA's eye and it works perfectly at 4k23 12-bit 444!)

    Also, as I said earlier, I've seen some freaky and unexpected effects from 4K23 10-bit 444 on 1295 boxes - I always use 12-bit 444 on other boxes to mitigate any potential issues.

    You'll obviously see banding in 10-bit video when played back at 8-bit (assuming no dithering, which none of these players do) but you will also see it at 12-bit 422 since that mode is handled internally at 8-bit - this I think is a limiting factor of the 129* SOCs - I have other players that are fine at 12-bit 422 (HiMedia & Shield for example).

    Banding isn't an issue at 4k23 10 & 12-bit 444, and indeed there is no difference in picture quality between 10-bit 444 and 12-bit 444. At 12-bit the player just pads - there's no extra "processing".
     
    Last edited: Apr 3, 2019
    gymnos and Zigourney like this.
  9. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    I have never had the black screens, but I HAVE had audio dropout on DTS-HD/X tracks on v2.1.22 and v2.1.30 and reported this to Support at the time. I never had that issue before v2.

    I managed to get rid of these dropouts by reverting to v1.7.8 then installing v2.1.40 over that. Since then I've watched 26 4K remuxes with no issue (I've been keeping count. Sad eh? :))
     
    Zigourney likes this.
  10. vman

    vman Member

    I updated the firmware and the HT2, while it scans my usb drive, now it does not recognize any titles, for example aquman, bumblebee, creed2, mortal engines, robinhood, etc. I even tried using the IMDB codes and it still did not recognize them. Anyone else having this issue!
     
  11. Zigourney

    Zigourney Member

    Yes the DTS audio dropouts that I was referring to are to be precise for DTS-HD/X tracks, for example The Harry Potter Complete Collection is in DTS-HD MA and DTS-X, I had stutter issues on those on the Z9s and the Z10 but they play perfectly fine on my X9S.

    ....and no keeping count is not that sad, I had zero 4k movies before I bought my oled tv last Sept 2018, and now I have 134!
     
    Markswift2003 likes this.
  12. Guz

    Guz New Member

    The developer options are gone with firmware v2.2.56. Is there a way to get them back?
     
    gymnos likes this.
  13. blenky

    blenky Active Member

    I installed the latest beta but my HT2 was still version 1.97 (or something.) I d/l a new apk that was posted on another forum (v2.1.8). Doesn't HT2 get updated as part of the firmware update?
     
  14. vman

    vman Member

    Zidoo want let you go back to a prior firmware version. When I tried to go back to firmware 2.1.30, it says, "verifying failed, the upgrade package is lower than the current version."


    WTF.


    Anybody know a workaround.
     
  15. x9suser

    x9suser Member

    When FW 2.2.56 was released , there was a problem with HT2. So they released a fixed version of HT 2 later to install separately.
     
  16. blenky

    blenky Active Member

    OK I get that there was an issue with HT2 within 2.2.56 - but when I installed 2.2.56 it did not update my HT2. So I just happened across a thread with a link to the fixed version of HT2. Otherwise I would have never known I was out of step!
     
  17. DaMacFunkin

    DaMacFunkin Active Member

    Hurray 7.1 aac files fixed, no green screen and reboot
     
  18. Thor

    Thor New Member

    didnt fix the 10bit black screen issues... same problem..
     
  19. Emphyrio

    Emphyrio Member

    the same still black screen issue, could you please add a dev option to enable 12bit choice ? tks
    Because i think this prob can stand months ..
     
  20. Theeraphon

    Theeraphon Member

Share This Page