ZIDOO Z9X subtitle flashing blink

Discussion in 'HDD Media player(RTD 1619DR)' started by Eleonor, Dec 29, 2020.

  1. Eleonor

    Eleonor Member

    At the outset, I would like to apologize for my English - I rely on google translate and can guess a bit :)

    Several users have reported a problem with external .srt subtitles on the Z9X.
    The point is that the subtitles sometimes flash before or after the moment they are to be displayed.

    In my case it is not repetitive so it is not enough to rewind the film to repeat the blinking.
    Blinking occurs on every movie with external .srt subtitles and when the movie is about 2 hours long it flashes dozens of times

    One colleague managed to record it :
    http://forum.zidoo.tv/index.php?attachments/flashing-subtitle-rar.6083/

    Please friends @Magyar Péter @wally @maglione @papirus
    to write in this topic about this problem

    The weird thing is error that it's not repetitive - it is in different places and different times of the movie - yesterday as I was pushing back and forth

    I couldn't get it I often do the captions myself - I take them out of blueray, I transform them into SubtitleEdit and there is no error or any time overlaps in them - they are like on the internet when you download quickly and people can't do it
    I pay attention to the inscriptions and they must match perfectly ..
    And here on the Z9X I have such a flashing error

    I have the latest firmware v6.0.85 loaded but users reported that the subtitles flashed on older firmware.
     
  2. 3DBuff

    3DBuff Active Member

    This is the post with captured video file:
    http://forum.zidoo.tv/index.php?threads/beta-version-v6-0-85-for-z9x.84701/page-3#post-141178

    I don't have this problem but I don't use subtitles much.
    Looking at video file it almost looks like next chapter or new scene starting up and text is reapplied again on new scene. The blink is quite long. Few frames for sure and movie appears to continue at normal speed without stutter.

    Someone mentioned using custom fonts. Is everybody with this issue using custom fonts?
     
  3. Eleonor

    Eleonor Member

    Custom font doesn't cause this - I checked
    I attach a video - this is not my material and I hope that my friend @Magyar Péter will not be offended :)

    https://files.fm/f/5yyur83r8#


    the flashing subtitle.
    time : 00:08, 01:12 and 01:28
     
    3DBuff likes this.
  4. Magyar Péter

    Magyar Péter New Member

    I have used a Zidoo Z9X player for a month. The external subtitles (.srt) show up with flashing effect. You can imagine this flashing effect that the text appears then disappears for some milliseconds and appears again. It would seem the definite text duplicate in the srt file but it isn't. The timings of subtitles are OK. This bug happens 20-40 times during a 2 hours movie. Curiousity I see the effect anywhere in the movie and I rewind to that same point and the effect doesn't occur in that same point.
    I stepped on every fw version from 6.0.45 to 6.0.85 and this bug has occured with every fw.
    This effect occur with every movie in mkv container with external srt file. The display of the subtitle is perfect with internal subtitle in mkv container.
    I have passed along every subtitle settings in the main menu and in the subtitle menu.
    I use the player only from local source via USB 3 or SATA port. I watch mixed 720p/1080P RIP and Remux only from mkv container. Before the Z9X I used a Dune Base 3.0 and on that player I haven't such problem with external subtitles.
    I made two short movie about this effect. You can download here.
     
  5. Magyar Péter

    Magyar Péter New Member

    I've experienced that you can see in the video with these default settings:
     

    Attached Files:

  6. Eleonor

    Eleonor Member


    Here is an example of the inscriptions - everything is correct for me, line 43 was flashing frequently - it was flashing for a fraction of a second before or after it should be displayed :

    40
    00:03:26,582 --> 00:03:28,709
    pożałujesz, że uciekłaś z Alderaan.

    41
    00:03:30,127 --> 00:03:31,420
    Widziałem tatuaż.

    42
    00:03:32,754 --> 00:03:34,047
    A wiesz, co jeszcze?

    43
    00:03:35,465 --> 00:03:38,010
    Widziałem, jak ginie twoja planeta.

    44
    00:03:40,429 --> 00:03:41,722
    Na Gwieździe Śmierci.

    45
    00:03:42,514 --> 00:03:43,557
    Na której?

    46
    00:03:45,184 --> 00:03:46,977
     
    Last edited: Dec 30, 2020
  7. Whitfield

    Whitfield Active Member

    Strange. I can confirm the flashing external srt. Strange thing is, that with a HD video this does not seem to happen. At least, I've watched a 1080p movie for half an hour without any subtitle flashing. I only notice it with UHD video. And within a few minutes then.
    Can somebody confirm this?

    It would be consistent with other subtitle issues I found earlier this year. These concern SUP files being handled differently, according to the type of video (HD or 4K) they're muxed with.
    I still have to describe these issues properly and I will start a thread about it, when I have time...
     
  8. maglione

    maglione Member

    I have flashing in 1080p, 4k, 4k UHD,
    since September and I also reported it in my first post on this forum, in mid-September. I have experience for 10 years in media players, many brands and I can say without a doubt that this is a zidoo bug.
     
  9. Magyar Péter

    Magyar Péter New Member

    I would supplement some circumstances. It may be interest.
    I use the Z9X still with FULL HD LCD TV (Samsung LE40A656) and the video output is set 1080P60Hz (Auto), Only Framerate switch, Colour range 16-235, but I have tried every setting options. I use with HDMI cable that I got to the player.
     
    Last edited: Dec 29, 2020
  10. Eleonor

    Eleonor Member

    A moment ago I launched the same file Mandalorian from the very beginning, without scrolling, and the error showed up - the subtitle are flashing

    Time 00:12 or 00:20


    I had a subtitle blink right after the correct time

    88
    00:07:43,755 --> 00:07:46,800
    dobrze przemyśl,
    czy do nas nie dołączyć.

    or

    90
    00:07:52,472 --> 00:07:54,433
    - Przemyślę.
    - Jeszcze jedno.



    This is what it looks like in the .srt file:

    85
    00:07:34,830 --> 00:07:35,873
    Zgoda, pomożemy.

    86
    00:07:37,291 --> 00:07:40,335
    Ale w zamian zatrzymamy statek
    do walki o Mandalore.

    87
    00:07:41,003 --> 00:07:43,130
    Jeśli zdołasz ukończyć swoją misję,

    88
    00:07:43,755 --> 00:07:46,800
    dobrze przemyśl,
    czy do nas nie dołączyć.

    89
    00:07:47,593 --> 00:07:51,638
    Mandalorianie zbyt długo
    byli skazani na tułaczkę.

    90
    00:07:52,472 --> 00:07:54,433
    - Przemyślę.
    - Jeszcze jedno.

    91
    00:07:54,975 --> 00:07:57,644
    Gideon ma broń,
    która kiedyś należała do mnie.

    92
    00:07:58,604 --> 00:08:01,273
    To pradawne ostrze,
    zdolne przeciąć wszystko.

    93
    00:08:01,857 --> 00:08:02,858
    Niemal wszystko.

    94
    00:08:03,984 --> 00:08:06,111
    Nie przebije czystego beskaru.

    95
    00:08:07,279 --> 00:08:10,574
    Zabiję Moffa Gideona
    i odzyskam swoją własność.


    p.s.
    After moving forward and backward, the blinking of the subtitles did not occur at this point

    Here is the proof:
     

    Attached Files:

    Last edited: Dec 29, 2020
  11. gogo789

    gogo789 Member

    I also experience the issue, I thought it was due to bad subtitles but aparently not.
     
  12. Eleonor

    Eleonor Member

    Welcome to the club
    I hope it gets fixed, but Zidoo has problem to see it
     
  13. papirus

    papirus Member

    Thanks Eleonor ,

    The problem is not that the video file is UHD or 4K.

    Same for HD videos. This flashing was doing occasionally on previous software.

    But I thought the subtitle file was corrupt.

    The strange thing is that when I take the video back and look at it again, it doesn't do it in the same place...


    Edit ( Update about files )

    Subtitle Language : Turkish
    Subtitle : srt
    Video File : mkv
    Encode : Turkish ( Windows-1254 )
    and Subtitle file has not been tampered with...
     
    Last edited: Dec 31, 2020
  14. Eleonor

    Eleonor Member

    True, it is strange, but on the plus side, it proves that the subtitles and video file are correct and without errors :)

    Hope you read it all @mirror
     
  15. Comporellon

    Comporellon New Member

    Hi!
    I have Z1000pro and I also experience this issue since I have it.
     
  16. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I have never seen it. I am using USB3 or SATA attached HDD's and movies are always BD or UHD/HDR10 BD unfragmented in ISO format. I do watch movies almost exclusively without menu's (menu's only when needed for a specific view). Player processing with and without menu does make a difference as it uses a different engine doing so.

    No idea if the above makes a differentiator? But just try it with those conditions.

    I do use external srt subtitles a lot as I often use Dutch via on-demand download.
     
    Last edited: Dec 29, 2020
  17. Eleonor

    Eleonor Member

    I bought the Z9X only because it was advertised that Dolby Vision will open in mkv ......

    For what you watch ISO, BD I have something better: Oppo 203 or Clone


    I mostly use .mkv movies
    I always have subtitles in SubRip .srt, UTF-8 with BOM
    Each video has subtitles flashing in different places
    Maybe you don't see it, but you have the evidence above

    Did you watch this video I posted?

    http://forum.zidoo.tv/index.php?attachments/z9x-subtitle-problem-zip.6095/

    Do you know what we mean?
     
    Last edited: Dec 30, 2020
  18. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I watched it under Windows on my PC and saw what you mean also there but I repeat I have never seen that with my way of viewing movies.
    I hardly ever play MP4 or MKV with DV or without as I don't like manipulated content and go for 1:1 copies only.

    I also own a real original OPPO UDP-203 too which I use almost exclusively for playing Music. MP6 needs a lot of work to catch up for that. I frankly prefer my Z9X for movies as it has lot better/more features for several goodies including subtitles which I always use and very often in External SRT format. I use very often the subtitles downloaded from opensubtitles.com or Zidoo on-demand itself. Never edit those subtitles just use time-shift set to the up/down cursor keys. The green key I have matched to requesting downloading subtitles on-demand. It never results in the problem shown in the video. Never use UTF-8 (Polish) but Western Europe CP1252 instead (subs in Dutch, English, Spanish, French or German). There is an Eastern Europe CP too, does that one work for Polish?

    I am sure the problem is there and real but you need to nail down the exact condition it happens with. Try English subtitles with CP1252 for example with the same movies and see if it still happens? Just repeating that it happens with your way of viewing does not help diagnosing as many don't see it including me and I watch a lot of movies using Z9X.

    There are many different ways/formats to use a Media Plyer to watch the same movies.
    "So saying I have the problem too" does not help in anyway solving it. Specify exactly how you watch movies with as much variables clarified as possible as a start:
    - Source: USB2, USB3, SATA, NAS NFS, NAS SMB
    - Container: ISO 1:1, ISO remux, BD folders, MKV, MP4
    - Language subs:
    - Character set for subs:
    - Format for subs: SRT assumed here but did you try other formats?
    - Edit program used for subs:
    etc etc
     
    Last edited: Dec 30, 2020
  19. Eleonor

    Eleonor Member

    Coding doesn't change anything if I choose UTF-8 with BOM or 1252 or other ..
    It's just about showing the diacritics of your country, in my case Polish Ą ą Ć ć Ę ę Ł ł Ń ń Ó ó Ś ś Ź ź Ż ż

    I am not able to determine the exact state in which it happens because it is different each time - the inscriptions flash here and then in a different place ... this is not normal and I repeat again that on another player it does not happen



    My way:

    - Source: USB3, NAS SMB
    - Container: MKV
    - Language Polish
    - Format for subs: SRT UTF-8 with BOM
    - Edit program used for subs - SubtitleEdit

    I check each subtitle for errors, fine-tune - I've been doing it for over 20 years ...
     
    Last edited: Dec 30, 2020
  20. Magyar Péter

    Magyar Péter New Member

    I have tried any subtitle encode format in Z9X.
    Auto: works with flashing
    UTF-8: works with flashing
    ANSI: doesnt't work (resolved subtitle file failed)
    Central european W1250: works with flashing
    etc.
    More format visualize some character wrong.
    I have tried every subtitle fonts. Nothing changed.
    I think the problem is subtitle language specific. I always watch movie with hungarian subtitle. Hungarian language has some accentuated letter (á, é, í, ö, ő, ü, ű)
    Eleonor colleague watch movie with polack subtitle. In polack language there are some special letter.
    What do you think?
     

Share This Page