New firmware v2.1.40 beta version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by mirror, Jan 24, 2019.

  1. DaMacFunkin

    DaMacFunkin Active Member

  2. blenky

    blenky Active Member

    The files do indeed green screen and reboot my Z9S. They also they don't play on my Dune HD Pro 4K. On that device it just hangs at the loading screen and I need to press stop. This crashes the internal player but not the device.
     
  3. filip kenens

    filip kenens Member

    I have the same problem with my x9s.
     
  4. Baciok

    Baciok New Member

    Even with this new firmware the status bar / notifications bar is absent.
    I request the resolution of this bug.
    Thank you
     
  5. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    You are touching the difference between Android for Smartphones and Android TV. APP´s for Android TV are designed to work without the notification bar. The Android version on most media players sits somewhere in between as Android TV needs a permission from Google. Do you want your movie player to show a notification when one of the APP´s receives something?
     
  6. Baciok

    Baciok New Member


    on Z9s there is no Android TV but Android "classic" or am I wrong? I think the status bar is very important to be able to use my Android box in all its features and with all the apps that use the notification bar (example download speed, time remaining, quick activation of functions, mirror notifications from other devices, etc.)
    In all the TV boxes I had, I always had the opportunity to decide whether to enable or disable the notification bar via an option in the settings. Even if the bar was enabled, using full screen apps like Youtube, Netflix, Amazon Prime Video etc., this was automatically hidden.
    I bought my first Zidoo paying much more than a traditional Android box because I am convinced that it is the best at the moment (paid as a Shield TV) but it seems to me absurd that such a trivial setting as activating or deactivating the notification bar is not present .
    I want to be able to use my box at 360 degrees as I have always done with my previous boxes (and paid a lot less) and not just to view the video files.
    Without the notification bar / status bar I can not use the box unfortunately ... and I'm really sorry (even for the price paid)
    If I had known before this strong limitation, I would have bought something else even if, as already written, at the moment I think the Zidoo Z9s is the best in its category
    I hope that the developers Zidoo decide to solve the problem with the next firmware or I will be forced to resell the box even if very sadly given the overall quality of the device.
     
  7. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    @Baciok
    I do understand the desire but if it will come I have my doubts.
     
  8. J.K.uploaden

    J.K.uploaden New Member

    Seamless Branching does not work.

    On the Alpha (2018) Blu-ray ISO: if you select the Director's Cut, Zidoo plays the audio track from the Theatrical Cut, which does not match the video track, of course.
    This happens from the Blu-ray menu selection and also from the Blu-ray light menu. :mad:

    The The Equalizer 2 Blu-ray with Seamless Branching (Retribution Mode) did not work either. :mad:
     
  9. metar

    metar New Member

    Hi everyone, I'm new here: using the Z9S for a month, and maybe it's time to have some answers to my doubts about the firmware.
    Z9S has factory v1.7.8, but now there is the v2.1.40beta: just because it's beta, it will not upgrade automatically, but I must follow the manual OTA procedure: is this right?
    After the upgrade, just in case it would disappoint me, is there any chance to roll back to v1.7.8?
    And how I would eventually do it? Just because I didn't see any link to download the v1.7.8 OTA anywhere....
     
  10. razserv2010

    razserv2010 New Member

    Link and download the guide in PDF file I attached here
     

    Attached Files:

  11. metar

    metar New Member

    Thank you very much: next days I'll try with the 2.1.40, and if I should have any issue I'll let you know...
     
  12. x9suser

    x9suser Member

    I sent a sample of the color problem to their service contact. But they told me the problem was fixed in this 2.1.40 firmware.
     
  13. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    It's possible they misunderstood what the problem was - Must admit I haven't checked on v2.1.40 as I don't use HDR>SDR but I'll check the scenes I originally sent today and get an email off to Support too to reconfirm the issue.
     
  14. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    Ok, confirmed the posterisation is still there in HDR-SDR - very easy to see in the opening scenes of Bladerunner 2049 on the pilot's jacket.

    It's noticeable if you have gamma set to <Bright> and more so if set to <Movie>, but if you set gamma to <Vivid> it's not really noticeable, so in the meantime if you need to use HDR to SDR I suggest using gamma set to <Vivid>
     
    gymnos likes this.
  15. x9suser

    x9suser Member

    I don't like vivid, on my TV it makes the pic look dark, no matter how I adjust the blacks , details look lost.
     
  16. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    I've never seen a 129* player do a good job with HDR to SDR, the gamma is always set way too low.

    The only way I've countered it in the past is to set gamma to 1.6 but I was only able to do that because I can write custom gamma curves to my projector (by default it would only go to 1.8 which was still too dark). Unfortunately most TVs don't have that level of control.

    Anyway, I've sent another email off to confirm the issue is still there in v2.1.40.
     
  17. x9suser

    x9suser Member

    The X9S does the job beautifully. Everything bright and clear. Colors nicely saturated.

    FW 2.1.22.
     
  18. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    Ok, I'll take that comment back! I just tried my X9S in HDR>SDR and you're right - it's not bad at all. Certainly better than the Z9S currently, but I think the Z9S was similar back before the gamma updates in v1.9.7.

    The conclusion to draw from this then is if you have an SDR display, stick with the X9S until the gamma is fixed on the Z9S.

    Just did a quick comparison with the Dune Pro 4K too and the X9S trounces the Dune in this department too!
     
  19. metar

    metar New Member

    Well, here I am again after installed the v2.1.40
    The main issue I found is that when I play mkv files with dts audio, while video is fluid, there are often 'holes' in the audio, just 1/10 or 2/10 sec, and it happens every 5-8 minute.:(
    I tried with both the Nuplayer and the Native Player (although I really don't understand the difference between them : any clue?:rolleyes:).
    Audio output raw to the amplifier via SPDIF.
    Video output raw to the tv via HDMI.

    Another issue is on another mkv file (and only with that): I can watch the movie on my pc without a problem, but with the Z9S it give me the infamous "green screen" (but it doesn't freeze the player).:(

    After the update the "weather app" is now ok (I couldn't insert the locations before, but I don't know if it was fixed on a previuos release).:)

    I have other questions, but I'm going to open a new topic, since I don't think they are about the firmware...;)
     
  20. Markswift2003

    Markswift2003 Well-Known Member Beta test group Contributor

    The distinction between NuPlayer and Native Player is relevant only for online media - they call different players depending on the URL of the media - NuPlayer calls the Android Player included in the Google Framework and Native Player calls the Realtek Player.

    Neither selection has any effect on playback of local media. According to Zidoo, leaving it on NuPlayer is generally okay, but it doesn't really seem to matter, and again, is only relevant to online media.

    I have had audio dropout, but only a couple of times per movie (max was three) and with both DTS-HD and Atmos, however I think I fixed it by restoring to v1.7.8 (using emergency USB restore method) and then going straight to v2.1.40 (using OTA USB method).

    Can't say categorically that fixed it, and it only happened on 2 or 3 movies, but I've watched quite a few more since and not had a problem.

    Never seen a green (or black - loss of HDMI sync) screen.

    Just realised you're using the S/PDIF output for audio - so this is different to the issue I had since you're only transferring the standard DTS or AC3 core streams - I take it your receiver isn't 4K?
     
    Last edited: Mar 2, 2019

Share This Page