New firmware v2.0.34 version for ZIDOO X9S release

Discussion in 'X9S Official Firmware Releases' started by mirror, Jul 4, 2018.

Thread Status:
Not open for further replies.
  1. JohnS

    JohnS Member

    If your Avr is capable of decoding TrueHD and DTSMA you shouldn't connect it with Spdif because of problems downmixing on 5.1. You should connect your zidoo to AVR (HDMI) and then your Avr to your Tv (HDMI), i believe this is the best way. All of us which tried to connect through spdif are having problems with correct downmixing.
    I never really tried to play an HDR content since my tv is only capable of 1080i (i know it's old!)
     
  2. kairi033

    kairi033 New Member

    I really understand your point because that was my initial set-up however, my AVR (Denon 1612) can only passthrough 1080P/3D video signal and thus, 4K signal can't passthrough (I only get black screen with sounds) which also makes me wonder that my AVR should downscale the resolution to 1080P.
     
  3. JohnS

    JohnS Member

    Have you tried an HDMI splitter?
     
  4. kairi033

    kairi033 New Member

    No, actually I never tried an HDMI splitter in my entire life and how does it work:p

    Actually it doesn't matter since the problem lies somewhere between the TV box and my TV. I'll dig out more information later.
     
  5. JohnS

    JohnS Member

    There is one input (where you connect the zidoo) and has 2-3 or more outputs where you connect your tv and avr. So you have the sound to your avr and video signal to your tv. Google search it, there are tons of options!
     
  6. godalmighty

    godalmighty Active Member

    i think something very wrong with your firmware, maybe you can try to flash it from the begining using .img file version 1.4.12
    and then slowly but sure try to update it one by one, not by jumping through the last version :p
    never used this feature, but i will try it
    i have HDready tv to try, surely its non HDR
    report back to you soon
    what you mean by "not kicking in"
    my tv is LG 55UH650 that already support HDR, when a HDR content play, my tv automatically change the picture mode to HDR
    but ok i will try using other box to play SDR version from the same movie i have, so i can compare it
    report to you later
    if your TV support trueHD & DTSMA, you can use that HDMI ARC to passthrough the sound from ziddo to AVR
     
    Last edited: Aug 8, 2018
  7. 3DBuff

    3DBuff Active Member

    Splitter for HDMI may or may not work correctly for splitting the signal between TV and receiver.
    Typically it is not a simple port repeater or Y splitter. It has electronic chip trying to adapt the source signal to 2 or more clients. It will take the lowest compatible settings between the 2 devices and send those ID tags to Zidoo. In your case it would probably take the stereo audio from TV and HD resolution from the receiver and send it to Zidoo as compatible standard between the 2.

    I have something similar set up on my 3D HD projector where I use HDMI matrix 4 in, 2 out switch to connect various sources to projector and parallel 7.1 HDMI audio extractor. The reason for this set up is to avoid unnecessary hoops on HDMI cable where 7.1 extractor is not always used. HDMI matrix switch also has SPDIF 5.1 and analog stereo outputs.
    It works but with some tweaks and additional configuration on Raspberry Pi. First off all in order for the projector and RPi to synchronize on all vidoe modes from projector and audio modes from extractor those devices need to be powered up in certain sequence. If RPi is rebooted for any reason I would loose the correct configuration and end up shutting everything down and starting it up again in sequence. It's much better now after some work where I can force correct video modes using EDID tags captured into a file from projector HDMI port and forcing specific audio configuration in Kodi on RPi.
     
    Last edited: Aug 8, 2018
  8. I already tried everything before you can suggest and I'm here because I don't find any solutions.
     
  9. kairi033

    kairi033 New Member

    Normally when I play HDR content the TV pops up a HDR10 indicator but now it does not indicate anymore, I even checked the video information on the TV but it only shows 2610P and 23.976FPS.
     
  10. godalmighty

    godalmighty Active Member

    sorry man, with kodi sample trueHD/Atmos audio 5.1/7.1ch in my box downmix got no sound too
    but when i play a movie that have 7.1ch Atmos sound, downmix work fine, my files is bluray untouched (.iso/.bdmv) and the bluray menu work well too
    at the other hand, i tried Dolby Atmos Demonstration Disc 2014 1080p Blu-ray AVC TrueHD 7.1 Atmos, downmix and bluray menu wont work
    https://rarbg.to/torrent/f75xvzl
    that make me wonder, why its only have problem with sample video/demo
    i hope someone with experience more can explain it why :(
    oh i see, just for that i can answer it work fine with my box
    last time when i played Deadpool 4k HDR bluray untouched, my tv pop up HDR icon
    and i dont think its a cable problem too, coz i`ve tested before with HDMI1.4 and it can transfer HDR too but with some color degraded but my tv still pop up a HDR icon
     
  11. kairi033

    kairi033 New Member

    Ok thank you for your input, anyway I'm already tired of finding a way to solve this, I'm just going to use whatever is working and maybe I can solve the problem accidentally (It always happen on that way).
     
  12. JohnS

    JohnS Member

    Thanks for the heads up!i think the best way to connect your media player (zidoo for example) is with HDMI to AVR and HDMI from AVR to Tv, correct me if i'm wrong.
     
  13. Yeap the dolby atmos demo disc wont work, if possible try this and see https://torrents.me/s/dts+demo+disc+17:btdb
    The menu is not working for this and all the DTS Demo Disc that i have tested but i tried with the FW v1.5.0 it works fine.
    Now im not worried about the TrueHD because all of you guy's seems to have the same problem so Zidoo @mirror have to find a solution for this.

    By the way @godalmighty can you please provide me a link to the movie that the Menu and Audio works well. I just want to try and see.
     
    Last edited: Aug 9, 2018
  14. godalmighty

    godalmighty Active Member

    this is what i promised you to try
    HDR icon pop up when a HDR content play in my LG TV

    depend on what you wanna play and your avr support
    i have 4k tv but my avr is old Denon 1905 that only have RCA input for video
    next step, upgrading my AVR :(
    ok i try it later
    something strange happen when i try play HDR content through non HDR TV just like i promised you, the PQ is standard SDR
    but suprising me the downmix HDaudio wont work even the Dolby Digital 2ch wont sound :(

    my panasonic tv is only HDready tv but i`m pretty sure that it support dolby digital sound, cos usually i used it with other android box that play AC-3 sound

    yes all of us maybe have the same problem with trueHD/Atmos audio from the sample/demo video but not with the movie video
    from the movie i`ve tried, The Dark Knight, Deadpool and Wonder Woman, all work fine with Downmix HD audio 5.1ch
     
  15. kairi033

    kairi033 New Member

    Thank you very much. Let's see what I can do.
     
  16. 3DBuff

    3DBuff Active Member

    It works with TrueHD/Atmos when DD/AC3 5.1 audio track is imbedded in source ThrueHD stream. You can see it in sample files. Some of them will tell you that you are listening to supplementary truck and ask to use proper equipment for ThrueHD.
     
  17. 3DBuff

    3DBuff Active Member

    Thrue under the condition that the receiver has 4K video pass through and all the latest standards in audio with HDMI ports. My receiver is high end from 20 years ago;) The days of DVD disks. It’s high current 7.1 channels and no HDMI ports. With a bit of tweaking I got 7.1 working like a charm:)
     
  18. I have tried with the movie you have listed (The Dark Night, Deadpool and Wonder Woman), and i dont receive any output in both HDMI and SPDIF. I guess Zidoo @mirror
    should focus on this.
     
  19. godalmighty

    godalmighty Active Member

    this one that i try from kodi sample, i think it have DD/AC-3 embedded and the downmix still not work :( and yes they have supplementary track with AC-3 codec that i can choose
    Code:
    General
    ID                          : 1 (0x1)
    Complete name               : E:\MOVIES CLIP TEST\4K\dolby-audiosphere-lossless-(www.demolandia.net).m2ts
    Format                      : BDAV
    Format/Info                 : Blu-ray Video
    File size                   : 142 MiB
    Duration                    : 1 min 1 s
    Overall bit rate mode       : Variable
    Overall bit rate            : 19.5 Mb/s
    Maximum Overall bit rate    : 35.5 Mb/s
    
    Video
    ID                          : 4113 (0x1011)
    Menu ID                     : 1 (0x1)
    Format                      : AVC
    Format/Info                 : Advanced Video Codec
    Format profile              : High@L4.1
    Format settings             : CABAC / 4 Ref Frames
    Format settings, CABAC      : Yes
    Format settings, ReFrames   : 4 frames
    Codec ID                    : 27
    Duration                    : 1 min 1 s
    Bit rate mode               : Variable
    Bit rate                    : 17.5 Mb/s
    Maximum bit rate            : 40.0 Mb/s
    Width                       : 1 920 pixels
    Height                      : 1 080 pixels
    Display aspect ratio        : 16:9
    Frame rate                  : 24.000 FPS
    Color space                 : YUV
    Chroma subsampling          : 4:2:0
    Bit depth                   : 8 bits
    Scan type                   : Progressive
    Bits/(Pixel*Frame)          : 0.351
    Stream size                 : 127 MiB (89%)
    
    Audio #1
    ID                          : 4352 (0x1100)
    Menu ID                     : 1 (0x1)
    Format                      : TrueHD / AC-3
    Format profile              : TrueHD+Atmos / TrueHD / AC-3
    Muxing mode                 : Stream extension
    Codec ID                    : 131
    Duration                    : 1 min 1 s
    Bit rate mode               : Variable / Constant
    Bit rate                    : 640 kb/s
    Maximum bit rate            : 7 800 kb/s
    Channel(s)                  : 8 channels / 6 channels
    Channel positions           : Front: L C R, Side: L R, Back: L R, LFE / Front: L C R, Side: L R, LFE
    Sampling rate               : 48.0 kHz
    Frame rate                  : 31.250 FPS (1536 SPF)
    Bit depth                   : 16 bits
    Stream size                 : 4.66 MiB (3%)
    Service kind                : Complete Main
    Number of dynamic objects   : 15
    Bed channel count           : 1 channel
    Bed channel configuration   : LFE
    
    Audio #2
    ID                          : 4353 (0x1101)
    Menu ID                     : 1 (0x1)
    Format                      : AC-3
    Format/Info                 : Audio Coding 3
    Commercial name             : Dolby Digital
    Muxing mode                 : Stream extension
    Codec ID                    : 132
    Duration                    : 1 min 1 s
    Bit rate mode               : Constant
    Bit rate                    : 640 kb/s
    Channel(s)                  : 6 channels
    Channel positions           : Front: L C R, Side: L R, LFE
    Sampling rate               : 48.0 kHz
    Frame rate                  : 31.250 FPS (1536 SPF)
    Compression mode            : Lossy
    Stream size                 : 4.66 MiB (3%)
    Service kind                : Complete Main
    but with the movie i tried, i dont use supllementary track, just used the trueHD/Atmos track to prove that the downmix worked

    at first thats why i thought it was the firmware problem
    but after i tested the box with my HDready TV with the same movie "Deadpool" and it surprised me that the downmix did not work
    so i think maybe it because they downmix it to a higher bitrate that my tv cant handle it even the codec is supported :(
     
  20. JohnG

    JohnG New Member

    I'm a new user and am seeing the "stuttering" that impacts the video signal. After reading most of this long thread, it looks like the problem is not a frame rate conversion issue, but something else. It isn't so bad that I can't use the box, but considering how many complaints there are about this issue you'd think they'd want to fix this. The good news: the picture looks darn good (played back on a 110" 16x9 screen via a JVC DLA-X790 projector).
     
Thread Status:
Not open for further replies.

Share This Page