JellyfinTv Zidoo-Edition support post

Discussion in 'Development' started by andy22, Jun 18, 2022.

Tags:
  1. andy22

    andy22 Active Member

    Last edited: Jul 30, 2022
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Stickied!
     
  3. Sledgehamma

    Sledgehamma Active Member

    Works great so far.
    Resume works and progress gets synced back to Jellyfin Server as expected!

    Would it be possible to display Logo and Movie name (not file name) like HT does it when loading the video?
     
  4. andy22

    andy22 Active Member

    Not atm, i still use the ZDMC Activity which has no overlay support and i could not get the main MovieActivity working, which is used by HT.
    If i try use the main MovieActivity i get a crash on a smbmount call, so HT does some extra stuff before handing over to the internal player.
    Need to more reverse engineer whats going on, before i can try use the player like HT does, which would than support handing over those extra overlays.
     
    Sledgehamma likes this.
  5. nc88keyz

    nc88keyz Active Member

  6. Sledgehamma

    Sledgehamma Active Member

    Working just fine with ich777’s Docker on unRaid for me.
    Did you set up this:
     
  7. nc88keyz

    nc88keyz Active Member

    apparently not:

    Just to be clear, you still have to identify the volume on the docker, its the field underneath that correct? says you have to do it like \\192.168.1.x\mediafolder but nothing about nfs. I dont think i can just add it . Its getting an attemptto send to zidoo player and failing.says cannot play. I deleted the library and am attempting to set up with the following above which is in my error screenshot as well?

    hopefully i am doing it right.
     
  8. Sledgehamma

    Sledgehamma Active Member

    I didn’t change any Docker settings for this to work.

    My Docker has its own IP: 192.168.178.3 while my NAS has 192.168.178.57 and share like “Movies”
    So inside Jellyfin I set the “shared network folder” of my Movies library to the IP of my NAS:
    smb://user.pw@192.168.178.57/Movies

    Most likely your Docker has the same IP, though. I’ll have a look at the official Docker and look for differences.
    I hope this helps.
     
  9. nc88keyz

    nc88keyz Active Member

    Not working either, Yes Docker and media has same IP, Just rebooted, Love trailers ( digitalsignagemode) on start up. I have a docker pulling new trailers every day as they are released. Pretty cool.
    Anyways, Gonna try again on report.

    Are you mapping the volume for your media share in my case its nfs://ip/hdtv for "shows" but I have the folder mapped in volumes under "hdtv" in the docker as I have always done with dockers.
     
  10. Sledgehamma

    Sledgehamma Active Member

    Can you try SMB just to see if that works. Maybe the issue is with nfs?
    These are my mappings inside the Docker, not really relevant for this from what I see:
    [​IMG]
    /mnt/user/XXX is where the unRaid shares are

    @andy22: Can the app be displayed in 2160p?
     
  11. nc88keyz

    nc88keyz Active Member

    5
    I have installed the docker version you mentioned. Same result. Works fine with zdmc to zidoo player . but this is not working. I am on a ds3615xs synologyNas No issues with smb "nfs" whatsoever. I prefer nfs actually but tried both. Nothing but that message. and says error cannot play video. It is transfering it to the zidoo player for what its worth, just unable to play back file. period.
     
  12. mattmarsden

    mattmarsden Active Member

    Awesome, looking forward to trying this
     
  13. nc88keyz

    nc88keyz Active Member

    An update: I turned off: I experimented developer / playback options on client beta and found out the following: I could went in and turned off pass direct "path for external player" and experimented with preferred media player, trying Video Player ( zidoo player) vlp and one other. then tried always choose, and selected external app, got error. With direct path off, its working with smb or nfs. With pass direct path on it works with smb but not nfs for some reason I switched from the official jellyfin to the ich777 version and now it is running on the docker host ip vs the nas actual ip. I doubt that is the issue though. The first time i went in and it asked me to use Video Player which i recognized as the zidoo player by the OSD and options. I guess the log might show more at this point. i am not sure why the nfs does not work correctly with default install settings on the pkg. It does for everything else from oppo, to atv, to shield, to zidoo, and even windows using other winnfsd i think but I am actually not using that at the moment.

    i can test some things if you like but that is what I have tried. i actually just started messing around with jellyfin a week or so ago so its a little different than my kodi/xbmc/xbmp roots.
     
  14. Very excited to see the inclusion of Jellyfin!
    At the moment, though, I am unable to connect to, or even see my Jellyfin server (Synology package).

    Jellyfin does not auto-discover any servers on my local network, & if I manually enter the server address I get the following error message:

    Unable to connect to server, tried the following addresses:
    https://192.168.0.103:8096 - SSL handshake failed
    http://192.168.0.103:8096 - Server uses version 10.7.7 which is not supported


    Despite this, I can see the Z9X from the server dashboard as an 'active device'.

    I have successfully connected to my Jellyfin server from the Z9X in the past using the officially Jellyfin app, so I'm guessing that I'm missing something relatively simple.
    Can someone point me in the right direction?
     
  15. andy22

    andy22 Active Member

    Woopsy, should have mentioned Nfs is untested. I did not yet setup a NFS test case, to verify if its working. Will add this on my todo list!

    Mhh the app is tested against the latest 10.8 server, in theory 10.7 should also work, so no idea whats going on there. Need to test this case and check why it exactly fails.

    I also noticed that the server discovery is not working on my versions, compared to the official, yet manually entering the server ip/name works.
    Need to check why this happens only on my version.

    Its beta1 for a reason :p

    Just to clarify, if you disable "Direct Path" and than manually select the "Zidoo player" as external player, will use the zidoo player in HTTP stream mode, which will somewhat work, but you get no playback/resume/watched handling. The app will just hand the stream to the player and than is hands-off. This is not the currently recommend way on Zidoo devices and i will enable this option if it gets more stable and works as expected. So if you force this manually be aware of the limitations.
     
  16. Well, whatever the case may be, I do appreciate that it's a Beta version, & I'm sure I'm not alone when I say that I appreciate people like yourself who generously give their time & expertise working on things like this to improve the end user's experience. Thank you so much :):)

    Edit:
    Upgraded to server version 10.8.0 & have successfully connected, but I'm getting the same "Zidoo player failed' that nc88keyz is getting.
     
    Last edited: Jun 19, 2022
  17. nc88keyz

    nc88keyz Active Member


    I got that error with 10.7.7 as well. Says database not supported. Pulled latest build and not only connected but saw it automatically. Only had to log in once updated. That can solve one of your issues.
     
  18. nc88keyz

    nc88keyz Active Member

    Turn off direct play and send to external app in settings / playback . This works and survives a reboot as well on nfs. but not with direct mode or whatever it is called.It still goes to VideoPlayer ( Zidoo Player) just not direct, as long as you set to external app. That is what I did to fix it. I had never used the server address. just mapped the media volumes through the docker on synology ( just as many other dockers with shared success) It does seem snappier with those nfs server addresses filled out just under the mapped volumes that were set up in docker config. Hope this helps those struggling get it going on synology anyways
     
  19. andy22

    andy22 Active Member

    Just to confirm, you have "Direct Path" disabled and "use External" player enabled, than on play you get a dialog to pick a player?
    Are you getting a real nfs file or just the http stream?

    PS: Its been a while since i used nfs, can someone provide me with a quick demo/guide that i can setup in the windows debian wsl for testing?
     
    Last edited: Jun 19, 2022
  20. Well, I didn't, but I do now!
    Got it working now, thanks.
    Looks promising...
     

Share This Page