JellyfinTv Zidoo-Edition support post

Discussion in 'Development' started by andy22, Jun 18, 2022.

Tags:
  1. andy22

    andy22 Active Member

  2. Cyclone99

    Cyclone99 New Member

    Still not working for me, even with the new syntax. When I press play, it goes right to the 'Zidoo Player Failed' screen, without even displaying the Zidoo player screen that says 'Can't Play Video' at the bottom.
     
  3. nc88keyz

    nc88keyz Active Member

  4. nc88keyz

    nc88keyz Active Member

    I confirm the same, I tried serveral variations on the syntax and got nothing. exiting out of jellyfin each time to make sure it was registering the change. SMB still works ;)
     
  5. andy22

    andy22 Active Member

    ok can i get a screenshot/settings of your library path settings from the Jellyfin server, than your nfs export file and a linux cmd line where you successfully mount this share manually to something.

    Example:
    Server library setting:
    • Folder "E:\test\lala"
    • Shared Network Folder "nfs://192.168.1.101/e/test/lala/:"
    Linux NFS Export:
    Code:
    /e/test/lala
    Linux mount test:
    Code:
    sudo mount -t nfs -o vers=3,nolock 192.168.1.101:/e/test/lala /home/andy/nfs_test

    Just need to check what i miss here, since i tested several combinations and all worked for me.
     
  6. Cyclone99

    Cyclone99 New Member

    Jellyfin server setting:
    Folder: /mnt/vol2/tv
    Shared network folder: nfs://192.168.1.57/srv/nfs/vol2/tv:

    From /etc/fstab, /mnt/vol2 is bind mounted to /srv/nfs/vol2:
    Code:
    /mnt/vol2       /srv/nfs/vol2                   none    bind  0 0
    From /etc/exports, (the Z9X is at 192.168.1.24):
    Code:
    /srv/nfs/vol2   192.168.1.24(rw,all_squash,insecure,anonuid=1000,anongid=1000)
    Successful mount command from another device (odroid n2 running coreelec):
    Code:
    mount -t nfs -o vers=3,nolock 192.168.1.57:/srv/nfs/vol2/tv /storage/mount
    I've tried other syntax variations for the Shared network folder in Jellyfin. Streaming on the Z9X over nfs is working with HT4 and ZDMC.
     
  7. andy22

    andy22 Active Member

    Is this a typo?
    This should be
    Code:
    nfs://192.168.1.57/srv/nfs/vol2/tv/:
    Tobe honest i pulled the "/:" marker out of my... since i need to separate the nfs root/export base path from the subpaths, so i thought just using "/:" is a good idea.
    I could use whatever marker i want, but should be a symbol that cant exist in a normal folder, filename. So my idea was to construct a virtual "/:" folder ":", since that can't be part of a filename and is also never used as a normal folder.
     
    Last edited: Jun 21, 2022
  8. Cyclone99

    Cyclone99 New Member

    I had tried it both ways, I just set it to nfs://192.168.1.57/srv/nfs/vol2/tv/: and tried again to make sure, and it still doesn't work.
     
  9. andy22

    andy22 Active Member

    Can you try with a full reboot of the zidoo, just to make sure, thx.

    I think i see the issue here, the export is this:
    /srv/nfs/vol2

    Yet we hand this as nfs root to the mount logic via the "/:" marker
    /srv/nfs/vol2/tv
    Yet this nfs export path does not exist, so it fails.

    So if you add a export for "/srv/nfs/vol2/tv" it should work.

    This should also work by marking just the nfs export portion.
    Code:
    nfs://192.168.1.57/srv/nfs/vol2/:/tv
    So the "/:" marker needs to-be inserted right after the actual nfs export path which is /srv/nfs/vol2.
    I know a bit hard to understand, need to think how to make this more clear or fail proof it.

    I think i could just try my way up the subpaths until the player accepts one...which is a bit hackish.
    Otherwise i would need to probe for valid nfs paths beforehand myself, which i try to avoid.
     
    Last edited: Jun 21, 2022
  10. Cyclone99

    Cyclone99 New Member

    Yes, that works:
    Code:
    nfs://192.168.1.57/srv/nfs/vol2/:/tv
    So the shared folder should be nfs://ip_addr/nfs_export_name/:/path_to_folder
     
    Last edited: Jun 21, 2022
  11. nc88keyz

    nc88keyz Active Member

    Sorry this is over my head, I know enough to map nfs shares on my nas via DSM with synology, and I know how to set it up from Kodi, ATV, Oppo203, and Shield, and Windows. I have no idea what any of the above language is except that my guess it is handled by linux of which DSM powered by linux runs on. I use NFS because its simple and effective for me. I will have to wait for the superheros to debug this going forward.
     
  12. andy22

    andy22 Active Member

    Whats setup on your synology for nfs and what have you setup in Jellyfin server for your shows library path?
    With this i can give you the Network path settings, so maybe after you see it, it will click.
     
  13. OK, so I'm happy to admit that I'm reasonably clueless when it comes to networking. I've tried practically every SMB & NFS path variant listed above for mapping the direct media path in Jellyfin & the only way I could direct-play files (using Beta #3) was to list my movie media path exactly as follows: 192.168.0.103/Movies/Movies. Any change to this resulted in the 'Failed to play' error.
    I initially thought this meant I was accessing via SMB but at no point have I been asked to enter a username or password. So, am I in fact connecting via NFS? (Either way, it's working, so I'm a happy chappie).
     
  14. andy22

    andy22 Active Member


    Thats a weird syntax: 192.168.0.103/Movies/Movies

    What happens is that without any "smb://" or "nfs://" in the Jellyfin Server Network paths options, with DirectPath enabled, the logic will assume smb and add a "smb://" in the front, than without a username/password the logic assumes "Guest" access and send username "Guest".

    So your "192.168.0.103/Movies/Movies" will be converted to "smb://Guest@192.168.0.103/Movies/Movies", yet no clue why there are two Movies paths?


    PS: I mean you should know if you have setup smb or nfs shares somehow in windows/linux or you NAS?
     
  15. Well, for reasons I won't waste time explaining, the first Movies folder contains several sub-folders including another Movies sub-folder, which in turn contains additional genre sub-folders :D. My TV library is similar (TV/TV/Ended & TV/TV/Continuing).
    Well, I do have all the SMB & NFS permissions enabled on the NAS, though I gave up on SMB a long time ago as I liked the convenience of not having to enter user names & passwords to access my media. Much easier to just add individual IP's to an NFS shared folder white list.
     
  16. nc88keyz

    nc88keyz Active Member

    This for me as well. In Synology i map all users to guest ,

    So it goes like this

    See attached:

    the mount is /volume1/4K as you can see in the bottom left corner in DSM.
    * is all ip addresses
    mapped to guest
    the other options are all yes or allowed as you can see.
    If there is a command in terminal that you think i can issue to get you more info , i am comfortable doing that as well, but i am not sure the above ones worked.

    Here is my collection of real world working nfs shares working across the ATV/Nvidia Shield/Zidoo using a variety of apps and examples. This should help you tremendously in my opinion but I am not a coder. Again, I know just enough to be dangerous.

    Windows (Smb) Windows 10/11
    smb://user: pswd@192.168.1.24/4K/movie.mkv (ignore space between U/P to prevent emogi)

    Kodi (sources.xml) on Shield TV under .userdata
    nfs://192.168.1.24/volume1/4K/movie.mkv

    Kodi (myvideos119.db) (Path Table) ( also referencing volume1/)
    nfs://192.168.1.24/volume1/4K/

    Zidoo Posterwall GUI path
    nfs://192.168.1.24/4K/movie.mkv

    Zidoo (Theater.db) (Sources Table) ( Notice the syntax after the common syntax from Kodi)
    nfs://192.168.1.24/4K?ip=192.168.1.24&share=/volume1/4K

    Zidoo (Theater.db)(Video_Info Table) ( Media JSON) Tab

    .MKV/.MP4 files
    /mnt/nfs/192.168.1.24#4K/The Adam Project (2022)/The Adam Project (2022).mkv

    BDMV Folder
    \/mnt\/nfs\/192.168.1.24#4KHEVC\/Zombieland (2009)(UHD)(HDR10)(TrueHD Atmos 7.1)

    .ISO Files
    \/mnt\/image\/temp

    SS: NFS maps on DSM ( Synology/Xpenology)
    https://www.dropbox.com/s/04aedbqej8o2v1f/nfsscreengrab.jpg?dl=0

    SS: Sources Syntax on Theater.db
    https://www.dropbox.com/s/rp17arf3phuiwwm/ScreenShot_20220621132754.jpeg?dl=0


    The funny thing is , one of these likely works. After ($1 Hard Shell Tacos) for lunch I will take a look when I return to the helm. I know, I cannot believe they still exist in the world today with inflation. $1 and includes all you can eat salsa / chips. Been that way for 15 some years! Beach Perks!


    Tried all those variations and even some other possibilities.
    No Success
     
    Last edited: Jun 21, 2022
  17. Cyclone99

    Cyclone99 New Member

    Try:
    nfs://192.168.1.24/volume1/:/4K/
    or:
    nfs://192.168.1.24/volume1/4K/:
    for the shared network folder in Jellyfin.
     
  18. nc88keyz

    nc88keyz Active Member

    negative ghostwriter
    No action from those two syntax.

    Forgive me for asking but why doesn't jellyfiin have an nfs discovery like everything else. Crazy if you ask me. If this is a fork of sorts what in the world would break this fairly simple form of serving files from a Linux box. ??


    I stand corrected: SUCCESS! (Can this be made simpler now that we know the path that it is requesting?)

    Anyways, I can confirm with the following that NFS "Direct Play" is working with zidooplayer:
    on Andy22's Beta3

    Here is my proof below:

    Zidoo Video Info
    https://www.dropbox.com/s/idu1f2lafw6w3eb/ss.ndsvideoinfo.zidooplayer1.jpg?dl=0
    ss.ndsvideoinfo.zidooplayer1.jpg

    Zidoo Pause ( OK Button while playing if selected)
    https://www.dropbox.com/s/74toy8jeu1rlvqx/ss.ndsvideoinfo.zidooplayer2.jpg?dl=0
    ss.ndsvideoinfo.zidooplayer2.jpg

    Jellyfin Media config
    https://www.dropbox.com/s/b2d0r5tsdfgvbpl/ss.nfs.jellyfin.folderpaths1.jpg?dl=0
    ss.nfs.jellyfin.folderpaths1.jpg

    What can we do now with this fantastic info Cyclone99 and Andy22n? Another Beta ;) For those following along loosely, /HD /BD/ are the folders mounted as volumes to the docker that Jellyfin is running inside of on the NAS ( A Synology NAS in this case)
     
    Last edited: Jun 21, 2022
  19. andy22

    andy22 Active Member

    Let me explain the main issue and difference between smb/nfs for DirectPath.
    First off by default the Jellyfin client only sees the fully assembled and replaced Uri path, which looks like this in your case:
    Code:
    nfs://192.168.1.24/volume1/hd/Shows/Halo (2022) [tvdbid-366524]/Season 01/Halo (2022) - S01E01.mkv
    smb://andy:123456@192.168.1.24/volume1/hd/Shows/Halo (2022) [tvdbid-366524]/Season 01/Halo (2022) - S01E01.mkv
    
    So now we need to actually mount something, which is easy in the smb case, since the first part after the server host part is always the smb sharename, which is "volume1" for smb.
    Now for nfs, the export could be any part of "/volume1/hd/Shows/Halo (2022) [tvdbid-366524]/Season 01/" so how do we find the actual export portion?
    Well in beta3 we do this by marking it with "/:", so we get: "/volume1/hd/:/Shows/Halo (2022) [tvdbid-366524]/Season 01/" now we can check for this marker and extract the nfs mount path: "/volume1/hd".

    So yes a other way to solve this would be to allow the client to fetch the actual settings value of the path substitution from the library admin settings, yet a other would be to probe each path segment until one succeeds. So starting with "volume1", than "volume1/hd" than "volume1/hd/Shows" and so on.

    I hope this explains what currently goes on with nfs, DirectPath.
     
    Last edited: Jun 21, 2022
  20. nc88keyz

    nc88keyz Active Member

    I mean if it is working that is fine, i am not sure you can or will change it in future betas but if all i had to do was learn something minor that was new to what I already know, its not a huge deal in perspective to all the other bulshit in the world today. I have already changed the the paths in the jellyfin admin and they all work just like poster now via nfs. i included as many strings as I knew how to pull from posterwall, kodi and synology to help you debug. Maybe it was helpful , maybe not so helpful. I also include screengrabs of what is in those databases and synology DSM as well. i am sure there will be more betas forthcoming and I enjoy helping out where I can.
     

Share This Page