X9S HOW TO FLASH ZIDOO X9S UNIT

Discussion in 'ZIDOO X9S' started by HoneCharles, Oct 8, 2016.

  1. tomas80

    tomas80 New Member

    Hello Donny and THX for your reactivity

    I've also tried with putty (with VT100 settings for keyboard) but no realtek or u-boot prompt ...

    To be sure with ESC key procedure :
    1) launch putty
    2) select connection (in my case com3)
    3) ush and keep ESC key pressed
    4) power on my Zidoo Box and wait 3 sec
    5) stop keeping pressed ESC key

    but I'm not able to
    1) push and keep ESC key pressed
    2) launch putty
    3) select connection (in my case com3)
    => impossible because of ESC key pressed and putty window desappear ...


    I can also get the SPI prompt with CTRL Q (but no U-Boot prompt with Esc)
    I think I have to reflash the bootloader .... but no precise idea how

    With SPI pompt I have minimal command (but not a fully doc)
    H : download hw settings
    D : download file
    R : enter words
    G : for GO ?
    P : to read memory at defined address
    S : to write memory at defined address
    J : to jump at specidied address
    ....

    Loading HW settings works good (from bootloader.tar in install.img firmware version 1.2.3)
    But after I don't know :
    - the necessary files to be loaded for bootloader and u-boot
    - to flash again
    Is there any tests from SPI to verify if CPU rtd1295 and eemc are still alive ?
    The USB ports seem not be powered (no led if I plug a USB stick) ....
     
    Last edited: Nov 28, 2018
  2. slavensiz

    slavensiz New Member

    Perhaps you need to do it in Windows. 5.Disable for a while: Control Panel \ All Control Panel Items \ User Accounts \ Change Account Control Settings \
    The slider in the bottom (Never notify) is saved. http://forum.zidoo.tv/index.php?threads/how-to-flash-zidoo-x9s-unit.2959/page-8#post-38299
     
  3. slavensiz

    slavensiz New Member

    It will turn on only after successful loading in U-That's the whole procedure of actions, and the last command "goru".
     
  4. tomas80

    tomas80 New Member

    @slavensiz
    Thank-you for your answer

    I'm using Windows 7, I have a labtop with a french azerty keyboard.
    I've also done the modification with control panel (with no effect, the putty window close itself) but maybe due to french keyboard, the ESC key is not the good one ?

    What was your terminal settings for the keyboard in putty ?
    You also mean that we should keep Esc key pressed before launching putty (or extra putty) ?
    => To be sure the Esc caracter will be send at first to serial port ? and not after having launched putty ?
    => I can also try to verify ESC caracter send with a SSH session to another computer

    I'm afraid I have to reflash the bootloader from SPI .... according to banana pi procedure with hyperterminal ...
     
    Last edited: Nov 28, 2018
  5. tomas80

    tomas80 New Member

    I've done oher tests with the ESC sequence on another zidoo box and I succeed in getting realtek prompt

    So I conclude the bootloaer and U-Boot are broken on my broken zidoo X9S
    The only way is probably to reload and re-flash the bootloader and U-Boot from SPI prompt

    Is there anybody to help me ?
     
  6. tomas80

    tomas80 New Member

    The log stop there
    Goto FSBL: 0x10100000

    And after nothing, even with ESC sequence
    So it is as if the boot sequence was pointing to a broken FSBL

    2 possibles explanations :
    - CPU is definitevely dead ...
    - Boot loader (FSBL) and U-Boot are not correctly flashed

    With Bananapi WS2 (with RTD1296 CPU) they know how to flash from SPI prompt
    http://forum.banana-pi.org/t/bpi-w2...rt-with-linux-kernel-4-4-2018-4-25/5510?u=boe
    => See the Method B with Hyperterminal

    B. Use hypertrm burn uboot on W2:
    1)You need these files and tool:
    hypertrm
    • RTD1296_hwsetting_BOOT_4DDR4_4Gb_s1866_padding.bin(hardware configuration binary file)
    • dvrboot.exe.bin(u-boot binary file)
    2)Connect W2 debug console to windows PC:
    • Run hypertrm ,config console parameters right
    • Holding on press “ctrl + q” and power on board,after the screen show “d/g/r”,then loose “ctrl + q”
    • Input “h”,use Y-modem way to send “RTD1296_hwsetting_BOOT_4DDR4_4Gb_s1866_padding.bin” to W2 board
    • After finish transferred,input these parameters:
      s98007058
      01500000
    • Input “d”,and send u-boot binary file
    • after finish transferred,input “g” to burn u-boot file on W2 EMMC
    Maybe somebody know on this forum howto for RTD1295 zidoo box ?
    For the HWsetting file, I took the file from bootloader.tar and it works
    But after to load the bin files with address and offset and start flashing for Zidoo I don't know ...
     
    Last edited: Nov 29, 2018
  7. videobruce

    videobruce Member

    Where is there the ROM file for a X10?
     
  8. litlgi74

    litlgi74 Member

    Thank you... Worked perfectly!
     
  9. Apofisao

    Apofisao New Member

    @slavensiz
    Thank's for your job, also my zidoo x9s has been repaired.
     
  10. darkanbil

    darkanbil New Member

    Hi,
    is there any workaround regarding newest console procedure? about no goru command thing.
    my box is still dead.. waiting..
     
  11. Gedeon

    Gedeon Member

    I had to return my box and finally got a refund. If Zidoo hasn't fixed it (or given any help) in last 3 months no reasons to expect them to fix it in next weeks.
     
  12. RuBob

    RuBob New Member

    I also returned my box to the seller for repair or replacement. Unfortunately, it was not possible to restore it yourself.
     
  13. darkanbil

    darkanbil New Member

    So my x9s gonna have going back inside original box & waiting for solution.Cost too much to send it back to Zidoo..

    For now.. my old Himedia HD900B is getting his job back :D ..This box has served me well over many years ago.. and still strong.. no problem with dolby atmos/dts:x passthru.. except 4k playback.
     
  14. Gedeon

    Gedeon Member

    Zidoo won't never release a software solution for your box. Bricked boxes at that stage can only be repaired by them. They won't allow final users to use the special software/hardware tools to fix it.

    I think it's better you assume that sad reality sooner than later.
     
  15. darkanbil

    darkanbil New Member

    What a shame you Zidoo.. for me this fault is from their side.. they never mention that box come with 2.1.1 cannot be downgrade..
    Because ver2.1.19 is too buggy.. i try to try to downgrade to test it.. but this happend..
    They supposed to make a warning & put a big red sign about this.
     
  16. slavensiz

    slavensiz New Member

    Apparently, the processors have different instructions and you do not have this command "goru", you can do according to another instruction how they restore the routers.
     

    Attached Files:

    • my.png
      my.png
      File size:
      6 KB
      Views:
      21
    • your.png
      your.png
      File size:
      4.5 KB
      Views:
      19
    Last edited: Feb 4, 2019
  17. slavensiz

    slavensiz New Member

    Zidoo has the right to change the firmware, because it is opened and put on other devices, firmware costs money, but in this case they screwed up. There must be some kind of warning for you with firmware 2.1.1
     
    Last edited: Jan 11, 2019
  18. darkanbil

    darkanbil New Member

    I'm sorry, but i'm not understand that language.Also cannot clearly on video (too small to see).

    Can someone make a step by step instruction?..required software,command,etc..

    BTW, thank you very much for this, seem there is a chance to give my x9s a life again.
     
  19. slavensiz

    slavensiz New Member

    [QUOTE = "darkanbil, сообщение: 82791, участник: 29085"]
    Can someone make a step by step instruction?..required software,command,etc....
    [/ QUOTE]
    You must create this instruction, by trial and error, who has such a device, I do not have it. I have just given you a direction, but it may be wrong.
     
    Last edited: Jan 11, 2019
  20. Carlos Lorenzo Diaz

    Carlos Lorenzo Diaz New Member

    The tutorial uses version v1.4.12, to restore, Is it possible to update with the latest firmware version (v2.0.34)?

    Do you also have to install the latest version of the internal player (with kodi 17)? or is it included in the firmware?
     

Share This Page