X9S HOW TO FLASH ZIDOO X9S UNIT

Discussion in 'ZIDOO X9S' started by HoneCharles, Oct 8, 2016.

  1. zero33

    zero33 Member

    Gedeon,

    What version firmware was on the box?
    Where did you download from?
    How was it install - ota or img?
    Was the USB port working before this?

    Are we facing another malicious firmware designed to kill our boxes?
     
  2. Gedeon

    Gedeon Member

    It was the latest, 2.1.14 beta, but It didn't allow any OTA or usb downgrade to 1.4

    I downloaded the firmware from this fórum, first pages, since I wanted to test 1.4 and 1.5

    The process I triggered was pressing the reset button and pluging in the usb flash. It seemed to finish the flashing process well… I mean, the progress circle showed percentages… then at the reboot not logo, no way to "continue" the process...

    Hence I decided to open the box and try the UART way. But very sadly the Realtek console doesn't load any USB drivers, tools so I didn't find a way to access the flash unit or to load a console with usb support.

    Very disappointed at this point. I play a little with the yload transfering binaries (ymodem protocol) with ExtraPutty, but no luck, and to be honest, not very sure about which procedure I should follow to transfer and load in the Zidoo a recovery console which supports USB to reload the firmware.

    I haven't tried to load any "foreign" firmware, just images from this fórum....
     
    Last edited: Nov 19, 2018
  3. zero33

    zero33 Member

    Have you tried -
    1) use the rescue files img 1.4.12 and the 4 files yet?
    1a) try boot without reset button
    1b) try with reset button.
    Plug usb drive to usb2.0 (not 3.0) format fat32
    Post #93

    For me the 1a worked on 2.1.1
     
    Last edited: Nov 19, 2018
  4. Gedeon

    Gedeon Member

    Yes, I tried all of those. No luck.
     
  5. RuBob

    RuBob New Member

    exactly the same problem. from 2.1.14 to 2.0.15 = brick. In the console of the first loader, there is no command to restore from the usb source. no goru command
     
  6. Gedeon

    Gedeon Member

    So I just need two things:
    - One set of recovery files
    - Clear instructions from Zidoo to load those fikes in memory (using the yload command) and to write them in the MMC (rtkmmc command) or to launch a full recovery from USB.

    As far as I know, a Zidoo firmware developer, should be able to publish that instructions without "violating" copyrights, company secrets or things like that.

    Please, Zidoo, could you be so kind in helping us to recover our boxes to an "usable" state?

    I'm ready to follow them, with care and patience.

    Zidoo, we are beta-testers, please take care of us in this kind of issues. I think we deserve a bit of support. This month of silence is starting to worry me seriously.
     
    Last edited: Nov 19, 2018
  7. zero33

    zero33 Member

  8. zero33

    zero33 Member

    Tony77 and donny,

    Do you still have the putty log during the 2.1.1 rescue when you type help.

    Compare the command.

    My txt was deleted.

    Why is it that the goru command is missing or removed ?

    The dev made changes in firmware or hardware problem or wrong label firmware or different hardware?
     
    Last edited: Nov 19, 2018
  9. slavensiz

    slavensiz New Member

    zero33
    Already many prefix purchased and come came with firmware 2.1.1, these prefixes changed bootloader, when booting through putty, the input occurs in the second bootloader, for this there are no commands like on our consoles.
    My puuty.log
    http://forum.zidoo.tv/index.php?threads/how-to-flash-zidoo-x9s-unit.2959/page-8#post-38299
    puuty.log consoles coming with 2.1.1
    https://drive.google.com/file/d/1orO_t9ht1-4D9QtH1SnM_D6BQYRmMVqa/view?usp=sharing
    https://drive.google.com/file/d/1CYioFT54ZX4SkEJGQsMeMOVcq9REClzN/view?usp=sharing
     
    Last edited: Nov 19, 2018
    колбаскин likes this.
  10. Gedeon

    Gedeon Member

    Thanks to @slavensiz and other members. I'll give it a few more tries using "yload" but I guess my chances are very low unless a Zidoo employee explain us a step by step procedure.

    I hope they will.
     
  11. slavensiz

    slavensiz New Member

    Last edited: Nov 19, 2018
  12. zero33

    zero33 Member

    Much earlier before my repair, they said send back to supplier and supplier will send back to factory.

    Slavensiz, in this case, seems no possibility to downgrade to any old firmware 1.x.x or 2.x.x from the 2.1.14

    Still puzzle is goru command missing.

    Too much said in this forum and someone don’t like users make own repairs.
     
    Last edited: Nov 20, 2018
  13. slavensiz

    slavensiz New Member

    Perhaps you are right, the manufacturer does not want what we could independently restore through the port of Uart. It all started with the deliveries of Zidoo S9X with firmware 2.1.1, before that the prefixes with firmware produced below 2.1.1 were restored much simpler, and there were fewer bricks. it was necessary to write in the instructions in red - for consoles that came with firmware 2.1.1, it is strictly forbidden to lower the firmware, but to wait only for a new one with an increase. In this case, hardly anyone wants to buy such consoles from which you can not choose your favorite firmware. Many already repent that they acquired Zidoo.
     
    3DBuff likes this.
  14. 3DBuff

    3DBuff Active Member

    Yes, I don’t mind waiting for new firmware with better features but we have stutter flaw in recent releases. We should have an easy way to roll it back to any version.
     
  15. Gedeon

    Gedeon Member

    I got a positive answer from geekbuying. I explained them the issue and they sent me instructions to send the box to them in order to be restored (by Zidoo I guess).

    So it will take several weeks but at least I have a chance to get it working.

    Thanks again.
    PD: I think that A BIG warning in the forums should be posted to avoid/reduce chances more users could try to tests other firmwares non shipped with their boxes.
     
  16. slavensiz

    slavensiz New Member

    Of course, the manufacturer of Zidoo should have a utility, like other manufacturers of consoles for recovery, and we are responsible for opening the console and fixing the error through Uart. This is not the owner's mistake, when the console does not work after the firmware, it is the manufacturer’s fault. Personally, I will not lower the firmware now, I do not know what happened to my prefix after firmware 2.1.1, and whether I can restore it a second time in the event of a failure. Now firmware v2.1.14.
     
    Last edited: Nov 21, 2018
    колбаскин likes this.
  17. tomas80

    tomas80 New Member

    Hello
    I m new to the forum
    I have a console using UART port.
    The console print this
    ===================================================
    C1:80000000
    C2
    ?
    C3hswitch frequency to 0x00000046
    frequency divider is 0x00000080
    switch frequency to 0x00000046
    frequency divider is 0x00000004
    switch to SDR 8 bit
    switch bus width to 0x00000008 bits success

    hwsetting size: 00000740
    C4
    f
    5-5
    Goto FSBL: 0x10100000
    ===================================================

    I have the ability to use Ctr Q and access d/g/r menu but i have no ability to access u-boot menu

    Please could u help me ?
     
  18. tomas80

    tomas80 New Member

    I'm using hyperterminal and "Esc" sequence provide no access to U-boot
    => Pressing "Esc" key is supposed to give access to U-boot menu but nothing ...
    => bootloader is broken ?
    => U-boot is broken ?

    Any way, is there a process to re-build/re-flash bootloader or U-boot ?
    I'm trying to use this kind of process (banana pi w2 using rtd 1296 shipset) with no result
    http://forum.banana-pi.org/t/bpi-w2-new-image-burn-openwrt-with-linux-kernel-4-4-2018-4-25/5510

    But I'm not sure to have :
    - the good files (hwsetting.bin and other files ...)
    - the good addresses or offset to "jump" to U-boot

    Is there any guru to show me the way ?
     
    Last edited: Nov 28, 2018
  19. donny

    donny Member

    Hello everyone.In the log of Putty I read, a long explanation(it said to make other things)
    without finding the command Gore (before the failed downgrade I had version 2.1.1). The procedure suggested by Slavenzis N.2 has worked just as well, but after trying the first.
    Now with version 1.4 I detect several bugs.I had tried a reset and I thought I had to repeat everything again.
    I tried the recovery procedure from the usb stick and it started again(the one with four file.)
    I will try to load a more recent version of the firmware.
     
  20. donny

    donny Member

    Tomas ,also for me the command ESC didn't work...I have turned on the box after having started Putty(at that time it has received the log).
     
    Last edited: Nov 28, 2018

Share This Page