X9S HOW TO FLASH ZIDOO X9S UNIT

Discussion in 'ZIDOO X9S' started by HoneCharles, Oct 8, 2016.

  1. slavensiz

    slavensiz New Member

    Last edited: Nov 25, 2018
    donny likes this.
  2. Sarco

    Sarco Active Member Beta test group

    Thank you slavensiz for all the informations!
     
  3. donny

    donny Member

    Thank you very much Slavensiz.
    Thanks for your help Sarco.I'm trying to understand...
     
    Last edited: Sep 11, 2018
  4. slavensiz

    slavensiz New Member

    Good luck
     
  5. zero33

    zero33 Member

    After this method uart/putty recovery, will the special boot loader be restored or we need to do this on every firmware downgrade?

    I loaded a fw 2.1.1 and no longer able to change firmware anymore. Bad firmware from this post:-

    http://forum.zidoo.tv/index.php?threads/fw-2-1-1.10879/
     
  6. Tony77

    Tony77 Member

    SAVED ANOTHER LIFE... before I found this info I was looking for a high window!
     
  7. deusexe

    deusexe New Member

    What if I updateing 1.4.12 -> 1.5.0 via USB and screen "Update the System" has already been 30 minutes and still waiting... Power off and brick?
     
  8. Tony77

    Tony77 Member

    BTW- I've been STUCK on 2.1.1 even AFTER this process.. I can't even UPGRADE to newer firmware (or downgrade, after performing above process it actually still shows as 2.1.1)??? I assume the orig bootloader or something must be corrupt?? idk

    Can anyone help pleeeese???
     
  9. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    You tried the well documented emergency firmware reload? This is using the PIN press combined with a special ROM IMAGE file (install.img).
     
  10. Tony77

    Tony77 Member

    ABSOLUTELY!! YES... the original img.. also the one with the files where u don't even NEED to use PIN (that at least TRIED to flash, went thru process)

    In addition, I even used the NON PIN emergency reload, but with different .img files I extracted out of the upgrades.. something was different about the 2.1.1 firmware..I went thru the files in the image. take a look at attached..these are the config files..one from 2.1.1 and other from 1.2.3.. the 2.1.1 has differences I don't see in ANY other firmwares.. Admittedly, I'm not ANY kind of programmer or coder(in the least!)...im just digging around???
     

    Attached Files:

  11. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    The USB drive should have 1 file only called install.img it never can be used without using the PIN procedure. It is over 1 Gbyte in size and can't be mistaken. If you can you are not following the correct instructions.
     
    Last edited: Oct 7, 2018
  12. zero33

    zero33 Member

    1) OTA update by usb from 2.1.1 to 2.1.12 will cause the box cannot boot.
    The img use without pin (img and 4 files) is to recover non-boot rescue. only by this way will the box boot again to ZUI nicely!

    2) 2.1.12 img update from 2.1.1 to 2.1.12 cannot work also.
    I know to put ONE img file in usb (fat32) and with pin and the special bootloader does NOT run. Its not even reading the USB drive.


    Bad firmware 2.1.1 from Zidoo!!!
     
  13. zero33

    zero33 Member

    Last edited: Oct 8, 2018
  14. Tony77

    Tony77 Member

    YUP!! My EXACT experience.. I notice also it doesn't read usb drive.. I've even downloaded 2.1.12 from the zidoo browser directly to the INTERNAL MEMORY..(fixed file name) Then attempt the update from update option...select FLASH folder or browse to download directory and select zip file.. It checks & loads it 100%, click ok, system auto-reboots, and STUCK at zidoo logo forever...

    I can get it to boot back to 2.1.1 by pressing reset button(not a flash) and turning off and on twice..


    what are we to do?????? the 2.1.1 firmware I received was from a ZIDOO link to update.. wtf?
     
  15. zero33

    zero33 Member

    Planning to try post #142 and #181.
     
  16. zero33

    zero33 Member

    I ordered the uart serial from the Alibaba and performed the advise on #142 and #181

    Install CP210x_Universal_Windows_Driver for windows 10 and Putty

    Using goru, the usb can be read and restored to 1.4.12 img

    Further test to -
    1) Downgraded from 1.4.12 to 1.2.3.img by restore pin. Works !

    2) Upgraded from 1.2.3 to 2.1.14 by ota zip, Works !

    And the zidoo X9S is restored back to normal.

    Thanks you, slavensiz.

    Tony77, you can do the above for your box. With the uart serial, you can play with firmware versions without fear !
     
    Last edited: Oct 26, 2018
    Tony77 likes this.
  17. Tony77

    Tony77 Member

  18. zero33

    zero33 Member

    Yes it’s the same serial adapter. Alibaba cheaper 3x. Shipping took some time.

    You just need to get into putty console. the rest follow the guide.
     
  19. Tony77

    Tony77 Member

    Zero33...
    to be honest, (as I always am), I have no experience even using PUTTY! Yes, I've heard of it, but I've never actually used it or have much experience with Linux either... So the instructions for UART are practically a different language to me! lol..
    But I will try to figure it out.. Just letting you know this is all foreign to me!
     
  20. zero33

    zero33 Member

    Post here if you have problem. Details will be good.
     

Share This Page