Beta version v6.4.40 for Z9X release

Discussion in 'HDD Media player(RTD 1619DR)' started by mirror, Oct 13, 2022.

  1. badboyxx

    badboyxx Member

    Most of my movies are Blu-ray Isos and I recognized that "Seven Worlds - One Planet" (BD-Iso) starts the intro and stops after that with a black screen. The menu does not appear. I think it has something to do with the java-menu. On the pc I can start it without any problems.
    I hope this will be fixed soon.
    serg fedorov likes this.
  2. kovacsgergely83

    kovacsgergely83 New Member

    Hey Guys, excellent work, I can also confirm that DoVi hard clipping at 86 is gone now, below are my own tests with FW 6.4.40 on my Z9X in TV-Led mode on an LG C1 (brightness was jacked up to 80 as I was upgrading in the afternoon).


    Last edited: Oct 17, 2022
  3. Cranks

    Cranks Member

    Just set everything to VS10 is what I am using...very happy with the results!
    ccart likes this.
  4. ccart

    ccart New Member

    how come you use VS10 for DV content though, or even HDR10 content? genuinely curious as I'm fairly new to all this, I just have mine on auto but I can understand VS10 for SDR. The majority of my media is DV and HDR10 and I have it set to use TV led DV.
    xskip and Delfanboy like this.
  5. B0RN

    B0RN Active Member

    Not sure if you follow AVS Forums, but I've had the Z9X for about 3 weeks now and was complaining to everyone there that the PQ was worse than both the Oppo and the Shield Pro. Well people had a very hard time believing me. I didnt have the technical tools to prove anything but it just was a mess in many ways as I was doing long hours of A/B testing. Well thankfully, this new FW dropped before my return window and BOOM! the Z9X is now leaving both devices behind in many ways. All those missing details have come back to life and very much in line with the Oppo, which is still damn close but now I can clearly see even that has some softer details in comparison to the Z9X.

    I do still have one issue though:
    My WD external hard drive runs way too loud and noisier on the Z9X compare to silent operations on the Oppo or the shield pro. It ramps up (almost violently) every time I start or stop a movie, whether I am in the Media Center or the HT4.0 app. Such issues do not exist on other devices whether I am playing or sorting the long list like a maniac. My best guess is this is because the drive is 18TBs and seems to have compatibility issues? Thus, it almost makes me not want to use the Zidoo because its shortening the life of the drive by such rigorous usage. If theres a any way to handle the drive better/make it run smoother, it would be great. I already have the Posters saving to the local storage and not to drives and have auto scanning and updating off in Preferences.
  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Sorry, can't help much with this one - I use network storage and other than the odd USB stick, I've never connected external drives to Zidoos.

    Is this a USB or Sata drive?
  7. kovacsgergely83

    kovacsgergely83 New Member

    (I'm already on FW 6.4.40 on Z9X) is this fine for HDR10?

  8. B0RN

    B0RN Active Member

    This is via USB 3.0 - WD Easy Store external Hard Drive. 18TB may be too big of a library to cache I am thinking.
  9. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    No, that's not the problem - my 4K library is currently about 16TB and I've tested libraries much bigger - it's a SQLite database located on the box itself.

    My feeling is it's something screwy in the way Android is handling the USB port and drive access. Unfortunately I don't have a physical USB drive to test it with..
  10. B0RN

    B0RN Active Member

    For good measure, I have tried other ports, even the 2.0 ones and this large drive does the same thing. I have two more 14TB drives connected and they are silent as a mouse.
  11. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Oh right that's odd...

    @Nice Monkey , any ideas about this?
  12. Oldpainless

    Oldpainless Active Member

    Interesting - did you use custom EDID 600MHz BT2020 HDR10+.bin and set DV and HDR to VS10?

    On my panel, i've gone back and forth with various settings, and the above produces amazing results (read best), but YMMV.
  13. 3DBuff

    3DBuff Well-Known Member

    I have 10TB on SATA port. As violent and continuously starting and stopping as you describe. I'm assuming this is something in Android as Zidoo is reading and flushing the buffers. My 10TB is 7,200 Seagate Barracuda. Very loud bare drive sitting with soft rubber legs on X9Z box. Your 14TB drives are probably doing the same thing starting and stopping but those are probably energy efficient slow green drives and quiet as a mouse ;)
  14. B0RN

    B0RN Active Member

    Even sorting the list just makes the drive go berserk as it buffers, it can't be good for the longevity of the drives? The 18TB is same brand and model, the Easystore... or at least I think it is, just a bigger drive, I hate that keeps struggling like that and wouldn't want to keep it running like that long term.
  15. which test files are you guys using? my test file (black level pattern FEL DT DL DV.ts) still clips at 88 while sony x800m2 clip at 77. black.levels.pattern.modified_3079.ts clips around 84.

    another question, UPNP TS file playback does not support DV? It only shows HDR10.
  16. cucnz

    cucnz Active Member

    vs10 will turn off if DV content is detected and play that
    so its easier to leave it on VS10 for SDR HDR
    Auto will play the dv hdr10 content but then all the sdr hdr is just in those modes (ie majority of tv epis i watch)
    Cranks likes this.
  17. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I have my doubts about using 18 TByte drives. You may trying reducing the format to 17.5 TBytes. I wouldn't be surprised if that solves the problem.
    Assisted in 2 cases with 18 Tbyte drives behaving badly and both were solved using that remedy.

    My educated guess is the Android HDD-driver is dealing with a 32-bit maximum for the sector counter. This is reached with that size.
    Asked Zidoo to validate this but never got an answer to that request.
    Last edited: Oct 18, 2022
    B0RN and AngryVirginian like this.
  18. Deano86

    Deano86 Active Member

    Curious.. what is your output resolution set for on your Zidoo to your display? I had something similar, but when I switched the Zidoo to output everything in 4K ( I think its upconversion of 1080p is fantastic anyway) and only match frame rate, any intermittent video issues disappeared for me on 1080p sources.
  19. Colmas

    Colmas New Member

    I have been reading this thread with much interest. My Z9x is still on 6.4.29, and I have been reluctant to upgrade to the intervening firmware due to the issues reported. This 6.4.4 looks like it's stable and hasn't introduced any additional issues. So, would it suitable to upgrade to this version?

  20. Onwrathz

    Onwrathz New Member

    Are you using your 18TB as a custom folder as well? I have my pictures saved to the device vs using custom folder on my main content drive. So if Nice Monkey’s suggestion doesn’t work, switch to “save to device only”, first option I think and see if that helps. You may need to “show hidden” and remove the “.HomeTheater” folder from your 18TB drive also. I have my 16TB in a closet so I will pay more attention to it if it thrashes in the future. But generally speaking I haven’t noticed it doing that when I have fiddled with it. To your point, I wouldn’t want it thrashing like that due to longevity. You said you noticed it while just sorting, that is why I am wondering if you switching off custom folder and just using the onboard storage as a better option. Good luck.
    Last edited: Oct 18, 2022

Share This Page