PlexToZidoo : An external player for plex using native Zidoo player

Discussion in 'HDD Media player(RTD 1619DR)' started by gogo789, Nov 4, 2022.

Thread Status:
Not open for further replies.
  1. lightsout

    lightsout Member

    I was in the incorrect place. There was a defaults section in advanced settings that I believe got it.

    Thank you. Things are working great now. My resume points are functioning properly. This is excellent. Much appreciated.
    bowlingbeeg likes this.
  2. techos

    techos Member

    Is there any way I can use the official plex client with PlexToZidoo on a Z9X Pro?

    No matter which versions I tried I could never select an external player.
  3. bowlingbeeg

    bowlingbeeg Active Member

    No, you have to use the ZidooPlexMod Kodi addon.
    techos likes this.
  4. lightsout

    lightsout Member

    I have HDR set to "Auto". I noticed yesterday when I played a file with HLG, (this is a rip from BBC, the file is definitely 2160p) that that the file was downsized to 1080p. TV reported this as did hitting info on the Zidoo. Is this a strange bug with HLG? This was with the internal player using plex2zidoo.
    I also noticed something unexpected, maybe wrongly on my part. That with plex2zidoo installed it takes over the internal player for all apps. When I went to use JF or Emby the option for "video player" was gone. Only plex to zidoo showed. I have a feeling I could correct this by unchecking "use internal player" in the settings of plex2zidoo but I didn't try.
  5. bowlingbeeg

    bowlingbeeg Active Member

    I feel like I've seen others on the forums talk about some issues with HLG but it's definitely not a a PlexToZidoo or ZidooPlexMod issue. So you should ask elsewhere in the forums.

    If you select "always" and the PlexToZidoo app then any video stream in android will go through PlexToZidoo. Regardless of the client. If you're going to use Plex and JF and Emby at the same time then you shouldn't select "always" when Android asks which external player to use.
    gyrene2083 likes this.
  6. I may switch to this from Jellyfin, and based on the above, it seems I need to decide on one, but will all my 3D MKV rips still play as normal using this with Plex?
  7. bowlingbeeg

    bowlingbeeg Active Member

    This just gives the Zidoo player access to the video files so if the 3d video plays fine using JF's external media player support then it will work with Plex as well.
    gyrene2083 likes this.
  8. Enet

    Enet Active Member

    Plex is my main player for my 3D movies. But I need to be able to play blu-rays and DVDs. I can't remember if Jellyfin allows it but HT4 does. If there was a way to incorporate those movies into my library even if Plex itself can't play them then I would use Plex here too.
  9. Przemyslaw

    Przemyslaw Member

    Hi guys, I am trying to use PlexTo Zidoo and ZidooPlexMod. My path in PLEX for Movies starts with /share/[...] so in PlexToZidoo I substitute /share with smb://NAS_SERVER_IP_ADDRESS/share but when I launch a movie, I get "Can't play video" error.

    If I open the movie file via File Explorer (SMB), it opens with no issues.

    Do you know what the problem might be?
  10. bowlingbeeg

    bowlingbeeg Active Member

    Please turn on the debug option in PlexToZidoo and it will show you if it found a substitution or not. You can then post a screen shot of that and of your PlexToZidoo settings and I can try to point out what's wrong. The other thing that could help is the path that's displayed in the media center app.
  11. Przemyslaw

    Przemyslaw Member

    Thank you very much for responding. I have the option constantly turned on. It is showing that it found the substitution.

    I am testing this on the movie The Conjuring (2013) - but the situation is the same for every movie.

    The path of the file displayed in the media center app is: All->SMB->NASF46E6B (this is my NAS name)->NAS-Drive6->Movies->The Conjuring (2013). Please see the screenshots of my PlexToZidoo settings and the debug info.

    Attached Files:

  12. bowlingbeeg

    bowlingbeeg Active Member

    Based on your path in the media center app it doesn't look like you should have the "/share/CACHEDEV8_DATA" in your final substitution. Can you try "/share/CACHEDEV8_DATA" for your "path to replace" and just "smb://" for your "replaced with" in PlexToZidoo settings?
  13. Przemyslaw

    Przemyslaw Member

    It worked when I set Part to replace as: /share/CACHEDEV8_DATA/ and Replaced with as: smb://192/168.68.119

    The thing is that in Plex I have 5 CACHEDEVX_DATA paths - please see the screenshot. Should they all be added and separated with a comma?

    Edit: I have added all paths and everything seems to be working fine! Thank you very much @bowlingbeeg

    Attached Files:

    Last edited: Nov 13, 2023
    bowlingbeeg likes this.
  14. Vamsi_krishna

    Vamsi_krishna New Member

    I apolosie if this has been asked earlier. Does this app support playback of Plex remote share?
  15. bowlingbeeg

    bowlingbeeg Active Member

    That's not an easy answer because it depends on a lot of factors including how the remote server is setup and which client you're using. I'll summarize what I know but really you'll have to try it yourself to see if it works for you.

    Native Plex Client(Z9X generation only):
    - Only works if you can direct play the remote video
    - Doesn't remember resume points

    - Should work for most videos including those that need to be transcoded but I have had times where it refuses to work and I have no idea why
    - Resume points mostly work but not always

    Both clients:
    - Subtitles do not work.
    - Can't skip around in the movie(aka no fast forward, reverse, or skip)

    There are probably other caveats I'm forgetting or haven't run into.
  16. bowlingbeeg

    bowlingbeeg Active Member

    New update for ZidooPlexMod(version 0.2.3).

    No new updates from my end but pulled in the latest 0.6.4 version from upstream. There were a number of changes to the upstream that don't affect us since we're not using the kodi player but a few things that did. If you want to follow along with the upstream changes you can check out this Plex thread,

    The new version is out in the repo so please try and install from there. See this post for more details on how to install the repo,

    Otherwise you can still manually install by downloading from here:
  17. Suramen

    Suramen New Member

    I have a problem with srt subtitles that appears in pink and nearly invisible (no problem if i read the file with the Plex app on mon LG TV) . Do you know how i can solve it ? thanks
  18. bowlingbeeg

    bowlingbeeg Active Member

    There are subtitle settings in the Zidoo player. While watching the movie hit either the subtitle button on the remote or use the menu button and select the subtitle menu.
  19. chrisdc039327

    chrisdc039327 New Member

    Hi everyone, been reading through this post, but I'm unable to get zidooplexmod for kodi to work.
    I have tried ZDMC and Kodi 20.2 with the zidooplexmod from the github repository and plex2zidoo apk configured for substition.
    ZDMC uses the zidoo player, but it's not using the plex library as I can not figure out how or where to select the plex library, so I added the smb fileshare.
    In Kodi I have the same issue except there it uses the kodi player.

    I'm fairly sure i'm missing something simple and have read the readme's several times but it doesn't click..
  20. bowlingbeeg

    bowlingbeeg Active Member

    In ZDMC/Kodi are you opening the ZidooPlexMod addon? You don't add the plex library as a source in kodi, you actually go into the addon and it totally replaces the normal kodi interface.
Thread Status:
Not open for further replies.

Share This Page