PlexToZidoo : An external player for plex using native Zidoo player

Discussion in 'HDD Media player(RTD 1619DR)' started by gogo789, Nov 4, 2022.

Thread Status:
Not open for further replies.
  1. chadamir

    chadamir New Member

    Thinking about switching away from jellyfin to this. Is there anything that doesn't currently work?
  2. B0RN

    B0RN Active Member

    Yup this is the screen I get... and that's the version I downloaded. I dont know how to get to my movies from this page.
  3. B0RN

    B0RN Active Member

    Oh so this isnt the app... just an add on for DV support among other things. Got it, that would explain why I was so confused.
  4. Gilgamesh

    Gilgamesh Active Member

    no, you have to use the Plex app to login to your Plex account where you can see your movies etc if you run Plex server, PlexToZidoo is just a bridge to the built in Zidoo player instead of the Plex player.
    bowlingbeeg likes this.
  5. B0RN

    B0RN Active Member

    Appreciate it all! If someone can answer one question - does this bridge allow me to not use the zidoo player but still provide DV playback support? Or must I select use zidoo player option for DV? I wanted to try this for DV but not use zidoo player.
  6. Dezed13

    Dezed13 New Member

    no. Plex’s internal player will not support Dolby vision. The whole point of this app is to allow you to use the zidoo player while using the plex interface.
    bowlingbeeg and B0RN like this.
  7. chucky527c

    chucky527c New Member

    I have been working on implementing the instructions to my system, and have been partially successful. I was wondering if there was anyone with experience or knowledge who can help point me in the right direction for the rest of it.

    I have multiple NAS units (specifically QNAPs), all on the same network as each other and the Zidoo. NAS #1 has my Plex server, and using remote mounting, I have Plex on NAS #1 pulling all of my Movies and TV Shows from across the multiple NAS servers.

    Following the instructions, I was successful in getting all of the media residing on NAS #1 to play correctly. However, I have been unsuccessful with files from other servers that are connected via remote mounting. I tried every combination that I can think of with respect to path replacement. Does anyone have any insight into such a scenario? I'm pretty sure my permissions are OK, but maybe there's something I'm missing from the NAS side? Or is something like this currently not possible?

    For reference, the format of the root movie folders in Plex are "/share/Media/Movies" for the files residing on the same NAS while those on the remote mounted shares are "/share/external/.nd/1000/xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/Movies
  8. bowlingbeeg

    bowlingbeeg Active Member

    For local media playback of your movies I think all of the features should work. Can't say I use every feature but I believe they should all work, if not please report any issues and I'll look into it. This will not play remote streams(aka, you can't stream a movie from your friend's plex server) and it won't work with the Plex free streams that they offer. Those are both limitations of the zidoo player itself.
  9. bowlingbeeg

    bowlingbeeg Active Member

    Can you post screen shots of the PlexToZidoo debug page(the one with the play button on it) and of your settings page specifically where the substitution strings are. Can you connect directly to that remote share from the zidoo media browser app?
  10. chucky527c

    chucky527c New Member

    As I was working on getting responses to @bowlingbeeg prepared, one of the questions inspired a new approach that helped me solve the issue on my own. On the off chance that someone in the future has a similar situation, I thought that I'd post my solution here:

    To start, there are 3 separate NAS units on the same network: NAS1, NAS2, and NAS3. Each house some media, all of which is connect to a Plex server running on NAS1 and connected via remote share. I had tried to connect to the media on NAS2 and NAS3 by adjusting the path while still going through NAS1, which proved to be challenging. Then, the question came up if I can connect directly to the remote shares from the zidoo media browser app, which I could. So, I thought that I would try substituting the paths the had gone through Plex on NAS1 with the paths that would connect the zidoo directly to the other 2 NAS units. This worked. An example to illustrate more clearly:

    IP -
    Plex Path (Native) - /share/Media/Movies
    Plex Path (Remote 2) - /share/external/.nd/1000/xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/Media Drive/Movies (different xxx for each remote NAS)
    Plex Path (Remote 3) - /share/external/.nd/1000/xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/Media Drive/Movies (different xxx for each remote NAS)

    IP -
    Plex Path - /share/Media Drive/Movies

    IP -
    Plex Path - /share/Media Drive/Movies

    We need 3 entries in the path substitution/replace with entries, each separated by a comma

    Path Substitutions (NAS1, NAS2, NAS3): /share/Media,/share/external/.nd/1000/xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/Media Drive/Movies,/share/external/.nd/1000/xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/Media Drive/Movies
    Replace with (NAS1, NAS2, NAS3): smb://, smb:// Drive, smb:// Drive

    The only catch is that the SMB login and passwords needed to be the same for all 3 units since multiple logins/passwords don't seem to be supported. As all units belong to me and are for personal use, this was not a problem. I imagine this solution may not work if the login/passwords are not the same.
    bowlingbeeg likes this.
  11. bowlingbeeg

    bowlingbeeg Active Member

    Yes, you are correct that right now PlexToZidoo only supports one username/password combination. I had contemplated adding that in when I added the support for multiple substitutions but I thought adding multiple passwords into the password box was a little challenging since you can't really tell where you are with the *'s showing. What I would really like is to have multiple substitution and username/password boxes but I couldn't figure out how to add that easily. Maybe now that things seem a little more stable I can revisit.
  12. park13

    park13 New Member

    "Install the Plex app but do NOT install the latest version on Google play. Please download and install version or older for the setup."

    Just making sure. Can someone please provide a link to this version?

    Thank you
  13. Gilgamesh

    Gilgamesh Active Member

    you literally have it one page back.
  14. bowlingbeeg

    bowlingbeeg Active Member

    New version 1.7 just released on github

    I added support for multiple username/password fields. The main settings page is still the same but now there is an "Add additional substitutions" link that will bring up a page of 9 additional path substitution and username/password preferences. Each path substitution field allows for multiple substitutions but the username/password fields only allow a single entry. Hopefully that makes sense, here is an example

    Part of Path to Replace: /path1, /path2
    Replaced With: smb://, smb://
    Smb username: User
    Smb password: passw0rd

    Part of Path to Replace: /path3
    Replaced With: smb://
    Smb username: User2
    Smb password: passw0rd2

    So on one server( we want to replace two paths(path1 and path2) that will use smb username/password, User/passw0rd and on another server( we'll replace one path(path3) and use smb username/password, User2/passw0rd2.
    Robik234, Rob W and Gilgamesh like this.
  15. Robik234

    Robik234 New Member

    1. I probably found a minor bug in both versions 1.6 and 1.7. PlextoZidoo does not manage correctly folders when # symbol is used in folder's name. For example: /Volumes/Blurays 3D #2/ . Removing # solved my problem /Volumes/Blurays 3D 2/ Maybe this issue touches also other strange symbols. I did not test.

    2. I am not sure if somebody has pointed that external trailers from Plex's Discovery feature do not work. Local trailers works well, TV services also. Is there any chance to fix it?
  16. bowlingbeeg

    bowlingbeeg Active Member

    I'll take a look when I get a chance at the # symbol issue. In general it's not a good idea to have symbols in your path names, it tends to lead to issues and they're not always obviously related to the symbol in the path name. As I've mentioned before in this thread the Plex free streams(and that includes anything on the Discovery page) do not work and that's a limitation of the zidoo player. So I can't really do anything about that.
  17. Cod

    Cod New Member

    Hi @bowlingbeeg - I just wanted to say that this is a fantastic bit of work, building on the original code, and everything works just fine. I like HT4 interface but it still sucks quite often at matching things properly, even though I use Filebot to name everything in the TVDB approved format, whereas my Plex server never has any problems like that. The Zidoo video player with the Plex UI is a win-win, particulary with play-resume function working on Zidoo and syncing with my Plex on other devices. I normally use the Plex player on my Shield but it's been getting a bit troublesome with 4K files (plays them fine, but on stopping it freezes - but then the poor thing has had daily use since release in 2019, so can't complain too much). Think the only things I would miss from the Shield and Plex is the poster layout is better on Shield as it's using the actual Android TV version rather than the mobile version in TV mode, and the AI upscaling for some things. Other than that I think I'll be sticking with using this and Plex on the Z9X going forward.

    So, thank you very much - you deserve a pint :)
  18. Agree with all of this, your work has really improved using the Zidoo for me!
    bowlingbeeg likes this.
  19. salora

    salora Member

    Hi, zidoo native player support BD folder structure and BD iso files.
    Does your app bring support to plex too? I know plex client player do not but maybe with your app it works?
    Thank you
  20. Gilgamesh

    Gilgamesh Active Member

    this is not an Plex app, it uses standard Plex app but calls external app in this case Zidoo player.
Thread Status:
Not open for further replies.

Share This Page