New firmware v2.1.40 beta version for ZIDOO X20 released

Discussion in 'ZIDOO X20' started by mirror, Jan 27, 2019.

  1. gymnos

    gymnos Member

    I can´t find the information about MaxFALL and MaxCLL output pressing the Info button, any idea?
     
  2. myzidoo

    myzidoo Member

    No noticeable problems induced by this firmware for me. In general I find it a GOOD JOB DONE.

    Getting better and better and some issues I noticed can soon be described as fine tuning :
    For my usage it mostly concerns the posterwall and in particular the web interface :9528 :

    - several buttons are still in chinese(?)
    - backdrops - which do not show after manual editing
    - in general editing done in the web interface do not reflect in the player's posterwall. But the editing done on the player with the remote (cumbersome) reflect in the web interface

    In particular it seems to me that editing (mostly deletions) are not reflected in the db. Also resetting the player to factory settings doesn't seem to *completely* wipe the db. Only a complete hard reset with installing the root image seem to do the trick.

    It would be perfect to be able to choose the posterwall db location (like the posterlocation folder or backup folder). This would allow the db with tables to be saved and run from a drive which would be accessible and one could edit with third party SQL-style programs see (http://forum.zidoo.tv/index.php?threads/home-theater-2-0-save-system-of-posters.42980/) #2 without the need to root the device.
     
    Last edited: Feb 23, 2019
  3. gymnos

    gymnos Member

    The option is listed in the first post as 'Optimize HDR display (available MaxFALL and MaxCLL output)', but I don´t see it in any menu or info screen.

    Thanks in advance.
     
  4. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    These are not options but HDR variables which the player should now react to implicitly. No idea how to test this exactly, but some HDR pictures used to come out very dark which may have been caused by not reading/using these variables.
     
    gymnos likes this.
  5. gymnos

    gymnos Member

    This is my configuration:

    Quick Settings\Other\About\Advanced Settings\HDMI Rx Functions set "HDMI Rx version" to <2.0>
    Quick Settings\Other\About\Advanced Settings\Developer Options set "Ignore EDID" to <On>
    Quick Settings\Playback\Automatic Frame Rate set "Frame Rate Mode" to <Only Frame Rate>
    Quick Settings\Display\HDMI Mode set to <3840x2160p 23Hz>
    Quick Settings\Display\Color Settings set "Deep Color Mode" to <Auto>
    Quick Settings\Display\Color Settings set "Color Space Mode" to <Auto>
    Quick Settings\Display\Color Settings set "HDMI Range Mode" to <16-235>
    Quick Settings\Display\HDMI Output\Main Vice-port Separation Mode
    Quick Settings\Display\HDR set to <AUTO>
    Quick Settings\Audio set "HDMI Audio" to <RAW>
     
    Last edited: Mar 30, 2019
  6. gymnos

    gymnos Member

    Any news about the next firmware?
     
    Last edited: Mar 30, 2019
  7. skelton

    skelton Member

    I am still having issues adding backdrop images for titles missing on the latest firmware, see this post for more details on my problems. Is anyone else having the same issue with the 2.1.40 firmware?
     
  8. gymnos

    gymnos Member

    I don´t have any problem changing backdrop images, my files are stored in two WD RED 8TB for the internal HDD bays.
     
    Last edited: Mar 13, 2019
  9. Johnwoto

    Johnwoto Member

    I don't have any problems with back drop images, i have a Qnap 4 bay nas, filled with 4tb wd reds, you can alter the location where the images are stored in the settings, have you tried that ?
     
  10. skelton

    skelton Member

    Which setting do you currently have for image storage?

    I have the default setting and i have tried to add backdrop images stored both on my Synology NAS & a USB stick. None of them works,
    Very odd..
     
  11. Johnwoto

    Johnwoto Member

    i have mine on the default setting, on my Qnap NAS i had to give the X20 full read and write. have you tried inserting a disk in to the x20 with films on it, then add that as a source and run the scan to see if the images come down to it
     
  12. Luigi

    Luigi New Member

    Just an info... the latest STABLE firmware is the 2.1.40 or 1.2.28? I've updated my X20 to the 2.1.40 via USB because via OTA not was present the update. The result... so many crashes (black window, need to turn off with the button, etc.)!
    That you for help me!
     
  13. SAMDestroy

    SAMDestroy New Member

    for me 2.1.40 beta is pretty stable. im not using any extras like gapps or root
     
  14. gymnos

    gymnos Member

    Last stable version is 2.1.30, but in my setup 2.1.40 doesn´t have those crashes.

    You can flash the unit and install 2.1.30 via USB, obviously at your own risk.
     
  15. I also have no problems. re load firmware. reprogram remote
     
  16. Luigi

    Luigi New Member

    Are you sure? Where can I find this release? On the Zidoo website I see only the 2.1.40 or 1.2.28....
     
  17. I would try reloading 2.1.40 again first. also make sure you have the x20 version.
     
  18. Luigi

    Luigi New Member

    Ok, I'll try!
     
  19. gymnos

    gymnos Member

    And do a factory reset after installing the firmware, this is very important.
     
  20. Johnwoto

    Johnwoto Member

    Has anyone got an idea when the new firmware will be released ?
     

Share This Page