New firmware v2.0.34 version for ZIDOO X9S release

Discussion in 'X9S Official Firmware Releases' started by mirror, Jul 4, 2018.

Thread Status:
Not open for further replies.
  1. cucnz

    cucnz Active Member

    quick test after install of Black Panther and menu system worked well....seemed to have more options/different popup box
    no issues banding/stuttering,even after sliding forward in play a few times,but i never do on 4k stuff,and dont use the Zidoo for lower quality stuff
     
  2. Techead

    Techead Member

    I did a little bit of digging and the resolv.conf was poiting to the wrong name server. change it and now it's working again.
     
  3. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Quick settings - playback - language - default subtitle -- off . Enjoy!
     
  4. gadgetman

    gadgetman Member

    The above does not sound like a seamless branching issue to me. Normally before the picture froze for a split second sound turned off then resumed from the different branch in the movie. The above picture been jerky i never got that or sound out of sync.
     
  5. cucnz

    cucnz Active Member

    much appreciated :)
     
  6. Rumootje

    Rumootje Member

    The symptoms you described can more or less be compared to the problems I have with the 3D iso CoCo. The movie plays fine up until about half the movie, after that the picture freezes a couple of times during the rest of the movie, the sound continues to play.

    When playing the same iso through my Pioneer BDP450 there is no problem at all, same receiver, same television. So in my opinion it is clearly a software problem with the X9S.

    I’m very curious if Zidoo looked into the matter, unfortunately I do not get a response from Mirror.

    On the other hand I’m very pleased with the X9S, “normal” UHD-iso’s, Blu Rays etc. play very well. For the 3D-iso’s with my seamles branching issues I can use my Pioneer. For the 4K ones with extended versions there’s no solution right now, for me that is.
    I was hoping just to use my X9S but I keep my loyal Pioneer for now.
     
  7. gadgetman

    gadgetman Member


    Not tried coco but did on previous firmware and it's has you described above. I never get a response of MIRROR neither i think he sick of me going on about this.

    The only solution for perfect 4k movies in which use the seamless branching is the very expensive oppo 203. Maybe the new Panasonic players due out later this year may do but unlikely.
     
  8. demiray

    demiray New Member

    HDMI audio: Close ///HDMI sends sound output when audio is turned off. Close the option is not active.
     
  9. hamster99

    hamster99 New Member

    Hi,

    seamless branching now works on The magnificent seven BD and Rouge One 3D BD.

    but...

    not on Star Wars - The last jedi UHD BD when selecting the German Dolby Digital Plus Track.
    It works when selecting the English Dolby Atmos 7.1 Track.

    The drop out occurs on ~00:02:07.

    This does not happen with other players.

    And please fix the refreshrate problems... With the current firmware it's 23.798hz. But 23.976hz (24*1000/1001 to be exact) is needed!!!

    And is it possible to add more HDR->SDR conversion modes & nits parameter like the oppo have them?
     
  10. godalmighty

    godalmighty Active Member

    @hamster99
    about HDR to SDR its already had it from the first but not for nit parameter
    Screenshot_20171205-160134.png
     
  11. hamster99

    hamster99 New Member

    Hi,

    i know that switch.

    but it's only on or off.

    The oppo has 4 modes + nits parameter

    And the current hdr->sdr conversion is better than nothing, but it's not good.

    MadVR on PC and oppo are having a much much better hdr->sdr conversion
     
  12. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Did a test for Seamless Branching using my reference Avatar EE as the basis. The problem indeed has been reduced with this firmware but it has not totally gone. On multiple points the jumps passed unnoticed but on some there was still a small glitch. Thumbs up and good hopes for a total fix. :)
     
  13. gadgetman

    gadgetman Member

    Yea a much better improvement. Can you check the following if you have these, Blu-ray alien boxset full disc does the menu appear?

    4K close encounters full disc?

    4K die hard works for me now i'm sure the last firmware it did not.
     
  14. Mysli

    Mysli New Member

    MX Player PRO v1.9.23 + Neon codec 1.9.18.2rev2.
    I can not watch a movie with AC3 - because the sound of AC3 (5.1) works only in HW mode. And in this mode, the picture and sound are constantly freeze.
    In SW and HW+ mode only 2 channels !!!
     
  15. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    This disc is notorious. Tested it on all platforms I have and is not working on any.

    Don't have the Alien boxset.
     
  16. godalmighty

    godalmighty Active Member

    but why if you play a HDR content and want to convert it to SDR :(:(:(
    its better if you got a new display/tv that support HDR :D

    i love this firmware, coz now i can use 10bit YCbCr 4:2:0 without any banding at least for my eyes :D
     
  17. DELUCAS

    DELUCAS Well-Known Member

    Am i missing something but why you using MX player for your movies ?
     
  18. Miguel Martin

    Miguel Martin New Member

    Thanks for another update ! I hope that the "hidden folder option"on file explorer will be add on next update :rolleyes:
     
  19. Mysli

    Mysli New Member

    And why can not I use the best player for android gadgets?
    Or you can call me another player with the same number of downloads of users :)?
     
  20. redscorpion133

    redscorpion133 New Member

    HELP

    Update process stuck at 95% by the little android guy with the turning gear.
    I wait now 1 hour no finish!

    What can i do now
     
Thread Status:
Not open for further replies.

Share This Page