New firmware v2.0.25 version for ZIDOO X9S release

Discussion in 'X9S Official Firmware Releases' started by mirror, May 25, 2018.

  1. Hi, I'm having a problem with Zidoo X9S. This only error, in the Home Theater and in the ZDMC, in the Kodi perfect wheel.
    Every time I go to see a movie in Home 2.0 or ZDMC, the movie gets o.k. after about 5 to 15 minutes, it stops, then fast and back to normal, No Kodi and perfect.
    This runs after the last two updates.
  2. godalmighty

    godalmighty Active Member

    i never used zdmc or official kodi, coz thats why i bought this box :p
    try factory reset or uninstall zdmc or any other player
    coz i dont have any issue using HT2.0
  3. I'll try. But I've always used everything and never had this problem.
  4. fabiopg

    fabiopg New Member

    Hello to all,
    I have a problem with music. When I play music, it is not immediate start but after 5-10 seconds or more. This problem is random for me.
    I tried fw 2.0.5, 2.0.12 and last 2.0.13 but I have the same issue with everyone.
    My zidoo is connected from Ethernet to Qnap NAS
    I do not have a similar problem with the previous firmwares (for ex. 1.5.0)
  5. Carsten Busch

    Carsten Busch Member

    I have exactly the same problem! I also have a Denon AVR 7200WA and stuttering with all DTS:X movies!
    Last edited: Jun 6, 2018
  6. cucnz

    cucnz Active Member

    i just got a new 4k hdmi cable to match ones im already using
    4k dts-x was working fine on existing cable(ie jurassic park 1)

    when i went to the new cable and retested jurassic park 1 ,i was getting the odd stutter
    go figure :p

    2 4k hdr cables from same manufacturer,but one doesnt carry full signals

    First place id look ,for those above with stutters
  7. godalmighty

    godalmighty Active Member

    with just $80 when i bought this box X9S
    i`m pretty sure very pleased with this box :D
    NUC is out of my range:(
  8. Theeraphon

    Theeraphon Member

    Which model of NUC you got?
    DribbleTool likes this.
  9. Carsten Busch

    Carsten Busch Member

    Gladiator has the same problem. I think it worked before I updated to this version!
  10. JohnS

    JohnS Member

    why bother with a nuc and not getting a ATV4K? Its the only officially supporting dolby vision, but here we are talking about zidoo, you get what you pay for! For the money i spent i'm quite happy with my x9s
  11. Carsten Busch

    Carsten Busch Member

    Does the at
    You are right. With this buggy firmware I can't watch most of my movies anymore!

    Does the atv4k support dolby atmos and dts:X bitstreaming?
  12. JohnS

    JohnS Member

    It supports Dolby Atmos, for dts I don't know. Don't get me wrong but these are completely different devices, Apple TV is a streamer and wants you to give money renting and buying stuff, on the other hand zidoo is more than a streamer (I use it also as a torrent download box) costs almost 1/3 of Apple TV
  13. Carsten Busch

    Carsten Busch Member

    I don't think it supports Atmos with MrMc. I have downgraded to V1.5.0 now and all the problems are gone.
  14. SaskMedia

    SaskMedia Member

    tvOS12 will support Dolby Atmos when it comes out this fall. No one knows whether it will be bitstreamed as TrueHD or DD+. TrueHD requires 24bit @ 192khz. The hardware on the aTV 4K is capable but it's to be seen whether Apple enables it in software. I recommend following the Firecore forums for their Infuse media player. As soon as support is available Infuse will have it.
  15. 3DBuff

    3DBuff Well-Known Member

    Couple of days ago I was watching movie using headphones connected to analogue 3.5mm jack through headphones multi-channels amp. I noticed that channels are flipped left with right. I run some tests on this case. Channels are correct from HDMI and probably SPDIF (didn't test this port) but they are definitely flipped on analogue 3.5mm jack. I didn't test this on previous firmware but it didn't strike me as wrong before.

    Is there any way to correct (reverse) left and right channels on analogue output port? This is before I cut one of my cables and splice it across ;)
  16. Sarco

    Sarco Active Member Beta test group

    The 3.5mm output on zidoo is audio and video, maybe that why channel are not in proper position.
  17. 3DBuff

    3DBuff Well-Known Member

    I would expect that if I plug in stereo headphones 3.5mm 3 pole jack directly into this port I should get correct left and right orientation as marked on the headphones. Most of the headphones can't be flipped around to put right side on left year.
  18. 3DBuff

    3DBuff Well-Known Member

    I use headphone amp. with 4 channels (4 pairs of headphones out) with individual volume control. I use it on occasion late night movie watching without burning heavy current amp for pair of headphones. Simple short patch cable 3.5mm stereo jack on both ends to connect to Zidoo. It works correctly with any other device except for Zidoo .
  19. anman

    anman New Member

    After the update, some applications from the became unavailable for installation from the library. All of them worked fine on older versions.
  20. saji

    saji New Member

    ZIDOO Tech Support pls help me

    I just tried to flash this update from the usb drive from settings menu...everything went fine but after flash when it tried to reboot. zidoo x9s is stuck at "boot" logo

    its not moving ahead

    pls help asap

Share This Page