slow SMB network

Discussion in 'HDD Media player(RTD 1619DR)' started by Topdude, Nov 20, 2020.

  1. Topdude

    Topdude Member

    My Z1000 Pro is fitted with a new Seagate IronWolf 4TB HD. Tested in my PC and very fast.

    In my Zidoo, however, copying files to it is slow and doesn't exceed 40 MB/s. And that is when I'm lucky.

    In my Q10 the same HD reached up to 70 MB/s copying from the same PC over the same network.

    This lower speed is with every file under all circumstances.

    Is there a limitation anywhere or a setting that I'm overlooking now?
    Do I need to enable anything on the Z1000?

  2. Polypenko

    Polypenko Member

    I just did a test my Z1000pro / WD 8 tb which is connected to the Network via a networkcable (not wifi) when I copy a file from my Desktop the average speed is 91mb/s. (see below screenprint)

    My pc network card is running at 1.0 Gbps, so you need to check if your pc network card is running at the correct speed 100 or 1000.

    Last edited: Nov 20, 2020
  3. Topdude

    Topdude Member

    Verified my network is running at gigabit speed. Also my Z1000 is connected by cable.

    like I said, the thing is that everything is exactly the same, just swapped Q10 for this one.
    HD, cable, network stuff etc etc, the same and running fast.
    For example, I can copy the same file from the same pc through the same router and it will go to a USB3 drive connected to the router port (ASUS RT-AX88U) with around 80-80 MB/s

    is there no setting in the Z1000?


    Attached Files:

    Last edited: Nov 21, 2020
  4. Polypenko

    Polypenko Member

    These are my settings.

    Just tested again 90 / 92 mb/s


  5. Topdude

    Topdude Member

    I have exactly the same.
    Assigned static IP address to the zidoo, samba enabled etc

    Really don't understand why transfer to USB3 drive to router is more than double as fast than transfer to internal drive.
    Both drives are Seagate IronWolf 4TB and new.
  6. Polypenko

    Polypenko Member

    Old networkcable Cat5 only 100mb/s between the router and the z1000pro?

    I use a cat6 cable.

  7. Topdude

    Topdude Member

    neither the cable. It's cat6

    Everything is exacly the same. Network, distance to pc, router, HD, IP, cables et etc. Only difference is Q10 / Z1000 Pro.
    It doesn't explain why transfer to external USB drive is close to 100 MB/s from the same network and to the z1000 only 35.
    Everything has been restarted, same result. Only 35 speed in zidoo.

    I changed back Q10: almost double. So? How? I have no idea
  8. Topdude

    Topdude Member

    Checked and made sure all SMB was running on my PC.
    Included the old smb1 version to see if it would make a difference, but it didn't.
    SMB direct is the version3 protocol


    Attached Files:

  9. Topdude

    Topdude Member

    I checked everything again switched cables again. Everything on my network works as should be.
    Meanwhile I’m thinking this is a faulty network box.
    During startup two lights at the Ethernet port on the zidoo turn on. Then the green light turns off and only one amber light stays on. This is weird.
    Then I also switched everything back to factory default. Same thing. Not the correct speed.
    Where can I assign. Gigabit network? my router says gigabit. All other devices run gigabit.

    New problem: I can’t get into my google account anymore. The box refuses to go past the certificate page. Typed in the number a million times restated but nothing.
    I’m starting to hate this box.
    What can I do to get gigabit network on this box and go in my google account?..
  10. Topdude

    Topdude Member

    On a sidenote: google account is fixed with the help of this page:

    Put in my devicenumber there, reboot and it worked. Ok. Playstore works.

    Back to problem one: network (lack 0f) speed.
  11. pcristi

    pcristi Active Member

    Q10 use SMB optimized settings(SAMBA Patch! by qqq1971 ), then you need apply to Z1000Pro too for improve speed.
    You can read on Tips and tricks. Unofficial guides and fixes. User edition about it.
    Apply via adb shell on Z1000 Pro by edit /system/etc/samba/smb.conf.template
    LE: try
    #socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072
    write cache size = 1024000
    Will probably get at least 60-70MB/s.
    Last edited: Nov 27, 2020
    Mabon and Markswift2003 like this.
  12. Topdude

    Topdude Member

    Thank you for your reply and recommendation! Great! :)

    but these technical things with code I don’t understand.

    indeed I applied the patch to my Q10. But I can’t get it to work in the same way on the z1000.

    openwrt I don’t know and what is adb?
    I’m sorry for these noob questions.
  13. Mabon

    Mabon Active Member

    But does that require Root access :eek:??? Is there a SuperUser app for the Zidoo Z1000 Pro?

    I can read the file but can't save it. It currently reads:


    interfaces = eth0 eth1 wlan0 br0

    domain master = no
    local master = yes
    preferred master = yes
    os level = 65

    disable spoolss = yes
    load printers = no
    printcap name = /dev/null

    map to guest = Bad User
    security = user
    encrypt passwords = yes
    guest account = root
    delete readonly = yes
    force create mode = 0644
    force directory mode = 0755
    force user = root
    force group = root

    unix extensions = no
    case sensitive = no
    unix charset = UTF8
    dos charset = ASCII

    strict allocate = no
    allocation roundup size = 4096
    read raw = yes
    server signing = no
    strict locking = no
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072
    min receivefile size = 16384
    use sendfile = yes
    aio read size = 16384
    aio write size = 16384
    aio write behind = true

    reset on zero vc = yes
    smb encrypt = disabled

    dfree command = /system/bin/

    deadtime = 15

    log level = 1
    max log size = 1024
    log file = /data/local/tmp/smb_%m.log

    usershare allow guests = yes
    passdb backend = tdbsam:/data/local/tmp/smbpassdb.tdb

    netbios name = ZD_SAMBA
    server string = ORG_NAME_SAMBA
    workgroup = WORKGROUP

    # path = /sdcard/Music
    # guest only = yes
    # public = yes
    # read only = no

    path = /storage/
    follow symlinks = yes
    guest only = yes
    public = yes
    read only = no
    Last edited: Nov 28, 2020
  14. pcristi

    pcristi Active Member

    Use adb (Android Debug Bridge) to write back on box smb.conf.template.mod with something similar to this
    adb connect <ip_player:5555>
    adb root
    adb connect <ip_player:5555>
    adb pull /system/etc/samba/smb.conf.template smb.conf.template.mod
    <--- edit smb.conf.template.mod with notepad++ or a Linux editor --->
    adb remount
    adb push smb.conf.template.mod /system/etc/samba/smb.conf.template
    adb shell chmod 644 /system/etc/samba/smb.conf.template
    adb reboot 
    smb.conf.template.mod is modified files like is suggested to try on my previous post comment socket options and add write cache size.
    For Windows can use ADB Kits (adb.exe AdbWinApi.dll AdbWinUsbApi.dll) download from here.
    Last edited: Nov 28, 2020
  15. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Don't enable SMBv1 as that is unsecure and slow. It is not needed.

Share This Page