PlexToZidoo : An external player for plex using native Zidoo player

Discussion in 'HDD Media player(RTD 1619DR)' started by gogo789, Nov 4, 2022.

Thread Status:
Not open for further replies.
  1. Gilgamesh

    Gilgamesh Active Member

    yeah subs do work as I used this before with my Unraid server when I had all my media local on harddrives, but now I stream everything with Plex Debrid.
     
  2. bowlingbeeg

    bowlingbeeg Active Member

    That sounds like you don't have your substitution right in PlexToZidoo ... the zidoo player will play the plex stream just fine but doesn't find internal nor external subs. I've been trying to get the devs to look into why but haven't had much response. So you need to have your substitution right so that the zidoo player has direct access to the movie. Then it will find the internal and any external subs in that same directory.
     
    Gilgamesh likes this.
  3. Gilgamesh

    Gilgamesh Active Member

    yeah I will check it out when I'm home again,
    hopefully I did something wrong there.
     
  4. karmu

    karmu Member

    Can you reproduce the missing title bar, shown in my screenshots?
     
  5. Gilgamesh

    Gilgamesh Active Member

    yes, also not possible to navigate with remote, need to use mouse first...but the normal Plex app still works.

    I finally kinda got the subtitles working but only for internal subs, as it's not possible to save external subs to the rclone drive, a small workaround is to download the subs to the internal storage which is ok...but overall Shield Pro experience is more straightforward.

    decisions decisions...I really like the Shield Pro UI speed and no need for HDMI handshakes...it works with external subs when downloading from Plex app even though it's not saving it to the rclone drive, but hey got the playback working with the Z9X even though no local media files. :)
     
    Last edited: Aug 4, 2023
  6. bowlingbeeg

    bowlingbeeg Active Member

    I'm not able to reproduce on my side bit if you can reproduce with the kodi debug logging enabled I can give you a location to upload the kodi log so I can review it and see if there is anything in it that might hint as to what's wrong.
     
  7. bowlingbeeg

    bowlingbeeg Active Member

  8. karmu

    karmu Member

    Great!
    First try: Remote works at start and the title bar is there.
    I'll do more test later. It's time for bed now (03:30) ;)
     
  9. Goodyear77

    Goodyear77 New Member

    Tested the 1.1.2 version and it’s moving forward! I can now navigate with my remote immediately, and I get the previously missing categories on top.

    But I noticed that the play state doesn’t seem to be saved. If I start a movie the playback works fine, but after I stop playback the movie isn’t the first in the “continue watching” row, and if I start the movie again it starts at the same time stamp as before I played the movie through ZidooPlexMod.

    So you’re making progress @bowlingbeeg !

    One other minor issue is that when selecting a TV show, there is a delay while it’s processing the item. It seems the delay isn’t present for movies. The delay is 3 seconds to bring up the TV episode details, and the 5-7 seconds extra processing without doing anything extra. The 5-7 extra seconds are not present for movies.

    Edit: cleared up the delay information.
     
    Last edited: Aug 5, 2023
  10. bowlingbeeg

    bowlingbeeg Active Member

    This is working just fine for me. Just remember if you're starting a movie from the beginning you need to watch at least one minute of the movie for Plex to remember the watched progress. That's a Plex limitation.

    I've noticed that at different times the delay to bring up screens varies. Sometimes the movie section will pop up instantly and other times it takes a few seconds. I'm not sure if it's just the response time from the Plex server or if it's the processing power of the zidoo or an issue with the addon. Probably a combination of all three. I'm not sure I'll be able to do anything about those kinds of issues.
     
    gyrene2083 likes this.
  11. Goodyear77

    Goodyear77 New Member

    I’m actually a starting from the middle of a movie/tv show, just tested again and let it run for 3 minutes. But I notice that after stopping playback then ZDMC starts and then ZidooPlexMod starts (I have it set to auto start when starting ZDMC). One theory I have is that the internal player kills ZDMC+ZidooPlexMod and then there is no way to save the resume point. Maybe it’s the same problem you have listed under “Misc stuff” in the PlexToZidoo repo? And maybe this isn’t a problem for the Z9x Pro that has more RAM?

    My brother in law is buying a Zidoo on my recommendation soon, and perhaps I should steer him towards the Z9x instead of the “pro” version…
     
  12. bowlingbeeg

    bowlingbeeg Active Member

    Yes, you still need to setup the zidoo so that it doesn't kill the background processes. Those instructions are in the PlexToZidoo readme.
     
  13. Goodyear77

    Goodyear77 New Member

    Understood, it’s just not a great solution since the settings are wiped after reboot. But perhaps the Pro allows more than 2 apps simultaneously?
     
  14. bowlingbeeg

    bowlingbeeg Active Member

    The zidoo firmware is setting the limit to 2 background processes so unless they changed that for the Pro models then I'm guessing it will have the same issue. I'm hopefully getting my Z9X Pro next week and then I can check it out.
     
    Goodyear77 likes this.
  15. karmu

    karmu Member

    My solution for this is:
    I've installed the non-G firmware,
    because you have less background task.
    For me this works great.
     
  16. bowlingbeeg

    bowlingbeeg Active Member

    I'm not sure why that would make any difference. We're not talking about background services that the G firmware might have, this is background apps that the user has started.
     
  17. Gilgamesh

    Gilgamesh Active Member

    one easy solution is just not to reboot or turn off the player, if you not must to, it does not draw that much power.
     
  18. bowlingbeeg

    bowlingbeeg Active Member

    I've just published version 0.1.3 which adds the ability to customize the layout of your library list. If you want a custom layout for your library list you can copy the file, customlayout.xml, from the <kodi_path>/addons/script.zidooplexmod directory to the <kodi_path>/userdata/addon_data/script.zidooplexmod/ directory. Then edit it with the layout you want. You can have unique layouts for each server and user, a default one that everyone shares, or a combination of both. See the customlayout.xml file for details.

    Oh and before anyone asks I won't be able to change the order of the hubs(the lists of media like "Top unplayed" or "Recently Added"). The order is pretty much hard coded into the XML that builds the GUI so it would be a major rip up to get any sort of custom ordering to work.

    https://github.com/bowlingbeeg/plex-for-kodi/releases/tag/ZidooPlexMod_v0.1.3
     
    gyrene2083 likes this.
  19. karmu

    karmu Member

    The Google play service runs in background, and that increases the background app and fills the counter to max.
    Since I have the non-G, Plex with Z2P runs without restarting Plex or Kodi (with G-firmware Plex always do a restart).
    So for me, this way works.

    You can verify that in the task killer:

    upload_2023-8-6_12-11-38.png

    Here you can find the Play service app and kill it...
    But it comes back after a few seconds / minutes.

    Edit:
    @bowlingbeeg
    is it possible to integrate the PlexToZidoo app into the ZidoPlexMod addon?
    This might fix the problem with too many tasks.
     
    Last edited: Aug 6, 2023
  20. karmu

    karmu Member

    Thanks, really nice to have and works great :)
     
Thread Status:
Not open for further replies.

Share This Page