Plex client for zidoo early version(24 Sep updated)

Discussion in 'HDD Media player(RTD 1619DR)' started by mirror, Jul 28, 2022.

  1. qsnake

    qsnake New Member

    For the subs, my embedded subs work fine, I even use mkvtool to merge the .srt into .mkv file, and then the zidoo player can show the sub.
    The biggest issue now is when I pause the video for several minutes, when resume playing, it will show an error and stop playing. This happens every time. Other problems did not have a great impact on the use.
  2. audiom3

    audiom3 Member

    @Cod it is worth the effort IMO, to get HT4 up and running correctly. I used Plex for years and now only use/abuse it for subtitles when my GF watches something via the ShieldTV. She likes Spanish subs vs my forced English subs on the Zidoo. There is no guarantee or even commitment to getting a full-featured Plex for Zidoo. What we have so far is greatly appreciated but it's anyone's guess if it will be updated from here on out. As for HT4, I've found it extremely helpful to match titles to what TMDB/TVDB lists. Verbatim. Sure, it isn't fool proof but Zidoo gets about ~99% of movies correct according to my data (98.89% to be exact). Most of the issues are with titles that contain a comma or a period. Those drive me nuts because I match them exactly as TMDB has them and Zidoo forces me to manually match them and they... match when I manually select the title that is exactly as my title! And other than Looney Tunes, I have yet to have an issue with my TV shows. What types of issues did you have with Absentia and Rick and Morty?
  3. karmu

    karmu Member

    I also had this problem.
    My solution:
    I've installed an older Plex client: download
    The app will ask you to switch to TV mode, just accept. Done. Now you can update to the latest version.
  4. dvdit

    dvdit New Member

    Thank you. This allowed me to switch to TV mode.
  5. Nejiro

    Nejiro Member

    Hi, I too would like to try plex in my z9x, I install this version then switch to the tv version, right? Once I've switched to the TV version, how do I put the latest version? Is there an apk or do I have to put the playstore and it updates automatically?
    Thank you
  6. lawdawg

    lawdawg Active Member

    The home grown plex Client from this thread hasn't seen any changes since July/August, and it was pretty limited at the outset.

    If you are looking for Plex on Zidoo you should take a look at PlexToZidoo : An external player for plex using native Zidoo player | Zidoo forum
  7. Nejiro

    Nejiro Member

    Thanks for your reply, I tried the version suggested here -13-0-37280-4-android-apk-download/ and it almost always makes me plant the Zidoo that I have to go and unplug it to restart it so I will desist and continue to use the excellent ht4
    Thank you
  8. lawdawg

    lawdawg Active Member

    That is a pretty old client version at this point. 9.13 is from December. You can get the latest beta apks straight from plex at
    I have never had the plex app hard lock the zidoo and require a hard restart like you describe.
  9. qsnake

    qsnake New Member

    Is there any new progress in the development of this app? I really need this feature to be able to play the resources from my home NAS on the internet(at my parents' house).
  10. Bartimaus

    Bartimaus New Member

    Got the same network issue like other users. tried several network settings, dns etc. no luck. The "normal" adroid-plex-app is working well, also ht.4.0
  11. Enet

    Enet Active Member

    I've been using Jellyfin for about a year but I downloaded the zidoo client from the first page and so far everything is working well. I can see my NAS and any share I enable and I am able to play files directly using PlextoZidoo. I get that the Plex client is still in alpha/beta so I hope it improves going forward.
    Last edited: Aug 20, 2023
    qsnake likes this.
  12. Bartimaus

    Bartimaus New Member

    Hi, after I somehome managed to log in (after installing my old router) I am just trying to map the folder to the local path.

    It works with some folders on the same share, with same permissions, but not at any folder. Then I get an error message "Failed map to folder, please select correct folder".

    But the folder/path is selected correct, and there are the same permissions like the other folder which mapped correctly.

    Any suggestions where I am wrong ?
    Last edited: Sep 1, 2023

Share This Page