Plex client for zidoo early version(24 Sep updated)

Discussion in 'HDD Media player(RTD 1619DR)' started by mirror, Jul 28, 2022.

  1. Daredevil

    Daredevil New Member

    Amazing
    I've tried a library server with a subscription and it works great 4K HDR DV No problems zidoo Z9x

    Thanks Zidoo
     
  2. lufc001

    lufc001 New Member

    Yeah i kind of thought thats what this was. I’ll probably just go back to using HT4.0 and hope that Apple one day upgrade their Apple TV to allow TrueHD Atmos encoding.

    I love the interface on Plex just a shame the video players aren’t anywhere near the quality of the Zidoo. I’ve recently upgraded to 4K HDR10 projector so want the best possible experience and unfortunately cant get that on ATV4K atm.
     
  3. cima86

    cima86 New Member

    Hi I just got my player yesterday and the Plex app doesn't open for me. When I click on it it just refreshes the screen 1-2x and then nothing. Any ideas?
     
  4. Daredevil

    Daredevil New Member

    After testing 80 GB REMUX 4k dv movies
    more than one server
    Amazing quality no problems, no buffering all works fine
    Plex zidoo is the best place to watch Plex
    I've had problems with my TV and Nvidia Shield buffering
    Zidoo Plex has a problem only some servers work and some don't Before subscribing to the server make sure it works on the plex zidoo or not Some servers use SSL and others I don't understand the work of the servers but some of them work Some do not work zidoo Plex.
     
  5. Wolfh

    Wolfh New Member

    In my case, works fine but only 10 minutes. Do not know why, ir if It is a issue for the server o for the app.
    After exactly 10 mins, the app closes and i have to enter again. In others plex apps (Windows, kodi, LG...) dont have this issue. Very strange...
     
  6. cima86

    cima86 New Member

    Can anyone help? I've installed/uninstalled 3 times both via web install and via USB and it never works.
     
  7. mattmarsden

    mattmarsden Active Member

    Are you on the latest firmware?
     
  8. cima86

    cima86 New Member

    I believe so? 6.3.6 for the Z9X
     
  9. Temearoo

    Temearoo Active Member

    The last one is 6.4.20. Check the option to receive the beta versions online.
     
  10. cima86

    cima86 New Member

    Done and Plex now opened! Thank you!
     
  11. cima86

    cima86 New Member

    I'm getting the Plex media service access failed error message...
     
  12. illmatic077

    illmatic077 New Member

    How did you get it to work? For me it says "Cannot play video" on the library I am using.
     
  13. illmatic077

    illmatic077 New Member

    I figured out it has to do with allowing secure vs insecure connections.

    Are there plans to allow connecting with secure connections in the future? Or connecting to port 80?

    Thank you
     
  14. Nicholas Hewitt

    Nicholas Hewitt Active Member

    A lot of people are having this issue, but nobody cares to fix it so they just ignore you when you have this issue. Use the jellyfin app cause the dev actually listens and tries to fix issues
     
  15. cima86

    cima86 New Member

    I found a relatively easy fix, I downloaded this app for my Mac called WARP by Cloudflare. I just press a button and I guess it encrypts my internet connection. When I hit that button then Plex works on the zidoo but I think it disables my remote access for my friends so it's far from a long-term fix but works if you dont need the remote access.

    https://1.1.1.1/ is the link
     
  16. leonkoum

    leonkoum Active Member Beta test group

    It is working great for me (with Shield 2019 as media server).
    Great app, thanks team, very appreciate! :)
     
  17. Etienne

    Etienne New Member

    Can't wait to see the next update :)
     
  18. lightsout

    lightsout New Member

    I find the opposite. A uhd movie with the internal player tried to play and froze my zidoo, hard reboot required. External player so far plays fine. This is with the latest Android TV version of Emby.
     
  19. cima86

    cima86 New Member

    What Emby did you use? I tried to install the Android version but it wasn't usable with the remote, I had to constantly switch to mouse mode.
     
  20. lightsout

    lightsout New Member

    There is an Android version and Android TV version. I used the tv version. Same thing I've had on my shield forever.
     

Share This Page