New firmware v2.3.33 Beta version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by McBluna, Jul 1, 2020.

  1. cappy1

    cappy1 Member

    When playing a 4K HDR movie, Zidoo "Info" shows the output is 3840x2160 (23.976 fps). The Lumagen is showing this frame rate at input and output to the projector. When I set the Oppo 203 and the Zappiti to "24 fps" they do not switch back to "60 fps". Still a bit puzzled!

    Thanks for your help.
     
  2. Markswift2003

    Markswift2003 Well-Known Member

    Bit confused - in the first post you imply the Zidoos won't do 4K23 and in the second post you say they do... Also, what do you mean by "EDID on"?

    An EDID whether in the Lumagen, Receiver or display only tells the source its capabilities, it doesn't actively switch the source (to 4K60 for example).

    When you set a source to <auto> for example, the source is making the decision based on the EDID rather than the display doing it - it's a subtle difference, but important.

    So if you discretely set the Zidoo to 4K23 and it won't do it, that generally means something in the chain is presenting an EDID that doesn't allow it, but I don't think that's the issue.

    Have you tried removing the LRP from the chain as a test?
     
  3. cappy1

    cappy1 Member

    Sorry for the confusing descriptions. Let me try again. Under Quick Settings>HDMI Mode, Ignore EDID is set in Off position. When first booted, the system comes on at 3840x2160p 60Hz. When manually trying to set 3840x2160p 23Hz, it attempts to switch, then goes back to 60Hz setting.

    Bypassing the LRP today allowed me to set 3840x2160p 23 Hz. Without turning system off, I reinserted the LRP in the circuit and the Zidoo did not switch back to 60 Hz. However, when I did a system reboot, the Zidoo switched back to 60Hz.

    Since the frame rate mode is set to “switch frame rate and resolution”, the system plays at 23.976 fps as reported yesterday.

    There is no problem here, except that switching frame rates creates an additional delay when playing a 23.976 fps source. This seem to be a topic for the Lumagen Forum.
     
  4. Markswift2003

    Markswift2003 Well-Known Member

    Right I understand now..

    Very odd - that sounds like the LRP isn't presenting the 4K23/24 VIC in the EDID or at least the Zidoo is getting confused by it, particularly as you say it attempts to switch and then goes back to 60Hz.

    Presumably you mean that you don't see the confirmation dialogue after changing framerate, just a blank screem and the Zidoo times out and returns to the previous mode.

    This is symptomatic of either an illegal mode or a resync time that exceeds the dialogue countdown (so you don't see the dialogue in time and hence don't click <ok> to confirm). It has to be said though that the countdown is a generous 20 seconds which even allows us JVC users time to click <ok>!!

    But yes - this seems more appropriate for the Lumagen forum - it'd be interesting to hear what the solution is though.
     
    cappy1 likes this.
  5. cappy1

    cappy1 Member

    Correct, no confirmation dialog, Zidoo just times out. On the surface it seems the problem is with Zidoo as it communicates with the LRP. The reason I say this is because both the Oppo 203 and the Zappiti both allow frame rate settings of “24” with the LRP after booting from a cold start; everything plays normally.

    Thanks for trying to help. I will report back if I find an answer.
     
  6. cappy1

    cappy1 Member

     
  7. cappy1

    cappy1 Member

    Would the HDFury Vertex2 be of any help in diagnosing this issue?
     
  8. Markswift2003

    Markswift2003 Well-Known Member

    I don't want to say yes, and then you spend $400 on one only to find you can't fix it.

    However, if I was in your situation, I'd do something like the following:

    With the Vertex in "EDID passthrough", I'd insert the Vertex into each leg of the HDMI chain to sniff the EDID from each device - I would then download each EDID and inspect it with Deltacast EDID Editor to see if they all present the correct VICs (this needs a bit of knowledge about EDID construction, but nothing you couldn't learn very quickly).

    Off the top of my head, one solution would be to set the Vertex to a full EDID and have it in front of the Zidoo - but, and it's a big but, if something is on the fritz with the Zidoo, which is a possibility, that wouldn't help - but the Vertex would help to confirm if that was the case.

    However, and I've said this many many times before, the Vertex is the single most useful device I've ever bought for diagnosing HDMI chain issues and for that reason alone it's well worth every penny.

    The Vertex 1 would do exactly the same for you, but it's not quite as elegant in use - the Vertex 2 has a web interface so it's much easier to use whereas the Vertex 1 needs to be connected by USB to a PC and there's a bit of software to run rather than it being internal on a web server.

    There is also superb support by HDFury over on AVS.
     
    cappy1 likes this.
  9. Markswift2003

    Markswift2003 Well-Known Member

    Have you confirmed whether the Zidoo, once set to 4K23, will maintain 4K23 if turned off then on again without the LRP in place?
     
  10. catorcio

    catorcio Member

    When will you entertain the Z10 with the v2.3.33 update?
     
  11. cappy1

    cappy1 Member

    If I can't figure it out, maybe I can at least create relevant files and send to Zidoo. And worst case, there is always eBay! I'll give it a go.
    Thanks gain for your help.

    PS: I have the same problem with two z9s and UHD2000, so it is not a malfunctioning Zidoo.
     
  12. cappy1

    cappy1 Member

    Hadn't thought to try this, but did so just now. Yes, it holds at 23p.
     
  13. Markswift2003

    Markswift2003 Well-Known Member

    So it definitely looks like the LRP doesn't like the zidoo..

    The key is the blank screen when you try to set 4K23.

    This is either caused by the TV receiving a mode it doesn't like or the LRP blocking it for some reason.

    Have you tried a leap of faith:

    With the LRP in the chain, try to set the Zidoo to 4K23. When the screen blanks, wait for 5 seconds then press <left> followed by <ok> which will force 4K23 and see if the picture comes up. This is the sort of test the Vertex is great for since you see exactly what's being squirted in and out on the web interface regardless of whether you have video or not.
     
  14. cappy1

    cappy1 Member

     
  15. cappy1

    cappy1 Member

    Forcing 4K23p worked. Once set, turning LRP Off then On...no change, still 4K23p. Turning Zidoo Off then On... it reset to 4K60p as expected.
     
  16. Markswift2003

    Markswift2003 Well-Known Member

    What have you got Display/Advanced settings/Deep Color Mode set to in the Zidoo?

    And also Display/Advanced settings/Color Space Mode
     
  17. cappy1

    cappy1 Member

    Deep Color Mode =10 bit
    Color Space Mode = Priority YCbCr444
     
  18. Markswift2003

    Markswift2003 Well-Known Member

    Damn. That's exactly what it should be.

    I can't think of a single reason how the LRP is influencing this - The LRP must be presenting a full EDID with the full raft of VICs and I know from experience when that happens, the Zidoo is happy to stick at 4K23 if that's how you set it.

    Is the Zidoo plugged into a 9GHz or 18GHz input on the LRP?
     
  19. cappy1

    cappy1 Member

    All my inputs are 18 GHz on LRP. Jim Peterson, Lumagen owner, first suggested changing the HDMI cable from my 2 meter cable (certified, 18 GHz) to 3 meters. I have one on order. He also mentioned EDID parser as a possibility. If all else fails, he suggested I send one of my z9s players to him to test at his facility.
     
    Last edited: Jul 15, 2020
  20. cappy1

    cappy1 Member

    Zidoo said they are waiting for results of HDFury Vertex2 since they don't have an LRP...they must be reading our posts.
     
    Last edited: Jul 14, 2020

Share This Page