New firmware v2.3.33 Beta version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by McBluna, Jul 1, 2020.

  1. McBluna

    McBluna Member

  2. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Solved the 3D MVC Seamless Branching issue.(It is mainly shown in some Disney movies)
    Faster frame rate switching. Now the AFR should be done before the movie starts playing.No flickering :)
     
  3. blenky

    blenky Active Member

    So this is to fix two issues only?

    Anyone tried them?
     
  4. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    In fact it is one fix plus one improvement. Indeed installed it.
    As common it needed a GAPP's re-run for the Googles Services to work again.
     
    Last edited: Jul 1, 2020
  5. catorcio

    catorcio Member

    Z10? thank you
     
    Last edited: Jul 1, 2020
  6. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I think this is released just to verify that 3D MVC is working too now being the missing step.
    Maybe it will be crafted for all after a confirmation that it now works as it should.

    @mirror
    After adding a 1 second delay AFR worked for me as intended. Without it it still gave a sound interruption when starting the movie.
    Not so strange with an AMP in between the EDID handshaking which is needing some time.
    Maybe the default AFR Delay should be set to 1 second?
    For me choices could be: 0.2, 0.5, 1, 2, 3, 5 just to enable the shortest matching a setup. Those very long values 7, 10, 15 should never be needed I think?
     
    Last edited: Jul 2, 2020
  7. cavedarter

    cavedarter New Member

    just tested Onwards 3D BD ISO and made it past the first instance of seamless branching with no issue. will test more later tonight, but glad to see it might be solved!
     
  8. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I am pretty confident it was solved just with that:
    http://forum.zidoo.tv/index.php?thr...ss-branching-a-serious-problem-with-uhd.7428/
    My original problem report from January 2018 still in the X9S age.
    May be interesting to read (once more) to know exactly where this is all about and why it is such a big step solving it.

    After lots of attempts and even more time and effort by Zidoo it finally seems to be solved. :cool:
    Some other media players had direct SOC/SDK support for it making this a very hard nut to be cracked on specifically Realtek based players.

    Congratulations Zidoo!!!
     
    Last edited: Jul 2, 2020
    Sampinto89 likes this.
  9. skywalker1978

    skywalker1978 New Member

    Before upgrading to the new beta FW, shall I first uninstall GapsInstaller, than instal the FW, and than instal GapsInstaller again?
     
  10. McBluna

    McBluna Member

    All you've to do after upgrading to new FW is start the Gaps Installer and hit the Install button.
     
  11. DELUCAS

    DELUCAS Well-Known Member

    must admit after all my updates ive never installed Gaps installer never have as such .
     
  12. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I need it for some Music and other APP's bought via the Play Store. If not better to avoid it indeed.

    This is the best FW thus far. Now for improvements to DVD and BD Menu handling. For me that would be the next priority. ;)
    After that and some instability issues (like SPDIF, green screens and spontaneous reboots) the Video Player is becoming very good. :)
     
    Last edited: Jul 3, 2020
  13. DELUCAS

    DELUCAS Well-Known Member

    Agree i avoid Bloat Ware at all costs . :)
    And if we get the new “ X “ or Z9X series we gotta start all over again as such .......

    But if everything was perfect from day one in life be alittle bit boring .
     
  14. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I hope not, I don't think the new SOC is that different after all. Just faster. :rolleyes:

    But yeah you are right it keeps us from the street. :D
     
  15. DELUCAS

    DELUCAS Well-Known Member

    ha :)

    its gone very quite on the new X and x9x front ........
    But id imagine a good time to release hardware for max sales is October on
    But im sure previous releases were this this time ?

    back on topic wheres the Z10 firmware release . ;)
     
  16. Abominog666

    Abominog666 New Member

    Despite my earlier poignant experience with installation of the previous beta (later appeared to be approved as the final release) I couldn't resist an overwhelming temptation to try this one. ...and, expectedly, to be caught in the same trap again. But this time I managed to outsmart the "Google framework stopped working" error since I put gapp installer shortcut on the desktop menu prior to installation of the update. Hence it took me significantly less efforts and pain to overcome the impediment of the system repeatedly spitting the annoying error message, as it was now much easier to reach the gapp installer button from the main menu.
     
    kfpanda likes this.
  17. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Isn't disabling all network services prior to upgrading easier?
    Good habit to disconnect everything not needed prior to USB upgrading anyway.

    Never seen this message myself and done lots of upgrades (I think all ever published by Zidoo for Z9S).
     
  18. Abominog666

    Abominog666 New Member

    Perhaps this malevolent behavior in each particular case depends on numerous factors, like specific setup, history of upgrades, settings, status of hardware, usage, etc. Probably, my case is less lucky than yours.
    Incidentally, I disconnected external HDDs and went offline before the upgrade, which, sadly, didn't seem to help either.
     
    Nice Monkey likes this.
  19. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Thanks for reporting. ;)

    Zidoo really needs to find a solution to this before releasing a general automated OTA update in my modest view. :(
    It potentially brings a lot of problems to those customers never coming to this site and/or doing USB updates. Plenty of those having installed Google Play Store?

    How difficult can it be to detect during the upgrade if GAPP's Installer as an APP is present and to re-run it as the last step when found?
    The root cause is probably caused by Google and may be even on purpose? Nothing that can be done about that?
     
    Last edited: Jul 4, 2020
  20. J.K.uploaden

    J.K.uploaden New Member

    Tested with the Blu-ray 3D ISOs of Star Wars: The Rise of Skywalker, Incredibles 2 and
    Thor: Ragnarok.

    And can confirm that the short picture freeze has been fixed. Good work!
     
    Nice Monkey likes this.

Share This Page