Discussion in 'ZIDOO X9S' started by HoneCharles, Oct 8, 2016.

  1. slavensiz

    slavensiz New Member

  2. valibira

    valibira New Member

    Any news on restore using USB 2.0 TTL UART with firmware 2.1.1?

  3. Janium

    Janium New Member


    Due to all kinds of things I have been very busy as of late and didn't have the time to dive into this. Last week I decided I had enough bricks in my house already and ordered this item from Amazon. After opening my brick I had a difficult time attaching the cables to the UART slot because the tiny plugs proved to be just not tiny enough. After bending the third pin of the UART slot I finally managed to get it right. After some failed attempts (due to not precisely following Slavensiz's instructions) I had Putty connect to my brick. Yay!

    I tried to install version 1.4.12 but it looked like it didn't work (putty ended with an error). Suspiciously, I hooked my brick to my TV.

    Yay!!! The number of bricks in my house is again the allotted number. The unbricking of my Zidoo was successful! Thank you, Slavensiz!

    Next attempt will be the installation of version 2.1.36. Fingers crossed.
  4. Janium

    Janium New Member

    Aaaaaand back to square one. Well, square two, I suppose.

    Installed v2.1.36. Again, no picture.
    Installed v2.1.1. Again, no picture.
    Installed v1.4.12 again, which works.

    I'm glad I got it running, but it is a bit frustrating not being able to update my device.
  5. nomai

    nomai New Member

  6. Tony77

    Tony77 Member

    I actually had your EXACT experience with UART! (funny)
    And after getting it recovered I remember the initial bootup to tv was a bit funky.. I think maybe I booted as a factory reset? holding in pin?? I remember I had to finesse it a bit, but it worked eventually!

    And if you have 1.4.12 working you can't perform a flash upgrade??? (Make sure you try diff USB sticks in usb2 port after FULL FAT32 format! (with the newer OS's u may even need a program to do a proper fat32 format..(I did!)

    PS. I was thinking a bit...does it get past "hello" LCD? if just tv screen is black maybe check ur HDMI cables..the newer firmwares updated some HDMI compliance..
    Last edited: Mar 21, 2020
  7. Janium

    Janium New Member

    Flashing the unit is no problem, I just get no picture. Nothing. Tried different cables, even tried RGB-cable. Nothing. :(
  8. Tony77

    Tony77 Member

    Hmmm.. wish I could help.. I'm having a lot of crashes in HT2.0 myself. (Mostly with dup titles)

    HERE is what u need.. must flash as here: https://www.zidoo.tv/Support/support_guide/guide_target/7WjcmduqUFZKKmVViAFMcQ==.html
    It's a version 2.1.1 ROM FLASH..this seems only way on newer players.

    Do below as last resort but for YOUR situation the above is correct!

    The only thing I can think of is to try the FORCE FLASH? The 1 where u have 4 specific files extracted on the USB, & when u boot you DO NOT press reset button.. have u tried that? Here ya go: https://www.zidoo.tv/Support/support_guide/guide_target/LpUhOsHcwiveq7k9e[ld]3ulg==.html
    Last edited: Mar 26, 2020
  9. Antonio Protić

    Antonio Protić New Member

    I bought about 10 devices, and everything was more or less fine until a few months ago 2 devices didn't upgrade firmware well. I tried everything and nothing helped. In the end, i realized that the box has too many firmware bugs for the selling price. I will not buy anything from Zidoo any more. The company that produces garbage firmware for their products will loose very soon their buyers!
  10. Tony77

    Tony77 Member

    Even if that is true, can you suggest a BETTER alternative???
    I have not found a better product..at least zidoo is ACTIVELY developing!!

    IMHO- Its pretty good unless you're a perfectionist. The only area I wish would be improved is HOME THEATER 2.0.. The reason I say this is because a user spends HOURS, or days, (or more) updating, scanning, & fixing their library..so when it crashes or library/database/posterwall gets corrupted it is a MASSIVE headache! (I get massive crashes on duplicate titles??? Refuse to display together?)

    BUT seems to be improving daily so I hope this gets refined! Keep up good work zidoo!!
  11. Janium

    Janium New Member

    Yes, I did. Didn't work. So, for the time being, I just settled for 1.4.12. :(
  12. Love3Dwatmos

    Love3Dwatmos New Member

    How did you handle the "escape" key. When i press and hold Escape my mouse stops and I lose control of it. I need to either release Escape so I can move my mouse over to the putty window and Load the Zidoo session and open it or I can Alt-Tab over to putty but then releasing the Escape key 3 secondes after turning on the Zidoo still gives me a blank Putty screen. This is the only part of the process that I may be misunderstanding.
  13. Janium

    Janium New Member

    I'm afraid I have no answer... I did it only twice and that was months ago. :(

    (And now that I finally have a working Mediaplayer, I'm NOT going to do it again! :))
  14. Stefano C

    Stefano C Member

    Hi I have seen firmware 2.1.40 for x9s is out...Anybody with x9s bricked have solved maybe installing this update? I'm bricked from many months (maybe 1 year) with 2.1.1 firmware with microstutters with some files and I'd love to solve it..tranks
  15. slavensiz

    slavensiz New Member

    Try like this https://4pda.ru/forum/index.php?s=&showtopic=772588&view=findpost&p=84001793
  16. slavensiz

    slavensiz New Member

    This is your answer http://forum.zidoo.tv/index.php?threads/stuck-at-2-1-1-please-help.64602/#post-113134
    no one will do it for you, get together and do as instructed.
  17. viVo

    viVo New Member

    Hey guys, i have flashed my zidoo X9S with Z9S firmware by mistake. the result is the device loads into android 7.1.1 but i lost the USB ports and wifi, bluetooth devices. i only have the remote control to access the device and the SATA port seems to still function. is there a way to install the X9S firmware without the USB ports?? or can i install a driver or a patch to make the USB ports work again??

    Thank you
  18. McBluna

    McBluna Well-Known Member

    viVo likes this.
  19. viVo

    viVo New Member

    @MacBluna thank you for your reply, The USB ports are dead, they don't even have power in them so im not able to mount the USB disk to perform the factory reset and flash the X9S recovery image. the only port that is working so far is the SATA port. if i do press the rest bottom and power up the device it will show a black screen but the USB disk wont light up or show any activity.

    Update: i used the UART method to flash the device and it worked
    Last edited: Sep 17, 2020
  20. McBluna

    McBluna Well-Known Member

    Could you please explain what the UART method is. I'll add this info to my recovery images page.

Share This Page