Guide to update OpenWRT from 15.05.1 to 19.07.0 rc-2

Discussion in 'HDD Media player(RTD 1296)' started by Thanos, Mar 14, 2020.

  1. Thanos

    Thanos Member

    UPDATE 1/03/2020 - 17:53


    I would like to highlight that this is the file, project from GitHub developer page jjm2473

    • In this tutorial we will see how to Upgrade the OpenWRT from 15.1 to 19.07 easily on the Zidoo device with SoC 1296 ( Z9S in my case)
    • Due to a problem with the OpenWRT part of the Zidoo device (especially with Aria2, Transmission, SAMBA) , I decided to upgrade my current version 15.05.1 “Chaos Calmer” (2016) to a slightly more suitable V19.07.
    Tutoriel :
    Read first : README_EN.MD
    Before 1.3, only supports (Linux 4.1.35-04005-g6c2818e-dirty + Android 7.1.1).

    I. Download the necessary file to update

    1) Go to the Github page, to find the nesesaire file: HERE
    2) Download file “.zip” with the update of OpenWRT here from GitHub :

    - Version preferably 1.3 and above (or higher HERE) according to you need, or your SoC :
    https://github.com/jjm2473/rtd1295-openwrt18-porting

    Or

    - Version RC2 (Relase-Candidat) Release Z9S 2.0.0 with bundle(Z9S 2.0.0 complet edition)
    (What is Relase Candidat ? Wikipedia)

    • RTD1296 (Z9S,etc.)
    Complete Edition (recommended)
    • RTD1295 (X9S,etc.)
    Complete Edition (recommended)

    3) Copy the download file (.zip) to your key formatted in FAT32.

    II. Update from a USB key

    1) On your Zidoo click on Update (Local Update)
    [​IMG]
    2) Choose the file update.op18_2.0.0.signed.zip / or a different version:
    [​IMG]
    3) Flash
    [​IMG]

    III. Overview

    OpenWRT now works on version 19.0.7 :
    [​IMG]

    New Aria2 WEB :
    [​IMG]

    - In my case, this will eliminate previous problems especially with Samba, Transmission and Aria2. All the services I use now work fine, I have better streaming performance.

    IV : OpenWrt configuration reseting package

    This method is suitable for resetting OpenWrt when you can enter the Android system. Just like the usual OTA package, flash reset_op.signed.zip (https://github.com/jjm2473/rtd1295-openwrt18-porting/raw/master/reset_op.signed.zip)
    PS :
     
    Last edited: Mar 16, 2020
    McBluna, am2, DevlopperWEB81 and 2 others like this.
  2. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Interesting. Thank you very much for sharing this experience. Infact Zidoo should think about bundling a newer version. I would use the latest stable version though not a RC2.

    Interesting to see that it uses the Zidoo Android USB update mechanism to install. I hope this procedure does not damage the bootloader by overwriting it in any way.

    A few reminders for others:
    - OpenWRT is part of the ROM image and as such not affected by Android updates in any way.
    So once done this upgrade it will just stay there with any new FW updates.
    - To go back to the original OpenWRT one needs to do an emergency ROM flash.
    - The story about SMB version 1.0 is about running SMB Server. The SMB Client is an integral part of the Android OS (not the Zidoo added FW). Android 7.1 comes with SMB 1,2, 3 support.
    - Above all I hope this procedure does not damage the bootloader
     
    Last edited: Apr 11, 2020
  3. Thanos

    Thanos Member

    Thank you for the information and for clarification.
    Yes, my SMB protocol is 3.* :
    [​IMG]

    After the first upgrade to 19 everything was OK until the restart where the connection disappeared and the connection to OpenWRT was not possible. I used :
    reset_op.signed.zip from here .
    It could have occurred to me to use emergency ROM :rolleyes:




    Previous versions of OpenWRT: https://github.com/jjm2473/rtd1295-openwrt18-porting
     
    Last edited: Mar 14, 2020
  4. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    It is a pity you had to back out. Must be solvable though. Please keep us informed.

    Just tried with the default OpenWRT but also that connects with SMB 3.1.1 protocol.
    So there is no need for upgrading for that reason.
     
    Last edited: Mar 14, 2020
  5. Thanos

    Thanos Member

    Yes, but in the second (clean) installation "OpenWRT 19.07.*, everything as services work fine.
    (at least for now :)) In any case, you can really see a significant difference from the V15 ..
    [​IMG]
     
  6. pcristi

    pcristi Active Member

    Guys first of all I hope your Windows are patch for CVE-2020-0796 is a remote code execution vulnerability in Microsoft Server Message Block 3.0 (SMBv3).
    @Thanos
    What is a Zidoo RTD1296 firmware base for mnt/Android from squashfs1.img on update.op18_2.0.0.signed.zip?
     
  7. Thanos

    Thanos Member

    Yes. The update.zip file (update.op18_2.0.0.signed.zip) contains 2 "squashfs1.img + META-INF" files.
    Only the OpenWRT section is updated. The Zidoo Android version remains the same.
    [​IMG]

    I don't, I'm using linux prediction ;-)
    But thanks for the info, on Windows has the updates turned off.
     
  8. pcristi

    pcristi Active Member

    Last edited: Mar 14, 2020
    Thanos likes this.
  9. Thanos

    Thanos Member

    Unfortunately, I don't understand you. OP means what?
    The fact that the file comes from GitHub I specified and wrote in the first post
    (In addition, I refer directly to Github invocations jjm2473 )
    https://github.com/jjm2473/rtd1295-openwrt18-porting/releases/tag/z9s_2.0.0_full

    PS: I added highlight for to your satisfaction and well-being:
    "I would like to highlight that this is the file, project from GitHub developer page jjm2473"

    You funny.
    Could I try it first, or do I have to pay right now?
    (I like supporting developers, but not in such a intrusive and forced way ).
     
    Last edited: Mar 14, 2020
  10. pcristi

    pcristi Active Member

    Replay to my self base on ZIDOO_Z9S_N_v2.2.82_201907120909_ota.zip
     
  11. Thanos

    Thanos Member

    I personally installed OpenWRt on a different version (v2.3.10) from yours ,I cannot guarantee that it works on your version but I would recommend for more information contact the developers jjm2473 or http://forum.zidoo.tv/index.php?threads/rtd1295-rtd1296-openwrt-package-feeds-package-repo.45071/

    IMHO may be V.18 1.0 (Release 1.0 with bundle) it for you more judicious.
    From Devlopper : jjm2473
    https://github.com/jjm2473/rtd1295-openwrt18-porting/releases/tag/1.0_full
     
    Last edited: Mar 14, 2020
  12. pcristi

    pcristi Active Member

    squashfs1.img is not only OpenWRT is also contend ramdisk file in mnt/Android witch look to be from firmware v2.2.82 then exchange squashfs1.img probably will not introduce problems in Zidoo Z9S firmware v2.2.x/v2.3.x.
    Between I will not go to release 1.0 that is was not stable for me on Zidoo Z9s v2.2.65 after factory reset.
     
  13. Fatih Durmus

    Fatih Durmus Member

    I installed and it is working good for now. Thank you.
    I have a general problem. when I add torrent to transmission or aria2 it is starting more time after. It changes according to file sizes.
    I think it is doing verify data. Dou have this problem?
    Thank againg
     
  14. am2

    am2 New Member

    I think the delay is because you have activated the prelocated option, which reserves the full size of the torrent on the hard disk before downloading it. As the Transmission has to write the complete file depending on the size, the operation takes several minutes.
     
  15. Fatih Durmus

    Fatih Durmus Member

    I selected none. I think it is same. I will test again. But ı forget to say other problem. When I add torrent after a few second (approx 30sec) gui is not respondig. I am waiting for it. Sometimes 20min. It changes file size. Is it normal?
     
  16. Thanos

    Thanos Member

    Hi

    If you have a problem with ARIA service timing, try to look here, and find other possible information about your problem :
    http://forum.zidoo.tv/index.php?threads/tips-and-tricks-unofficial-guides-and-fixes-user-edition.3603/

    I would also recommend you to try another web browser, or try using the "Private navigation" mode, as some of the installed add-ons in your browser may cause some problems.



    Aria2App (open source) - .apk for Android
    To manage Ari2, I used this application, which worked better in the question of checking, setting etc as a web browser:
    https://play.google.com/store/apps/details?id=com.gianlu.aria2app&gl=FR

    [​IMG]


    In my case, the ARIA2 application worked considerably better than the WEB interface, perhaps it could help in your case, at least like the "temporary" solution.
     
    Last edited: Apr 2, 2020
  17. Fatih Durmus

    Fatih Durmus Member

    Hi again.
    I have 3 usb hdd. They cant set standbye or spindown mode when unused. Always full running :(
    I tried hdparm like this "hdparm -S 36 /dev/sda1" I see it set but again always running
    How can i solve this problem.
    Thank you,
     
  18. lucausee

    lucausee New Member

    Hi, where i can find a guide to configure openwrt with a macbook? and about a NAS service is better to exchange files ? thank you in advance
     
  19. Thanos

    Thanos Member

    Hi!
    • Which version of OpenWRT do you use exactly? 19.07?
    • I had the same problem. In my case it helped to use restore setting with "reset_op_signet".

    reset_op_signet for download here :
    https://github.com/jjm2473/rtd1295-openwrt18-porting/raw/master/reset_op.signed.zip

    • The procedure is the same as for the update.
    Download the ZIP file to a USB key, and then update from your USB key.


    *In my case it worked, but the connected HDDs are automatically mounted after reboot.

    [​IMG]
     
    Last edited: Apr 7, 2020
  20. Fatih Durmus

    Fatih Durmus Member

    I was installed 19.07. I tried reset but same. Always full running. There was no problem before on 15.05.
    I turned back to 15.05 and sleep mode working auto. (I didn't set anything)
    I installed again 19.07 and same again. Always full running
     

    Attached Files:

    • info.jpg
      info.jpg
      File size:
      200.8 KB
      Views:
      21
    Last edited: Apr 7, 2020

Share This Page