Guide to update OpenWRT from 15.05.1 to 19.07.0 rc-2

Discussion in 'HDD Media player(RTD 1296)' started by Thanos, Mar 14, 2020.

  1. McBluna

    McBluna Active Member

    @Mirko87 from my experience the only way to fix eg any missing library dependencies caused by an OpenWRT update, is to flash the recovery image.
    I've updated to 18.06 and played with the libraries and at the end I couldn't navigate in the blu ray menu anymore. There is a direct dependency between OpenWRT and how the player works.
     
  2. Mirko87

    Mirko87 New Member

    you're always right. Meanwhile i had figured out that the only way to recover UHD2000 succesfully is this one:

    https://www.zidoo.tv/Support/support_guide/guide_target/EDuEFhCL20beq7k9e[ld]3ulg==.html
     
  3. tz4

    tz4 Member

    So finally, is it worth an upgrade to newest openwrt version, or should I leave it factory default version? Looks like it is more stable. McBluna has also deleted his version from his site.
    My only problem with the original version is the MiniDLNA service, which is need to manualy restart after every reboot.
     
  4. Mirko87

    Mirko87 New Member

    I don't know. I suppose this depends strictly on your device model. I rolled back to original 15.05 and still haven't tried any other version as it bricks the device and it's a pain in the arms...
     
  5. tz4

    tz4 Member

    I have an X20.
     
  6. Mirko87

    Mirko87 New Member

    Idk, you should try and be prepared for the worst: bricking device means you will be forced reset device to reflash stock firmware.
    McBluna for example, had problems to get some functions to properly work, while I have experienced bricking after few minutes working.
    Maybe OP Thanos knows something more
     
  7. Schumy

    Schumy Member

    hi guys, I try to do this with my Z9S but under the Samba service windows it gives the follow error lines and does even provide an GUI interface, appreciate your advice, many thanks:

    /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute cbi dispatcher target for entry '/admin/NAS/samba'.
    The called action terminated with an exception:
    /usr/lib/lua/luci/cbi.lua:311: Unable to read UCI data: samba
    stack traceback:
    [C]: in function 'assert'
    /usr/lib/lua/luci/dispatcher.lua:433: in function 'dispatch'
    /usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>
     
  8. Mirko87

    Mirko87 New Member

    Idk if this can help: https://github.com/openwrt/packages/issues/10492
     
  9. Mirko87

    Mirko87 New Member

    btw after flashing stock fw, upgrading to latest fw, then upgrading openwrt to 19.07.0 rc2, it finally worked stable. reset_op package is very handy, had to use it a couple of times while doing the config from scratch (experienced blank config web pages for some services).
     
  10. Schumy

    Schumy Member

    thanks Mirko, but that link seems to be for resolving the 'luci.cbi' not found problem, whereas my case the error log seems to suggest the problem is "Unable to read UCI data: samba"...so I really have no idea how to fix it.

    Is it possible to reinstall OpenWrt?

    Thanks
     
  11. Mirko87

    Mirko87 New Member

    First try and reset conf for ooenwrt with reset_op package. Then if you don't resolve, try to reinstall owrt 19.x.x rc2
     
  12. cNone

    cNone New Member

    Hello all,

    I have installed OpenWRT 19.07 as per instructions here but reverted back to 18.06 with instructions offered by McBluna, because of unstable samba and transmission. I am using private trackers and some of them banned Transmission 2.94 and I have to use Transmission 3.0 on those trackers. So my question is; can I have Transmission 3.0 without upgrading OpenWRT to 19.07? If possible where can I download appropriate package?

    Thanks in advance :)
     
    Last edited: Jul 10, 2021
    tz4 likes this.
  13. cNone

    cNone New Member

    Hello,

    I have checked the transmission build on this build and mine is 2.94. How did it happen :)
    Turkce not da ekleyeyim: Nassi oldu yahu, ben baya ugrastim :D
     

Share This Page