Dolby Vision FREEZE at approx. 1h16m / multiple titles (UPDATED)

Discussion in 'HDD Media player(RTD 1619DR)' started by Markswift2003, Mar 2, 2021.

  1. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Following on from the conversation in the 1619 v6.1.05 beta thread...

    For some reason it seems that certain Dolby Vision titles, when ripped to MKV will exhibit a complete freeze at approximately 1 Hour and 16 minutes into the presentation.

    The bizarre thing about this is the timing - it's always within a minute of 1hr 16m. This kind of negates the theory that it's somehow related to a layer break.

    Up to now, although I've reported this to the devs, I'd kind of forgotten about it since I'd only ever seen it on one Dolby Vision title - 2001 A Space Odyssey.

    Since it came up on the v6.1.05 beta thread, I thought I'd look into it a bit more.

    So it seems to be a much bigger issue than I expected.

    After asking for titles that exhibit this issue, I've tested those suggested, with surprising results..

    I'll post these results tomorrow, but in the meantime, if anyone has any more suggestions for titles showing this problem, I'd be really interested to know which ones.

    To reiterate - this is for Dolby Vision titles that freeze at approx. 1hr 16m and not any other issues like stuttering etc.

    So far, I've tested:

    2001 A Space Odyssey
    Angel Heart
    Gemini Man
    Mortal Engines
    Lord of the Rings Trilogy
     
  2. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Test Results:

    These tests were carried out on MKV files ripped from the UHD BluRay discs using MakeMKV v1.16.0


    1. Angel Heart

    No issues in playback to end of movie and no issues in debug log. MEL title played back in native DV.

    2. Mortal Engines

    No issues in playback to end of movie and no issues in debug log - but this is expected since this is a FEL title and so only plays the HDR10 base layer.

    3. 2001 A Space Odyssey

    Freeze at approx 76 minutes. debug log shows multiple VES Splitter checksum errors from playback start:

    D/Splitter( 2005): [2961]FIXME_DV!!m_vesBSringAccuOffset:-1187851119 not match sum:-1187851123

    This culminates in the playback engine halting.

    3. Gemini Man

    Freeze at approx 76 minutes. Debug log shows different to 2001 which I wasn't expecting. This time the error is:

    D/Splitter( 1984): [2257]VES ring(r:0x157217a9.w:0x158d9182(fw:0x158d9182).b:0x1519e000.vb:0xaa082000,size:16777216).newData:1800665(1800665).w2r(-1449676148,0,0).w2f(0,0,0).

    D/Splitter( 1984): [3044]not found.set m_vesRpAccuOffsetRptr:1312.frmStart:0x710fa7bc.startWp:0x70bbb28c.currWp:0x70bbb28c.


    So still problems in the VES splitter, but this time nothing like the number previously.

    These errors are in the order of 100's of thousands where the 2001 errors are in the order of millions.

    4. Lord of the Rings: The Followship of the Ring Parts 1 & 2


    Again, both titles freeze at approx 76 minutes and again the VES Splitter errors are the same as Gemini Man and in the order of 100's of thousands.

    D/Splitter( 2011): [2257]VES ring(r:0x154515a5.w:0x1549155c(fw:0x1549155c).b:0x151a5000.vb:0xb1582000,size:16777216).newData:262071(262071).w2r(-1556454165,0,0).w2f(0,0,0).

    D/Splitter( 2011): [3044]not found.set m_vesRpAccuOffsetRptr:3446.frmStart:0x70b40154.startWp:0x705e64eb.currWp:0x705e64eb.
     
    Last edited: Mar 3, 2021
    pcristi and xskip like this.
  3. cucnz

    cucnz Active Member

    To me since id noticed them all freezing at around that 1 hr 16/17 mark , thats what first made me think it was actually due to the layer break

    ie 100 Gig disc assume layer break at around 50 gig ,so 50 gig ish for first hour or so of the movie , with the remainding movie and all the addes BS they fill the discs up with on the second layer

    And ,with the movies all having the DV ,and say DA /DTX info , it would seem ligical that theyd all hit the layer break around similar times


    plus as id said when i originally suggested the issue was due to layer break
    I remebered that a couple years ago id read about 4k uhd bluray players and issues with pauses/stutters at the layer breaks
    An issue im sure was eventually fixed in player firmwares
     
  4. ammar11

    ammar11 Active Member

    Do we have to watch all the way to the 1 hour 16 minutes mark, or can we just fast forward?

    If fast forwarding doesn't cause the issue, it's not a layer break.

    PS: 100GB XL blu-ray discs GB disc has 3 layers.
     
  5. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    You can certainly get layer break pauses with UHD BluRay players due to the laser refocusing and processing the transition from one data stream to another, but that obviously doesn't apply to a single ripped file. The very fact that these freezes occur at the same time point in a video stream negate that this is due to layer breaks since their position varies greatly from movie to movie due to, amongst other things, authoring choices and data rates.

    Also, there are errors in the Dolby Splitter processing which start as soon as the stream starts - again, nothing to do with a layer change and culminating in the player crashing.
     
  6. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    No, the stream needs to run for about 76 minutes from wherever you start - so if you start the movie at say 23 minutes in, the freeze will occur 76 minutes later at 1hr 40m which again negates the layer break theory.
     
    xskip likes this.
  7. ammar11

    ammar11 Active Member

    Thanks Mark. Yep, not layer break. So it’s consitent at 76 minutes of watching. Seems like a glass can only hold so much beer anything more than that it will spill. Could it be related to buffering/memory?
     
  8. ammar11

    ammar11 Active Member

    Just tested Fellowship of the Ring. I let it play while I work, the perks of working from home!

    It froze at 77 minutes on mine. The only workaround is to stop and resume so it resets the 76 minutes counter. For movies longer than 152 minutes you have to do that twice. :D
     
  9. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    It's got to be along those lines.
     
    ammar11 likes this.
  10. rozel

    rozel Active Member

    @Markswift2003 - all the LOTR demonstrate this issue - all 3 titles and both discs in each. Haven't experienced the issue in Gemini Man
     
  11. Inikad

    Inikad Member

    Could pausing a DV movie for a few minutes and resuming playback be related to the freeze coming later?
     
  12. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Definitely the Dolby Vision version?
     
  13. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    No sure, haven't tried, that but it's possible.
     
  14. rozel

    rozel Active Member

    Yes
     
  15. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Weird - It definitely froze at the 76 minute mark and the debug log showed the same Dolby VES Splitter errors - I wonder if we have different disc sources.
     
  16. ammar11

    ammar11 Active Member

    Just started Gemini Man. Will report back in 76 minutes.
     
    Last edited: Mar 4, 2021
  17. ammar11

    ammar11 Active Member

    So Gemini Man is now frozen at 75 minutes 34 seconds.
     
    Markswift2003 likes this.
  18. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Thank you for the confirmation.

    So I wonder what's different about these titles to ones that play without error?

    Certainly they're all produced with MakeMKV although it's worth noting that 2001: A Space Odyssey was created with MakeMKV v1.15 and the others with v1.16 and the errors are different on those created with the later version.

    This might be coincidence, but I'll try reinstalling v1.15 and try on the later files to see if I get the earlier error...
     
  19. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Can you have a look at Gemini Man in MediaInfo and copy the info here please - just want to compare with mine..

    From the MediaInfo screen - File/Export (as text) and set the destination as required.

    upload_2021-3-4_9-10-17.png
     
  20. OlivierQC

    OlivierQC Well-Known Member Beta test group

    Hello,

    Concerning gemini man for example I had this problem at the beginning of January with the fw 0.90 and I speak about it in one of my messages, with the mkv dv of The Hobbit it can happen but it is random and rarer.

    I have the 6 ISO DVs of the Lord of the Rings, which are read in HDR by the Zidoo and no problem for the moment and I've watched it several times, (I love these movies)

    see you
     

Share This Page