Beta version v6.4.35 for Z9X/Z10 Pro/Z1000 Pro/UHD3000 release

Discussion in 'HDD Media player(RTD 1619DR)' started by mirror, Sep 30, 2022.

  1. Nicholas Hewitt

    Nicholas Hewitt Active Member

    It is on TV LED. I have HDR set to LLDV.
  2. cucnz

    cucnz Active Member

    got me lost then
    only time i have those issues is playing round with the LLDV TV DV setting in compatibility section

    swapping from auto to any of the others in the hdr section shouldnt be an issue especially once you change it back to auto or like lots use set to vs10 SDR HDR
  3. azon1951

    azon1951 Active Member

    Is this normal? I enable VS10 in SDR, HDR and DV content but when I'm playing DV, the VS10 icon didn't not appear. Only in SDR and HDR content.
  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Depends on the display.

    If the display is SDR or HDR only then the VS10 icon will appear, if the display is DV then the Dolby Vision icon will appear.
  5. azon1951

    azon1951 Active Member

    Thank you. Currently experiencing this right now. When I'm watching HDR&DV in ZDMC the screen goes with this green thing... tried to use Zidoo Player but the audio is choppy (AAC 5.1). Need to reboot the device to be okay. My TV support DV & HDR10+. This is the 3rd time it happens.
  6. Blue Stinger

    Blue Stinger Member

    This is absolutely normal. When playing native DV content, VS10 is not used because it is not needed.
    azon1951 likes this.
  7. cucnz

    cucnz Active Member

    cos DV is the higher mode to use VS10 for pure DV content would be a downgrade even if minor
    azon1951 likes this.
  8. Nejiro

    Nejiro Member

    I put this firmware and tonight I started watching some movies, a strange thing happens to me, I don't know if it's just mine or someone else's problem, practically all mkv files with dts-hd go in normal dts, I don't have changed any setting and I had never had such a problem before, how can I fix it?
    Thank you
  9. Cranks

    Cranks Member

    I reckon the picture quality with VS10 set for SDR, HDR & DV with this firmware is the best so far.
    The only gripe I have is the time delay for when an image appears on screen. It is about 4 to 5 seconds. I have tried a number of display resolutions that are fixed but I can't improve this delay time.
    Any suggestions?
    vddan likes this.
  10. Stove

    Stove New Member

    I’ve been troubleshooting some performance issues on SMB and noticed that the the Z9x is using a read request size of 65535 bytes when accessing a file over SMB either playback or a copy to local storage. In comparison a Win11 client is using a request size of 1M. These have been confirmed on Wireshark.
    This results in a limited throughput of 12-20MB/s on the Zidoo whereas I get 95MB/s on the Windows client. I have tried both Win11 and MacOS as the SMB server and it is the same behaviour.
    Is there a way to increase read request size of the SMB client configuration on Z9X?
    vddan, lawdawg and azon1951 like this.
  11. azon1951

    azon1951 Active Member

    Agreed. Super SLOW.
    vddan likes this.
  12. Stove

    Stove New Member

    Not sure if this has always been the case? I am running the beta but I had performance issues on SMB on the latest general release as well though I’ve only confirmed by wireshark on the beta..
    vddan likes this.
  13. ursiel

    ursiel Active Member

    I've been running on v 6.3.92 on my Zx9 for months. There have been some serious bugs I've been putting up with. The worst of which:

    - When playing iso or mkv, the audio stops/drops near the very end of the video, at the last 15-20 seconds during the credits. The video still plays, but there's no sound. This happens frequently. I never get to hear the end of the music during end titles.

    - Sound will often fall out of sync once during playback. I have to stop, go to "clean up", clean the cache, then resume playback, then it's in sync again.

    - If using the navigation bar to skip to various parts of the video, the player will eventually freeze and become unresponsive if I skip around too much (like looking for a certain part of the video). I have to hit the home key to get back to the main menu and then resume.

    Have these issues been fixed by now? These are major playback issues that should not be occurring.
    Last edited: Oct 9, 2022
  14. Deano86

    Deano86 Active Member

    If you have VS10 set only for SDR, HDR and DV... that means that the GUI is still on whatever resolution and frame rate and using the Realtek engine to display ... the delay is most likely due to the switching to the VS10 engine for your sources.. I have my default resolution at 4K and matching frame rate only with VS10 for everything and I get no delays or black screens.
    Cranks likes this.
  15. ursiel

    ursiel Active Member

    Is there a running log of all changes between beta versions for the Zx9? The last version posted on Zidoo's main site is v6.3.9.2 in April. The only versions I can find in the forums are this latest version and v6.4.20. I would like to see a changelog of all fixes between v6.3.9.2 and v6.4.36, so I can see what's been fixed/added.
  16. Deano86

    Deano86 Active Member

    Anytime any new Beta firmware is posted in this forum, there is a new thread created and it is accompanied with a list of updates and changes... so not really difficult to keep up on the changes. But, if you really want to see a nice running list of changes with all the firmwares and apk firmware and change logs, then I recommend using the excellent McBluna site for the Zidoo models!
    xskip likes this.
  17. ursiel

    ursiel Active Member


    I just installed this latest firmware on my Z9x, and yet the audio STILL drops out near the end of the end titles. The last 10-20 seconds of audio goes silent.

    Why does this happen?? It's been happening for months. Audio is fine through the entire film (unless it falls out of sync which happens for no reason), then the sound stops just before the movie ends.

    My Dune Vision player does not do this. It plays the audio right up to the last second, every time. This only happens on the Zidoo.
    Last edited: Oct 9, 2022
  18. Nicholas Hewitt

    Nicholas Hewitt Active Member

    I literally did a factory reset, then set everything to the recommended settings. Then all I did was change HDR to LLDV and now can't set HDR to auto cause I get a black screen. the only part on this screen that is slightly visible is the words in the prompt asking me if I would like to keep the settings. And even then the faint words are pink.
  19. Scavenger

    Scavenger New Member

    I'm a newbie at this. I updated my Z9X to 6.4.36. Everything works fine. So I tried out your suggestion of setting my custom EDID to the "600MHz Rec709 SDR.bin" from the link you provided. However, after rebooting the Z9X and testing on a couple of DV files, the video would show for 1 sec and then goes blank, with the audio still going as normal. My projector is the Sony VPL-HW40ES, which is just a 1080p HD projector with no HDR capability. What might be the problem that's causing the blank video? Do I have to use a SDR EDID specifically for the Sony VPL-HW40ES? Btw, I turned off the Custom EDID option and the DV videos are playing fine now, with the VS10 option showing up. Just wanted to test to see if there's any perceived video quality difference with a custom EDID ... Thanks in advance.
  20. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    That EDID is 4k which would explain why the projector won't play the files (they'll be output in 4K).

    There's no need to use an SDR custom EDID if you already have an SDR display.

Share This Page