Beta version v6.3.22 for Z9X/Z10 Pro/Z1000 Pro/UHD3000 released

Discussion in 'HDD Media player(RTD 1619DR)' started by mirror, Jul 17, 2021.

  1. rere130

    rere130 New Member

    With this options no problem for me to decode anything (with an amv of course) :
     

    Attached Files:

  2. giangi76

    giangi76 Active Member

    If think this is actually the logic and the difference between "Auto" and "RAW". "Auto" checks what the unit on the other side of the HDMI output supports (so if you don't have lossless DTS decoding it will output the core)...RAW is just plain bitstream, so if you can't decode lossless DTS you will have no sound output.
    Does it make sense?
     
  3. xpeczk

    xpeczk New Member

    Samsung website:
    Supported models for eARC


    • TV: UHD TU7000 and above models. (Mine is included)

    • Soundbar: Q70T and above models. (Mine is included)

    • Audio format: The latest high bitrate audio formats are supported including DTS Master, DTS:X, Dolby TrueHD, Dolby Atmos and more.
    https://www.samsung.com/levant/supp...t-is-earc-and-how-to-set-on-samsung-smart-tv/
    It's not the Tv or the soundbar

    If i connect the Zidoo directly to the soundbar on RAW it will play the lossless dts-hd and dts-x and any audio format. If the Zidoo is connected to tv and audio is passed-through to the soundbar, on RAW it will play Lossless TrueHd/Atmos DD+ etc., but it will not play dts, dts-hd or dts-x; on AUTO it will play DTS.
     
  4. giangi76

    giangi76 Active Member

    I think you've got all the answers. For me it's without any doubt a TV problem. By the way, I read what Samsung claims about your TV model...but here's what Rtings reported during there test (with your same extact model):

    ARC Yes (HDMI 2)
    eARC support Yes
    Dolby Atmos via TrueHD via eARC Yes
    DTS:X via DTS-HD MA via eARC No

    Try with a BD Player as I suggested before. If the same happens, well you'll know who to blame for sure. And by the way, as it seem to work perflecty, why don't you just connect the Zidoo directly to your soundbar??
     
  5. xpeczk

    xpeczk New Member

    I don.t have a BD player any more, i will try later to install Kodi on the Zidoo to see if it works, or borrow a BD from someone, but i doubt it's the eArc. I don.t want to connect it directly to the soundbar, i loose some features and also complicates things for me.
    Thanks for trying to help, will test earc too to confirm.
     
  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    With the Zidoo connected as you want it, can you go to Settings/Display/EDID/Save EDID and post the file here (change the suffix from .bin to .txt so the forum will allow it to be posted)
     
  7. xpeczk

    xpeczk New Member

    Thank you very much for looking into this.
     

    Attached Files:

    • edid.txt
      File size:
      256 bytes
      Views:
      9
  8. pcristi

    pcristi Active Member

    I have problems DTS-HD or DTS-X passthrough like DTS core event HDMI is set RAW.
    This always happens for me when mkv container have more then one audio track and DTS-HD or DTS-X are not default.
    1 Video
    2 DTS-HD/DTS-X (original language)
    3 AC3 5.1 (foreign language) default YES
    4 AC3 2.0 (Commentary)
    Old Zidoo X9S, Z9S not suffering by that problems.
    To get DTS-HD/DTS-X passthrough correct first need switch to other audio track then select DTS-HD/DTS-X again.
    Enjoy media collection.
     
    Last edited: Aug 1, 2021
  9. rere130

    rere130 New Member

    @xpeczk :
    I test for you with my TV (Oled Panasonic GZ1500) who decode Dolby but not DTS, like your Samsung TV :
    - AMV (Denon avr-x3600h) connect to HDMI 2 port arc on TV (don't have earc but that's not matter) and the Zidoo connect to port HDMI 1 on TV : Dolby Atmos OK but movies with DTS play in PCM stereo. I can simulate DTS or other system sound with my Denon.
    - AMV (Denon avr-x3600h) connect to HDMI 2 port arc on TV and the Zidoo connect to port HDMI on AMV : no problem with DTS or DTS-HD.

    Si I think your soundbar simulate DTS. If you choose direct audio from your soundbar, you will have PCM stereo too.
    Definitivly it's TV your problem, sorry
     

    Attached Files:

    Last edited: Aug 1, 2021
  10. giangi76

    giangi76 Active Member

    This is really strange...never happened to me with any FW. Just to understand: this happens to you with Zidoo connected directly to a receiver / processor / soundbar or to a TV?
     
  11. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Ok - it's as I expected.

    First thing to say is that this isn't a Zidoo issue.

    Any box can only push out what it's told it's allowed to push out by the EDID.

    In this case, the Samsung EDID is telling the Zidoo it can only spit out L-PCM, AC-3, Enhanced AC-3 and MAT.

    There is no mention of DTS-HD or even DTS in the EDID, so as far as the Zidoo is concerned, it's not allowed to push DTS or DTS-HD.

    Try the attached EDID (again, rename back to .bin) loaded into the Custom EDID of the Zidoo. This is the same EDID with the addition of DTS and DTS-HD blocks so the Zidoo will push DTS and DTS-HD. Whether the TV will pass that on, I'm not sure.
     

    Attached Files:

    giangi76 likes this.
  12. giangi76

    giangi76 Active Member

    This is a good point I didn't think of! (maybe because I just hate soundbars! :D:D )
     
  13. giangi76

    giangi76 Active Member

    Hi Mark. May I ask you how your able to look into the EDID file? Is there a software? And by the way that was not my EDID (you renaimed it Giangi76), but @xpeczk one :p:D
     
  14. Enet

    Enet Member

    The only other minor issue is that on posters with white or light backgrounds the watched status is invisible. It's not very important but it is annoying. At your convenience is there a way we can change its colour or put some other indicator like this one?

    mceclip6-1.png

    In this case it's the orange triangle. But the point is something that can be seen and it doesn't matter if the poster is black or white. Thanks.
     
  15. xpeczk

    xpeczk New Member

    Right so i tried it and it didn.t pass through anything. Very strange, technically it should of worked, considering it's playing everything else and samsung's specifications says it can via pass-through on eArc. On Hdmi Auto it might be like @rere130 said it simulates dts.
    When I saved the .bin file I had in the tv settings the audio set to auto instead of pass-through, but i don.t think it matters.

    Anyway thank you everyone for addressing this problem, if i'll need to watch a dts i'll connect it directly to soundbar, no other option
     
  16. giangi76

    giangi76 Active Member

    I'm afraid those specifications from Samsung are wrong. EDID can't fail (it just reports what a unit is capable of) and also Rtings confirmed your TV (as any recent Samsung TV) doesn't support DTS tracks of any kind and in anyway (direct or pass-through)
     
  17. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Oops - sorry!! I have a lot of EDIDs on my desktop ;)

    The attached one is yours - I think we've figured out the TV won't pass DTS but it's worth a try...

    The software I use is Deltacast E-EDID Editor:

    https://www.deltacast.tv/products/free-software/e-edid-editor
     

    Attached Files:

    dr4go, giangi76 and pcristi like this.
  18. giangi76

    giangi76 Active Member

    No Mark, it's not mine! It's xpeczk's EDID... he's having issues with DTS on his TV... I don't have problems...my Zidoo is connected to a Yamaha processor...I really don't care what the TV can or can not decode!! :D:D:D

    But thank you very much for the software link!! :)
     
  19. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I've changed the attachment now, but it was originally your LG :rolleyes:
     
  20. giangi76

    giangi76 Active Member

    Ah ah!! :D... and thank you again for the software tip... very interresting!!!;)
     

Share This Page