Beta version v6.1.05 for Z9X/Z10 Pro/Z1000 Pro/UHD3000

Discussion in 'HDD Media player(RTD 1619DR)' started by mirror, Feb 4, 2021.

  1. Hugh

    Hugh New Member

    ok, I will try that.. thanks
     
  2. Hi, I am getting a white snowy screen when my z9x is finished loading after boot. Pressing the resolution button is the only thing that returns it to normal. If it wasn't for that I'd have a useless brick. the reset button did nothing. it's not a resolution problem cause I have the resolution locked, so pressing the resolution button keeps it the same, yet fixes the white screen.
     
  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    That would indicate HDMI transmission issues - the first thing to check is cabling and switching if applicable.

    Make sure the colour settings are as per this thread:

    Recommended Settings and other useful stuff for RTD1619 Players

    Display/Color Settings/4K 50~60Hz: Priority YUV420 10BIT
    Display/Color Settings/4K 23~30Hz: Priority YUV444 10BIT
    Display/Color Settings/Non-4K: Priority YUV444 8BIT


    This makes sure the box sends the correct 400MHz signal for 4K60 (Except 4K60 LLDV) and doesn't needlessly up the bandwidth.
     
  4. I'm using the HDMI cord that came with the z9x. It plays lldv fine at 2160p60 12bits bt2020. So I don't understand how it would be the cable. I only have this issue on the initial start-up. After that, it plays everything and anything at the resolution I gave. I followed the colour settings from your guide already.
     
  5. It was working fine till I updated the system, and that's when it started. I didn't change any settings before I updated.
     
  6. cucnz

    cucnz Active Member

    it might be a boot up order issue?

    ie if tv reciever zidoo all turning on at ame time

    try tv reciever pause the zidoo 30 secs then boot it on see if it effects things
     
  7. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    With the greatest of respect to Zidoo, the HDMI cable that comes with it is pretty much the same as any HDMI cable that comes with any other kit for free - ie barely adequate. If you're lucky.

    I always always use Premium Certified HDMI cables just so I know they aren't the issue when problems arise. And you don't need to spend a fortune on them - in fact you're a fool if you do - I use these ones:

    https://www.amazon.co.uk/gp/product/B07FQVJYDW/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

    I'm not saying the cable is definitely the issue here, but it's always best to eliminate them from the equation.
     
  8. ulna68

    ulna68 Active Member

    as someone wrote here: CEC is the devil's spawn. Either it works or it does not work, I have quite an extensive set, if I want to turn on the TV, I take the remote control from the satellite decoder, if I want to turn it off, if I want everything to turn off, it only works with the TCL TV remote control, I got used to it and I do not complain :)
     
  9. I actually am using a TCL. I have only the TV, and the z9x connected. Like I said it was working fine before I updated, so I don't see how it could be the hdmi. I have CEC off so....... don't know what else to try.
     
  10. I'll try switching the cable out, and see if that works, but don't see how it not working after updating has anything to do with the hdmi cable
     
  11. cucnz

    cucnz Active Member

    i got round making sure everything turns off in a simple way

    Get a multi socket power adapter that has a control port on it
    I plug the TV in to the control port and all devices i want it to turn off , in to the sub ports
    They also usually have some never off ports

    then i just tell Alexa to turn the lunge tv off ,and amp etc all go at same time ,with no CEC issues
     
  12. It doesn't matter what order I turn them on or off, the end result is the same. I only have the TV, and the zidoo z9x, so I don't think that's too complicated. I usually turn the z9x off, and on last after the TV.
     
  13. I might just send it back. Cause I tried re-installing the update, but didn't help. I might try a couple other things. Any other ideas before I give up?
     
  14. ulna68

    ulna68 Active Member

    what is your TCL tv model ?? have you updated the firmware on tv ??
     
  15. It is a TCL 55R617-CA. It auto updates, so it's always up to date.
     
  16. I appreciate everybody's help, and hopefully there's a solution. I mean it's not that big of a deal seeing as I only have to push the resolution button to fix it. At the same time it's so close to being bricked if something happens to the remote or an update changes the resolution button functionality in any way.
     
  17. ulna68

    ulna68 Active Member

    and zidoo automatically updates you ?? do you upload new software ?? if you connect to automatic update, you probably have a very old version of the software, I have TCL 65x10 myself and, like in zidoo, I have new updates manually because in OTA there are very old versions ...
     
  18. My TCL updates just fine.
     
  19. Just tried another HDMI cable, and it didn't change anything. Checked my tv for an update, but it was already on the latest firmware. Any settings that could cause the white snowy screen?
     
  20. I figured it out. It was HDMI range. I had it set to the recommended settings, and thats what was causing the problem. Setting it to auto fixed it. Someone might want to mention in the recommended settings post that if they get a white screen to set it to auto. Thanks everybody that was trying to help. I really appreciate it.
     

Share This Page