Beta version v1.0.75 for Z9X Pro/Z20 Pro/Z2000 Pro/Z2600/UHD5000 release

Discussion in 'HDD Media player(RTD 1619BPD)' started by Markswift2003, Jan 9, 2024.

  1. domi80

    domi80 Member

    i have the 1.0.75 firmware from this site. is the same as the firmware 1.0.75 here? Firmware before everything works correct. menus also. equalizer 2 no problems. with this 1.0.75 firmware its shit. hope it will be fixed. liked the firmware before
    gymnos likes this.
  2. Visconti12

    Visconti12 Active Member

    As far I remember Mcbluna updated firmware 1.0.75b days after he posted it. I recommend you to update it from either source.
    Last edited: Feb 26, 2024
  3. domi80

    domi80 Member

    thanks do you have firmware version for me? link?


  4. Visconti12

    Visconti12 Active Member

    Simply go to the first post of this thread!
    blenky likes this.
  5. DaMacFunkin

    DaMacFunkin Active Member

    I've finally got round to giving DoVi baker a go, this program basically Re-encodes the FEL layer into a HDR10 compatible base layer and then injects the RPU to make a profile 8.1 MKV it *should* give the intended Picture experience. I've done 3 movies now and if you have the computer specs it is well worth it, SPR came out really good and once a title is done it is done. To add to this I owned the original Oppo 203 and a clone and was always slightly underwhelmed by it's DV colour performance, I think Vincent did some videos specifically about this - But that argument is now put to bed, currently happy with Zidoo representation of these movies.
    darky_zidoo likes this.
  6. TardisJockey

    TardisJockey New Member


    1st time poster, long time reader. I have a Z2600 on this latest firmware. It is connected to a Marantz 7015 AVR which is connected to a LG G3 OLED.

    All my media is on an internal 16TB Ironwolf Pro HDD. All are 4K MKV rips made using MakeMKV and contain the video file, the English soundtrack (Atmos, DTS-HD - whatever is most “advanced”) and any English subtitles.

    The problem I have is that any movie I play works fine…for a while, then it kicks out to the movie poster. If I hit play again it doesn’t continue where I left off, it starts again from the beginning. In the 2months I’ve had this player I haven’t got to the end of a movie once.

    For info I have the player set up using the settings provided by another thread on this forum somewhere
    “Recommended Settings and other useful stuff for RTD 1619BPD Players”

    Does anyone else have this problem or a solution I could try?

    Thanks in advance for any help provided
    Last edited: Feb 26, 2024
    gymnos likes this.
  7. Korgik

    Korgik New Member

    Tell me please

    there is zidoo z2000 and benq w5700
    outputting content using vs10 hdr to sdr (vs10 SDr Reс709)

    but it is noticeable that on HDR10 films there are few details in the shadows and, as a result, the brightness is lower
    on SDR and DV everything is fine

    is this a firmware bug?
    why is all HDR less bright?

    HDMI range is limited everywhere
  8. ivocky

    ivocky New Member

    Dobrý den, (TardisJockey) mám Zidoo UHD 5000 a mám podobný problém, film se zastaví na cca 30 sekund. a pak to pokračuje, problém je s vloženým HDD v zidoo. Zkuste tedy připojit HDD přes USB nebo hrát po síti přes sambu.
  9. blenky

    blenky Well-Known Member

    Most people don't have any issues playing MKV files on a Zidoo. I can only guess its a source file issue. You say it plays fine for 'awhile'. How long is 'awhile'. Is it always the same amount of time? Does it fail in the same location each time?
  10. cucnz

    cucnz Active Member

    is it an issue regarding format style of hdd? ie fat32 limits to 4 gig
  11. TardisJockey

    TardisJockey New Member

    It can vary by file. As an example, one I tried yesterday lasted about 30mins before kicking out, another today lasted just over an hour. Then after restarting the file & scrubbing back to where it failed, it kicked out again after another 10mins. Later that day I started the same movie again from scratch and it kicked out at just under an hour but when I started it again (and scrubbed to where it failed again) it played all the way through to the end. It seems random on each file I try.
  12. TardisJockey

    TardisJockey New Member

    I don’t think so, it isn’t formatted in fat32 and has files on it from 40 to 90 GB.
  13. cucnz

    cucnz Active Member

    can you try a file over smb from say your pc just to eliminate an issue with the internal HDD or associated internal pathway/parts or from an external hdd in the usb3 port
  14. TardisJockey

    TardisJockey New Member

    I’ll give it a shot tomorrow & get back to you. Thanks for the suggestions
  15. nutzer

    nutzer New Member

    i have exactly the same problem (also have a SDR-Display). with SDR and DV material everything plays fine and bright, but with HDR(10) everything is way too dark..

    @Markswift2003 is there a solution for this?
  16. TardisJockey

    TardisJockey New Member

    I tried playing the same file from my NAS and the same thing happened.

    Then I stumbled across a post on MakeMKV forum, who had the same issue and was using the same ripping set up as me (almost). Ripping using an Apple Silicon Mac directly onto an attached SSD, not onto the Mac’s internal SSD. They then tried ripping to the Mac’s SSD directly, and after transferring to the Zidoo they played fine. I tried this myself today, only one film (the one that I had been testing the last 2 days), re-ripped to my Mac’s SSD then transferred to the Zidoo. It worked!! Played from beginning to end no problem.

    Not saying this is a definitive solution as only one re-rip done, but it’s further than I have gotten before. I will try a couple more, I’m cautiously optimistic, even if it does mean I need to re-rip all my 4K’s again
    Last edited: Feb 27, 2024
    blenky likes this.
  17. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I don't see this.
  18. TheRedDevil7

    TheRedDevil7 New Member

    I drew conclusions too quickly, since I switched to version .075, I had my first bug yesterday on the UHD remux of Dune: Part One in Dolby Vision and Dolby THD.
    HDD inside the player.
    At a little over 1 hour into the film, it started to clunk, and I had to pause and then play for it to stop.
    I don't know if this is consistent with some of your problems...
    PS: Deepl Trad sorry
    gymnos likes this.
  19. KJC

    KJC Member

    I got a reply from the seller saying they are replacing the board. :)
    blenky likes this.
  20. Join the club:

Share This Page