Discussion in 'HDD Media player(RTD 1619DR)' started by DELUCAS, Aug 4, 2020.

  1. SolarGlider

    SolarGlider Member

    Thanks, hopefully if they test it they can replicate the problem so I'll get a new one.

    When I receive the new one (hopefully) I will get back to inform if the problem is solved.

    Edit: something I also should of mentioned is that I've never had a glitch free experience with the YouTube app inside the Zidoo. When I stream YouTube from the TV directly it's perfectly smooth (connected to the same switch). Whenever I play from the Zidoo it also glitches thus confirming that the problem is not just caused by a weak local LAN or faulty shares setup.
    Last edited: Dec 14, 2020
  2. 3DBuff

    3DBuff Active Member

    I don't think you can use YouTube as indication of network issue. Zidoo plays flawlessly only when Zidoo hardware player is engaged, files only. Any other app player (Kodi player) or online streaming services will use some sort of software player that will glitch and skip frames forever. Trailers in Home Theater skip frames all the time and this is very low resolution video and low bandwidth from YouTube.

    My older LG 4K OLED TV has 100Mb/s LAN port only. It plays Netflix 4K DV without a glitch. Network limitations are with UHD rips or full ISO 50GB files or more.
  3. SolarGlider

    SolarGlider Member

    So what you're saying is that the Netflix and YouTube apps are pretty worthless in the Zidoo for a smooth experience. Technically (even with my 100 Mbps technical issue) YouTube and even Netflix UHD are able to perform flawlessly so what you're saying makes sense. I didn't get the Zidoo to watch YouTube or Netflix on it anyway.
    3DBuff likes this.
  4. Whitfield

    Whitfield Active Member

    During a copy/paste test over Samba, Windows 7 taskmanager shows my gigabit network at about 50%. Not full throttle as I hoped. Maybe the USB 3.0 interface of the Zidoo has a part in this.
    Nevertheless, even this value of course should be way more than enough for high bitrate UHD videos.

    As for 3D-BD ISO playback, sadly I have to report that things have changed for the worse. Quite some re-done 3D iso's I created that played fine on FW .66 refuse to play now on .80. Pitty.
    I will go back to 66. Only thing I'm not fond of is doing the emergency-flash again. I really hate this.
  5. vaskorn

    vaskorn New Member

    Dear friends,

    I have some problem. Zidoo' AFR doesn't want to recognise one movie (Russian PAL 25fps DVD converted by myself with MakeMKV to mkv) as 25fps and plays it as 23.976. If I set the device manually in main settings to 25 (normally it is set to 23.976) than it plays this movie in proper way. Other movies in 25 are played as they should be played and AFR works properly. So it is not the Zidoo's fault, but the file most likely doesn't have a proper flag or tag, or whatever, what informs Zidoo's AFR what fps it should use (excuse my naive conclusions, I'm not that good in technical side). So my question - is there any way to manually add this tag to mkv file. Well, it even should not be necessarily mkv, I can make mp4, doesn't matter, the main thing - Zidoo's AFR should recognise it as 25fps. Well... the question is more about converting things and not about Zidoo, but as I want Zidoo to recognise it, I guess I can ask it here :)
  6. Whitfield

    Whitfield Active Member

    Should this not be a Zidoo issue, my first jump to mind at your problem could be a difference between bitstream framerate and container framerate.
    Maybe you want to try this:

    Import your file in mkvtoolnix. At the video properties, set "Default duration" to "50i"
    Be sure to check the "Fix bitstream timing info" box.
    Remux and try playback again?
  7. vaskorn

    vaskorn New Member

    Thanks, will try.
  8. vaskorn

    vaskorn New Member

    BTW, why 50i and not 25p? Sorry for, may be, obvious thing asking :)
  9. 3DBuff

    3DBuff Active Member

    I’m getting full speed 110MB/s up and down to and from Zidoo on both ports SATA and USB 3.0 using Windows 10 and 12 years old laptop with PCMCIA to Gigabit card ;) . SATA is more consistent, USB is dropping speed on occasion but it could be the drive itself.

    Careful with any USB to Ethernet adapters. I have few of those inexpensive USB 3.0 to Gigabit adapters (EBay specials). Most of single port and function adapters clip at 350Mb/s (35MB/s) transfer rate. Similar adapters but with USB hub configuration USB 3.0 or 3.1 type C to Gigabit Ethernet and 3x USB 3.0 ports run at full Gigabit speed 110MB/s. Both types of adapters use the same hardware chip down to revision number. It seems that single function USB 3.0 to Gigabit Ethernet adapters are limited to USB 2.0 transfer rates.
  10. Whitfield

    Whitfield Active Member

    Because PAL dvd's are interlaced. This means that each frame consists of two fields, that are displayed one after another on a tv (unless there's something about Russian PAL I'm not aware of).

    The "p" (as in 25p) stands for "progressive", where each whole frame is encoded as one whole frame.
    But, now you mention it, there might be a possibility that there is something uncommon with your file and that setting "25p" could help indeed.

    Try both?
  11. Whitfield

    Whitfield Active Member

    I know my pc delivers full throttle. For the SMB test I worked with SSD in pc and a USB drive attached to the Zidoo USB 3.0 port. Eventhough the latter is no SSD, I know this drive can write 120 MB/s.
    I think it's also about the sort of file that is being copied. I notice differences when copy/pasting big files between several harddrives within my pc. For example, sometimes mkv's can have other copying speeds than say ISO's. Strange.

    @SolarGlider told me about the colors. Just to be sure, can somebody confirm what the colors/behaviour of the leds must be, when

    A: connected to gigabit ethernet, and
    B: there's activity?

    Thanks in advance

    [EDIT] Please also let me know which firmware you're on. Cheers
  12. vaskorn

    vaskorn New Member

    Followed your instructions with 50i. Now Zidoo's AFR recognises it and plays properly, and it is visible, that AFR changes frequency (I have 23 as standard). What is interesting, the movie is anamorphic, and now, while recognising frame rate, Zidoo stops recognising this anamorphic tag :). Well... now I'll make another version with 25p and will try to set in mkvtoolnix proper height and width (what should be after anamorphic action) and see the result. I guess it should work. Many thanks for idea of using mkvtoolnix.

    Again many thanks for support!
  13. Whitfield

    Whitfield Active Member

    My apologies, that would be my bad. As dvd never uses square pixels (absolutely spoken, it is always "anamorphic" whether it is 16/9 or 4/3), you indeed must set aspect ratio. I forgot to mention.

    There are two ways to do this. Simplest way is set 16/9 or 4/3 in "Set aspect ratio" box.
    Or, for 720 x 576 video, you also can set 1024 x 576 for 16/9, or 768 x 576 for 4/3 in the "Display width/height" box.

    BTW there are firmware versions that don't display anamorphic video properly.

    Should you still have the dvd, and if it's a long time ago since you created the mkv, you could also try to rip it again with the newest version of MakeMKV and see what happens.
  14. Whitfield

    Whitfield Active Member

    Well this is funky. I went back to fw .66 and running the same copy/paste test with Samba,
    Win7 task-manager now states I'm at about 75% of my gigabit LAN.
    As to 50% on fw .80.

    Did any of you also perform some network speed tests on several fw versions and encountered differences?
  15. SolarGlider

    SolarGlider Member

    I'm on the latest firmware (V6.0.80)

    Imo blinking green led on the back is an indication for gigabit and blinking orange is an indication for 100 Mbps.

    There is nothing about this in the manual but it works the same way with some routers and switches.
  16. rozel

    rozel Active Member

    Same here and I agree.

    Today I transferred a 10.5 GB folder of two Rips worth of files from my PC to my NAS, using my PC and averaged 38 MBps. I was watching BBC iplayer, whilst Web browsing at the same time. I didn't think this too bad on experience. My files were on an (see Edit below). My wife was using her laptop connected to the network and my daughter was using her tablet. Sometimes when I'm alone and no network activity, I can get up to around 112 MBps although a good average is somewhere between 60 and 90. Cat 5e Network cabling well over 30 meters long. I get no buffering between my NAS or Zidoo when playing my media and my NASs' (I have 3) and always use NFS shares as I do get buffering when using Samba type ones on my Windows 10 setup. Of course speed drops massively when dealing with a series of very small files such as with say a large BDMV folder containing loads of small sized .m2ts files.

    Network-wise the only issues I've ever had have been when there is more than one switch between the Router and the end-device.

    Hope this helps getting some sort of perspective.

    Edit (19/12/2020): - my files were on a 4-disc HDD RAID setup within my PC not on an SSD as previously mentioned - my bad.
    Last edited: Dec 19, 2020
    3DBuff likes this.
  17. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    You're right that usually with switches, green denotes 1000M and orange 100M but in this case it's the other way around - green is 100M and orange is 1000M.
    SolarGlider and bones7 like this.
  18. SolarGlider

    SolarGlider Member

    Now it makes sense why it showed a green blinking led on the back when I connected the Zidoo to a 100 Mbps switch. Thank you very much @Markswift2003 for this info. I guess I'm going to try NFS again since I probably configured something wrong the last time I tried since I didn't get better results.

    One other question, is it normal that I can't access the Zidoo via IP in a network browser and that in shared devices it claims to be 'not connected'?
  19. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Depends how you're accessing it - if it's by network share name then windows networking can be a bit freaky - the best way is using the IP address - so in a network browser you'd type in \\IP_Address

    For example, one of mine would be \\192.168.0 53

    (obviously the SAMBA server needs to be switched on in network settings too...)

    To connect to clients (NAS boxes, PCs etc) you should get better performance with SMB these days - NFS was the choice maybe 10 years ago for high bitrate stuff since it has lower overhead and a simpler payload, but that's not really the case anymore. A lot depends on the age of the equipment it's connecting to, but as a rule these boxes perform better with SMB.
  20. Whitfield

    Whitfield Active Member

    Thanks to @SolarGlider, @3DBuff, @rozel and @Markswift2003 for their efforts and input on the network topic.

    I don't know what to think about the Zidoo's network speed change with other firmware. It strikes me as weird though.
    I can confirm that the led color is orange at 1000mb. Couldn't check green on 100mb as I don't have such a switch at hand now.
    As a reaction to what @rozel stated about having more than one switch between router and end-device: My pc has three of them inbetween. I tried a long cable and skipped two switches. It didn't make a difference in speed. Still at 75%.

    I never encountered issues that would imply speed-trouble on my LAN, so for now I'll leave it as is. I just went back to fw .66 and I'll await another update. But I will be keeping an eye out on LAN speed.


Share This Page