Zidoo X10...Review... FW2.0.15

Discussion in 'ZIDOO X10' started by OlivierQC, Jul 31, 2017.

  1. OlivierQC

    OlivierQC Well-Known Member

    desolé pour ma part je ne connais pas ca.

    A bientot
  2. ursiel

    ursiel Active Member

    And as I have said many times, calibration has nothing to do with the banding issues. I can play the same exact 10-bit UHD HDR video file directly in my TV's media player, and there is minimal to no banding, depending on the content. Those same exact files have banding in some color space/bit depth configurations on the Zidoo. Now maybe that's due to certain color space HDMI restrictions for some bit depths, and it's unavoidable, or maybe it's due to some TVs like my LG having issues with 10bit over HDMI in some color space/bit depth modes, or maybe it's the fault of the Zidoo, but it has nothing to do with calibration of the panel.

    At least let's stick to facts when trying to discuss these issues. This was posted recently and may explain why we see banding in some configurations:

    "If you're viewing a 10 bit 4:2:0 source (eg. 4K bluray) in 12 bit 4:2:2 environment, you're going to see banding which is kind of obvious when you consider how you get from 4:2:0 (as encoded) to 4:2:2, but if you view in 10 bit 4:4:4 or indeed 12 bit 4:4:4, you don't get banding at all since there is no interpolation going from 4:*:* to 4:4:4 as you get going to 4:2:2.

    There are quite a few posts on other forums citing banding as a bug when using 4:2:2 to view 4:2:0 material, but it's not a bug, it's just maths.

    Upshot - for 4K24/25/30 -> 10bit or 12bit 4:4:4 = no banding"

    This was also posted recently, by wesk05:

    "Your TV seems to process YCbCr 4:4:4 and YCbCr 4:2:2 differently. From the many user reports, the consensus is that LG and Sony TVs produce banding with YCbCr 4:2:2 input, whereas, Samsung TVs perform better with YCbCr 4:2:2 input.

    Also, the valid output modes for this clip are YCbCr 4:2:0 or 4:2:2. I don't think Zidoo actually outputs 4K 60Hz YCbCr 4:2:2, it falls back to 4:2:0. If you select YCbCr 4:4:4 or RGB, the bitdepth can only be 8-bit at 4K 60Hz which is expected to produce banding from a 10-bit source (if not properly dithered).

    This problem is not limited to Zidoo or Realtek. I have seen this with all Amlogic SoCs."

    So it may very well be that we will always see some banding in some configurations, especially on some TV brands or models. Again, if Zidoo bothered to answer some of these concerns in here, and in a language we could actually understand, it might help a lot with these concerns.

    Last edited: May 14, 2018
  3. ursiel

    ursiel Active Member

    Zidoo not selecting correct/largest video file when menu isn't working

    I tried playing a Blu-ray folder yesterday - Repo Man Criterion disc. The Zidoo was not handling the menu properly with v2.0.15. When I selected play with menu, it immediately started playing the longest extra instead - which is a 9Gb video file of the TV version of the film. The main feature film version is over twice that size, so the Zidoo should have at least defaulted to the largest file for playback, but it did not. Instead it chose to play an extra instead.

    Hitting pop-up or main menu brought up the pop-menu, but it wouldn't access the main menu and it wouldn't display the menu page that would allow me to select the main film. So basically the menu wasn't functioning right. I also tried playing the folder without the menu by selecting "play" and it also played the TV version extra instead of the main film. The only way I could play the main film was to open the folder itself and find the correct .m2ts stream (the largest file) and play it directly.

    The Zidoo should at least know enough to play the largest video file by default. That's the correct way to handle it - assume the largest stream file is the main video file. Instead it went with an extra that was half the size of the main feature.

    DELUCAS Well-Known Member

    Yes i read them posts a while back ....
    There is not a lot we can do except moan about it but its out of our hands until they release a firmware update to resolve so called issue that some see and some do not .

    Will have to wait till end of may now i imagine .
  5. godalmighty

    godalmighty Active Member

    hello @OlivierQC
    my friend have H6pro but did not get HT2.0, can he install HT2.0 to H6pro
  6. OlivierQC

    OlivierQC Well-Known Member

    good question...i'm not sure but it seems to me that it only works with X8 / 9s / 10

    i do not have H6 pro, HT 2.0 is an apk, your friends can install it and delete it if it does not work.
  7. OlivierQC

    OlivierQC Well-Known Member

    Hello godalmighty,

    I got the confirmation, it does not work with the H series, but it seems that a new version of HT for the H model is in development.

    See you
    godalmighty likes this.
  8. godalmighty

    godalmighty Active Member

    wow...great news
    my friend have not tried it but from your confirmation, no need to do it :(
    but the news is very pleasant to hear :D
    thanks @OlivierQC
  9. OlivierQC

    OlivierQC Well-Known Member

    you're welcome :)
  10. ursiel

    ursiel Active Member

    Tried playing a 4k SDR (no HDR) video file last night and it wouldn't play - it was extremely choppy and wouldn't play smoothly - just chugging and freezing with weird motion. It's a newly-released 4k scan/file of Star Wars: A New Hope, released from the fan community. Here's the video specs:

    Writing application: mkvmerge v23.0.0 ('The Bride Said No') 64-bit
    Writing library: libebml v1.3.6 + libmatroska v1.4.9

    Format: HEVC
    Format/Info: High Efficiency Video Coding
    Format profile: Main 10@L5.1@High
    Duration: 2 h 2 min
    Bit rate: 89.4 Mb/s
    Width: 3 840 pixels
    Height: 2 160 pixels
    Display aspect ratio: 16:9
    Frame rate mode: Constant
    Frame rate: 23.976 (24000/1001) FPS
    Color space: YUV
    Chroma subsampling: 4:2:0
    Bit depth: 10 bits
    Bits/(Pixel*Frame): 0.450
    Stream size: 76.3 GiB (91%)
    Language: English
    Default: Yes
    Forced: No

    There are also 15 audio tracks. Based on this, can anyone guess why this won't play on the Zidoo? It played perfectly fine straight through without a single issue directly from my LG TV's built-in media player via USB thumb drive. The Zidoo should have easily played this.

Share This Page