Skipped or doubled frames and stutter issue with Zidoo player.

Discussion in 'HDD Media player(RTD 1295)' started by 3DBuff, Oct 17, 2018.

  1. 3DBuff

    3DBuff Member

    A lot of people including myself run into this issue of frame rate consistency with Zidoo family of players using RTD 1295 chipset. It appears that new chipset RTD 1296 is also effected the same way.

    This small blip in motion or micro-stutter as some people call it is caused by double (repeated frame) looking like the movie was paused for split second. It effects all high quality videos 4K HDR and HD with high bitrate and 23.976fps. You can see it on average 4 to 6 times in one movie but it looks like the issue is cycling every 4 to 5 minutes but only noticeable during panning scenes. Original post here.

    Couple of examples captured in slow motion at 120fps.

    Watch the man in the background as he is passing corner of the fireplace. The entire scene pauses for one additional frame cycle.


    Panning camera over the table in the middle of the sweep repeated frame.


    Another issue is strong stutter lasting about a second during playback of low bitrate videos 4.5Mbps L:4.0 23.976fps. Full article here.



    Both issues appear to be caused by 23.976fps played at 23.98Hz but unconfirmed at this point.

    Looking for comments from Zidoo team.

    Can this be fixed in Zidoo player software? Some people reported good smooth playback with earlier firmware versions 1.5 for X9S player. There were also reports that the issue was fixed on Dune player with the same RTD 1295 chip.
     
  2. 3DBuff

    3DBuff Member

    To keep this thread updated. There were posts with info regarding new line of Zidoo boxes based on RTD1296DD with the same stutter issue.
    Links here and here.
     
  3. Techead

    Techead Member

    After the Last update this started happening to me as well. I did a factory reset and it fixed the issue for me. if you haven't tried that give it a shot.
     
  4. movd

    movd New Member

    This issue is not new to the latest firmware so it sounds like you were having a different problem. This issue that @3DBuff has reported is definitely a real issue and it is something that some people do not even notice. However, for those of us that notice it, it is very distracting.

    I really hope Zidoo comments here. I believe this issue is inherent to Realtek devices, but it would be great to know if it is hardware, the Realtek SDK, or can be fixed with Zidoo firmware. Users have reported this same issue with Dune and Zapitti devices too. See here https://www.avsforum.com/forum/39-n...-hd-pro-4k-ultra-thread-116.html#post56851122
     
    3DBuff likes this.
  5. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    if it's a hardware problem it probably has no fix and it will never get attention
     
  6. 3DBuff

    3DBuff Member

    Thank you for input @HaoSs, always appreciated. I hope you're wrong ;)

    Strong stutter the second issue described above (3rd movie) was not at the initial releases of the firmware until 2.0.15 from other posts. Both issues are somehow related to clock and repeating on time base cycle. There is always a gap at least 4 minutes after stutter or any micro stutter. It is Realtek player based on hardware chipset but I'm sure they can fix it. The new chipset RTD 1296 has the same set of issue. We need someone from Zidoo or Realtek to dive deep into the code and figure out the patch.

    Zidoo makes amazing players but this frame rate issue is killing it for a lot of us :(
     
  7. Nice Monkey

    Nice Monkey Active Member Beta test group

    If it is a real HW issue i would be surprised if RTD1296DD would not have fixed this? But that probably needs a change of FW code? Thus far the code seems almost identical for both.
     
  8. Stefano C

    Stefano C New Member

    I have the same problem in my zidoo x9s even with low bitrate mkv avc files (connected to usb 2.0/3.0), from firmware 2.0.5 to 2.0.34 (not tried 2.1.14 yet)...All ok with 1.5.0 firmware
     
  9. 3DBuff

    3DBuff Member

    Which problem do refer to or both? The strong stutter every 4.5 min on low bitrate files or micro stutter on all other formats around 4 times per movie?

    The files that have strong stutter don't show correct frame rate info in old program TSMuxer. The same files will play just fine on any other device.

    Testing and info here:
    http://forum.zidoo.tv/index.php?thr...3-0-upgrade-to-3-1-8.12094/page-15#post-79478
     
  10. Stefano C

    Stefano C New Member

    I'm sorry maybe I have understood bad, I have micro strutter problem both big and little files mkv (high and low bitrate) for all the video. I tried to flash/restore/reset and update before and after flash/restore/reset but these strutter remained. I tried to change usb and external device, but the problem continues with recent firmare (firmwares post 1.5.0)
     
  11. 3DBuff

    3DBuff Member

    Thanks for sharing the info. It confirms findings from other people.

    Micro stutters started after firmware 1.5 for all HD and 4K 23.976 fps files.
    Strong stutter lasting about a second on high compressed files mainly Web-Dl after firmware 2.0.15
     
  12. Stefano C

    Stefano C New Member

    I'll try new 2.1.14 beta firmware soon, but have been found strutters even in this firmware from other people yet?
     
  13. 3DBuff

    3DBuff Member

    The micro stutters are in every firmware from V2.0.5 until the newest V2.1.14 :(

    I’m on this latest 2.1.14 and I see it all the time.
     
  14. movd

    movd New Member

Share This Page