New firmware v2.1.14 beta version for ZIDOO X9S released(Music 3.0 upgrade to 3.1.8)

Discussion in 'X9S Official Firmware Releases' started by zidoo, Sep 26, 2018.

  1. 3DBuff

    3DBuff Member

    I think it’s you;)

    The default player in ZDMC is Zidoo Player. You need edditional steps to start Kodi Player in ZDMC. With this you you will have constant skipped frames outside of other audio and video quality losses.

    Players and differences here.

    Kodi Player issues here.
     
  2. burton

    burton Member

    Hi
    I meant with the external player (default zidoo player) disabled.
     
  3. 3DBuff

    3DBuff Member

    The external player is very confusing ;)

    Zidoo player should be exactly the same if started from Home Theater, Media Browser or ZDMC.

    Kodi player has issues with Zidoo / Realtek chipset. Don't use it unless you are desperate.
     
  4. 3DBuff

    3DBuff Member

    I ran into this movie last night. It has high bandwidth L:4.1 but exhibits strong stutter just like Web-Dl L:4.0 :(
    I even rebooted Zidoo thinking that something got stock in memory. No difference. This movie plays really bad on Zidoo.
    I get strong stutter exactly every 4 min 40 seconds on continuous play even scrolling credits at the end of the movie stutter on every cycle.
    When I pause the movie using "play/pause" button not OK the movie will stutter 40 seconds after resume from pause. Horrible!

    Send PM if interested in link.

    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4.1
    Format settings : CABAC / 4 Ref Frames
    Format settings, CABAC : Yes
    Format settings, RefFrames : 4 frames
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 1 h 43 min
    Bit rate : 9 000 kb/s
    Width : 1 920 pixels
    Height : 804 pixels
    Display aspect ratio : 2.40:1
    Frame rate mode : Constant
    Frame rate : 23.976 (24000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.243
    Stream size : 6.47 GiB (86%)
     
  5. DELUCAS

    DELUCAS Active Member


    Is this file streamed / networked etc to your Zidoo or played via usb / hard drive etc ?
     
  6. 3DBuff

    3DBuff Member

    Networked from NAS Samba. I don't think you could have network issue that would be cyclic like a clock. I play 3D ISO from the same network drive without any issues.

    I could trow it on USB to double check. Why would network make it cyclic? Zidoo network buffer issue? Maybe? Why for lower bandwidth only?
     
  7. DELUCAS

    DELUCAS Active Member

    Just wondering if networking is causing some kind of link / sync delay ?

    Try via usb just to confirm .

    My movies are all stored internal via ssd drive so elliminates any chance of buffer / sync etc / delay
    Or one thing out of the equation .
     
  8. 3DBuff

    3DBuff Member

    Just tested it. Exactly the same from USB. The movie has strong stutter afer exact 42 seconds from play after pause. No difference if the OK button with info or "Play/Pause" buttons are used.
     
  9. mattmarsden

    mattmarsden Member

    Could you try remuxing with tsmuxer to a ts file and see what happens.
     
  10. 3DBuff

    3DBuff Member

    We've been there before couple pages earlier. If I remux the file using tsMuxeR and don't change any options it will turn it to 25fps! The movie will run faster and finish sooner. It's an older program with no updates for years. It has some issues with recent encodes. Frame rate is listed at 90,000. If I use different program like XMedia Recode and change container only to .m2ts and copy video stream I will probably end up with the same stutter.
     
  11. 3DBuff

    3DBuff Member

    OK, I got the program open and I can quickly do it. What options would you like me to do?
    1. Keep Frame Rate at 90,000 (don't change anything)
    2. Force it to 24.00 fps. If everything goes as planed it will be marginal speed difference 15 seconds over entire move.
     
  12. mattmarsden

    mattmarsden Member

    You should be able to force it to 23.976
     
  13. 3DBuff

    3DBuff Member

    OK, I did 3 tests muxing to .ts files as suggested.

    All options on tsmuxer are default except for frame rate.
    Insert SEI and VUI data if absent
    Continually insert SSP/PPS

    1. Default Frame Rate 90,000 fps. TsMuxer ends in error right at the beginning - Frame Rate not supported ;)

    2. Forced to 24 fps. Length stayed the same 01:43:56. File seize increased by 400MB to 7.92GB. Video Bit Rate decreased from 9,000 to 8,860 kb/s. Zidoo is showing 24 fps upper left corner at the beginning of video.
    The move runs out of video sync and continuously advancing (lip sync issue). No visible stutter.

    3. Forced to 24000/1001 fps. Same movie length. File size almost the same as 24fps. Video Bit Rate the same as 24fps at 8,860 kb/s.
    Zidoo is showing 23.976 fps upper left corner at the beginning of video.
    No visible stutter or frame rate issues.

    Very interesting. I think we are getting somewhere.
    Original file that exhibits strong stutter is showing 90,000 fps in tsmuxer but Zidoo is displaying 23.976 fps at the beginning of video. Media info is also showing 23.976 fps without any issues. This file plays flawlessly on LG TV, PC and Raspberry Pi Kodi setups.
     
  14. mattmarsden

    mattmarsden Member

    Yes it has problems with certain codecs in an mkv container. This isn’t linked to the 23.976 microstutter however, thats a seperate issue. I can’t believe realtek have taken 1 step fowards and 2 steps back with this SOC compared to the old one used in the Mede8er!
     
  15. 3DBuff

    3DBuff Member

    One more test:

    4. Original mkv container changed to MPEG TS container .ts file extension just like tsmuxer but using my preferred program XMedia Rocode. Audio and video streams were copied into new container without any encoding (one of many excellent features of this program). The process took 2 minutes compared to 15 minutes using tsmuxer. Movie length is 1 second shorter 01:43:55. File size over 700MB larger 8.29GB. Video Bit Rate 9,000 kb/s just like original file (I used copy stream function). Frame Rate - here is where it gets really interesting. Original MKV file reports Frame Rate 23.976 according to latest MediaInfo. The new converted container .ts reports Frame rate mode: Variable according to the same MediaInfo and no numbers after container changed from MKV to TS.

    Zidoo reports 60fps! at the start of video upper left corner of the screen and does not show visible stutter.

    It's not that clear where the problem is. Original file plays fine in my TV, PC and Raspbrry Pi and it used to play without stutter in previous firmware up to 2.0.15 from the forum posts. I haven't tested it myself.

    Few pictures from Zidoo build in media info.

    Original MKV file below. It stutters every 4.5 min or 42 seconds after restart from pause:
    Original MKV s.JPG

    Converted by TSMuxer and forced frame rate to 23.976 below. No stutter:
    TSMuxer converted to TS s.JPG

    Container changed from MKV to TS using XMedia Rocode with copy only for video and audio streams. Please note video resolution reported back to 90,000fps just like TSMuxer and output set for 60Hz below:
    Video copy to TS by XMedia Rocode s.JPG

    I hope Zidoo / Realtek can investigate and correct this in the next firmware update. The stutter makes those files impossible to watch. It's some tagging of video stream issue that confuses the video processor. The first MKV file should play just fine like it does on other players and it used to back with firmware 2.0.15.
     
  16. 3DBuff

    3DBuff Member

    All movies that have strong stutter with Zidoo every 4.5 min show some issues with TSMuxer. All Web-Dl's show "Frame Rate: Not Found" in TSMuxer but show correct 23.976fps in MediaInfo and XMedia Recode. The file from example above shows Frame Rate: 90,000 in TSMuxer and 23.976 in MediaInfo and XMedia Rocode.
     
  17. filip kenens

    filip kenens Member

    When i download subtitles always get error,download failed,anybody else have that problem ?
     
  18. Fatih Durmus

    Fatih Durmus New Member

    Hi friends,
    I have problems darkness scenes. I tried last firmware and last beta firmware but darkness scenes very bad. It is very darkeness. I was using before 1.4.12. It was very good.
    Is somebody agree with me?
     
  19. cckelly73

    cckelly73 New Member

    web-dl try set 1080p 30hz, it will be smooth .
     
  20. Miguel Freitas

    Miguel Freitas New Member

    As someone tried the American Animals blu-ray? Can´t get the menu to show (black screen) and got a protection message on the first 10 minutes of the movie.
     

Share This Page