Poster wall slow loading ?

Discussion in 'ZIDOO X20' started by Johnwoto, Oct 18, 2021.

  1. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    It seems to be a case of narrowing it down now..
  2. Johnwoto

    Johnwoto Member

    Just been on McBluna website and found this in HT version 4.1.31

    Screenshot 11-09-2021 14.17.47.png

    Wondering if it is a firmware problem as I am scanning from the start as a new setup and not just updating files when added - I find it unlikely that the files are corrupt but will investigate - I do scans on the NAS quite frequently to check the integrity of the file system - The poster wall has never crashed before until I started a fresh setup - it's very strange
  3. Zwanzig

    Zwanzig Member

    I have the same problem on X20.
    Posters on the Zidoo internal drive.
  4. Johnwoto

    Johnwoto Member

    Hey – Did more testing – I added a source one at a time to the X20 – As each source was added I checked the poster wall for any glitches crashes or not loading the poster wall in and found until I added the TV Series source that’s when I started to have a problem of slow loading and crashing – The TV source has 84 series comprising of 2859 episodes - wondering if there is to many in that source – Next I thought of my old X9S so Dusted it down did a total wipe and delete any trace of .HomeTheatre folder and any previous setup I did – The X9S is running Firmware v2.1.42 – started adding the sources one by one and checking them as I go – All the same sources were added to the play like the X20 – I tested the wall over and over again but couldn’t get it to crash the poster wall loaded in perfectly even when pressing back the wall was still there – I recorded a video going through all the sources that I added

    Not sure what to think now if the X9S works great on firmware v2.1.42 but the other players don’t on Firmware v2.3.80 – it may be a bug in that firmware only when scanning from scratch

    Thought maybe downgrade the firmware on the X20 to v2.3.35 - I know it's a messing around doing that but if the poster wall loads and doesn’t crash surely that would indicate a firmware issue
    Last edited: Nov 10, 2021
  5. Johnwoto

    Johnwoto Member

    I decided to do a recovery firmware flash and then load v2.3.35 firmware on to test the poster wall – I loaded the 3 sources that have the most files in that I have been testing – Got all the sources loaded then slowly went through the wall to populate the posters once that was done I went through the wall over and over again with no crashes and the wall loaded in great as it should – Next I will load firmware v2.3.60 and see how that performs on the x20 – What I did find is that the poster wall scraping on the X20 firmware v2.3.35 isn’t as good as the X9S v2.1.42 for some reason had a lot more files that it didn’t see – Also going to do the same with one of my Z9S players
  6. Johnwoto

    Johnwoto Member

    More testing – I loaded firmware v2.3.60 on to the X20 to test as its been running great since the Recovery flash – I tested the poster wall over and over again but couldn’t get it to crash – I decided to do a Recovery Flash on one of my Z9S players to test like the X20 – Flashed the Z9S then put firmware v2.3.60 on it – Got it all set up with all the sources on and found that didn’t crash anymore – so going to set the other Z9S players up like this – Once all that is done going update one of the players to v2.3.80 to test if that doesn’t crash the poster wall then will do a total wipe and delete of all the poster wall then set up the sources again – I’m thinking it could be a firmware bug when setting up the poster wall for the first time with version 2.3.80 – But won’t know this until I have finished the testing
  7. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Very odd - but it has to be something very specific to your storage environment that this particular version of HT doesn't like - I know @Zwanzig said he had an issue above, but there hasn't been a flood of comments from users which you'd expect if it was a classic bug that manifests re
  8. Johnwoto

    Johnwoto Member

    Yes it is very strange - and I get what you are saying about a flood of comments but I wonder how many people are setting up the poster wall from scratch on version 2.3.80 – My setup is a Qnap NAS wired to a 16 port switch with Cat5e rated at 350MHz 24AWG then that routs out to all the players - will let you know how I get on over the weekend - Thanks again for your help - the poster wall defiantly loads faster set to that custom folder
  9. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I'll fire up my Z9S today, update to v2.3.80 and do a full reset - It'll be interesting to see what happens.

    I'll point it at a big library spread over several NAS drives to just to make it a bit more difficult ;)
  10. Johnwoto

    Johnwoto Member

    Ok that sounds like a plan

    This is my plan over the weekend

    Get them all working on v2.3.60 first as two of them have been great

    Update one to v2.3.80 see how that performs if that's working as it should with no crashes will reset the poster wall on that one - then set up the sources again.
  11. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Right - I loaded v2.3.80 onto my Z9S - it previously had v2.3.60 on it.

    I wiped HT4 using the reset procedure and then scanned a library of 842 movies over 4 separate NAS drives.

    After scanning, clearing up a few unmatched items and correcting a few mismatched ones, I scrolled through the poster wall to allow all the covers to cache.

    And you know what I'm going to say don't you ;)

    No crashing, no refresh issues - no issues whatsoever. Scrolling speed maybe a little less that my Z9X, but nothing else...
  12. Johnwoto

    Johnwoto Member

    Ok that’s great thank you for testing it like that I know it’s time consuming – will test mine over the weekend and let you know like I mentioned – it’s strange what’s happening never had a problem before like this
  13. Johnwoto

    Johnwoto Member

    Some more testing

    First I did a recovery flash then updated to v2.3.80 when that was all done I then started to add the sources one by one – when one was added I went through it adding all the missed files first before moving on to the next source – after adding the third source which was my TV stuff comprising of about 3000 files as I went through the poster wall it crashed

    Next I did the recovery firmware again then loaded firmware v2.3.60 did the setup again like I described – No crashes :)– Tested that for a while still no crashes

    Next I did a firmware update from v2.3.60 to v2.3.80 – I wanted to see what would happen when the poster wall was already set up – I found that I didn’t have any crashes but the poster wall loaded in a lot slower :( than the previous firmware

    It seems when I load the TV source with 3000 files that’s when I get the problem – I wonder if I split the TV folder up into three if that would work better – I might test that another day

    Not going to update the other players will leave them on v2.3.60 and have only one on v2.3.80 for testing
  14. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I use an old Mede8er for TV stuff mainly because I don't want the Zidoo cluttered up with stuff I'll probably never watch again, and mots of it is very old.

    I just checked and I have 3173 episodes (I had no idea there were that many!!) so I've just pointed my Z9S at that too.

    Not sure what the Zidoo will make of it because I use TVRename and have that set to format as :

    {ShowName} - S{Season:2}E{Episode}[-E{Episode2}] - {EpisodeName}

    It's scanning now - I'll let you know how I get on...
  15. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Well surprisingly, out of 3173 episodes, HT4 only had 60 episodes of 4 different series that were left unmatched.

    Only one of the matched series was matched incorrectly and this was Space 1999 which also had unmatched episodes above - I guess to do with the 1999 in the name - HT doesn't like numbers!!

    So I have 46 matched series, 60 unmatched episodes of a total of 3173 episodes - so 3113 episodes were recognised.

    On the "All" view I now have 718 items, Movies 671 and TV series 46. The discrepancy of 1 is due to the Unmatched icon at the bottom of "All".

    The TV episodes are all in one "source", so now I have 4 movie sources and 1 TV source.

    And again, I'm sure you know what I'm going to say....


    No crashing - I can zip through any of the posterwalls as quick as I want and it all holds up...

    Which kind of doesn't make sense because for you, the issue is only when you update to .80.

    Not sure where this leaves us....
  16. Johnwoto

    Johnwoto Member

    That was a really good test - still getting no crashes - it’s the poster wall - I go through the wall slowly to populate which is slower than usual but when you go back to that poster wall it has to load in again which is slower than the other players as I have a reference - Not sure what to do now apart from split the TV folder up and try that - Or I might wait till the next update before testing again -

    on you Z9s did you leave it as default setup or did you change any settings or have any apps on it ?
  17. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I have no external apps installed and everything was initially set as default - after I tested and found no issues I then configured HT as I usually do - overspread (smallest) posters, no background images and I set the order on the main page as I like (Latest at the top, then widgets, then genres etc).
  18. Johnwoto

    Johnwoto Member

    Ok thanks - When I tested mine I left it as default after the recovery flash - it was just a thought if it was set up differently - really not sure why it’s performing like this
  19. Johnwoto

    Johnwoto Member

    Another Test

    I separated the TV folder into 4 which has about 750 files in each - I then added all the 4 sources - Unfortunately that didn’t make a difference as the poster wall crashed - I thought that would of worked - so I decided to add a sources and test them one at a time once one was tested then it was removed and I moved on to the next - they all worked as they should no crashes - then I added 2 sources and tested had no crashes - I then removed them 2 then added the next 2 sources still no crashes - Then I added another source so now I have 3 TV sources - That's when it crashed - I removed that source then it was ok again so thinking it might be that source I added the 4th but that crashed when testing - its everytime I add 3 of the TV sources this is when it crashes - doesn't matter what order I add them as tested various ways

    so basically I’m still no further on than I was - Think i'll wait till the next firmware before testing again - it's not as though I watch the TV stuff all the time but it's nice to see them altogether - will still have access to them through Media Center
  20. Johnwoto

    Johnwoto Member


    I got a Z1000pro to replace my x20 so done some testing on that issue I had crashing when all sources are loaded going through the poster wall – Scanned all sources like I have done before as explained previously – The Z1000pro hasn’t crashed at all works great with everything loaded – Going to test one of the Z9S players as I have just updated HT to v4. wonder if that makes a difference

Share This Page