Occasional jerky/choppy playback

Discussion in 'HDD Media player(RTD 1619BPD)' started by Markswift2003, Dec 24, 2023.

  1. Pete B

    Pete B Member

    I've experienced it on 5 movies.

    The common denominators seem to be:
    4K MKVs with Dolby Vision.
    Usually it occurs after a pause/stop and then resume, but I've had it appear during the end credits and also in the last 15 minutes of a movie.

    As noted previously, it's rare, intermittent and difficult to repeat but then again, I don't go looking for it and actively try to avoid the conditions (i.e., stopping and then starting a 4K MKV with DV) that appear to precede it.
  2. jehangir kh

    jehangir kh Member

    I also got Nvidia shield pro 2019 my all videos are stable in respect of frame rate and picture quality and with Plex i manage to play DV . Whether you watch dv or hdr10 Dolby atmos does not give any jitters.
    I want to mention one more thing in Zidoo z2600 is too brightness and remain bright in all kind of scenes but in nvidia shield and my sony UHD i noticed brightness goes up and down /dim according to scene. Brightness stays up and does not go down in zidoo. Is it EDID problem?
    in every FW choppy and stutter getting better but very very far from being normal.
    i dont really feel happy
    Last edited: Feb 20, 2024
    gymnos likes this.
  3. shiftedmirrors

    shiftedmirrors New Member

    I'm really glad to see this thread on the stickies list again. It's about time Zidoo nailed this annoying issue for sure.
  4. KJC

    KJC Member

    In my case choppy/jerky playback can be seen every within 10-15 mins. Motion isn't smooth as my oppo device would play. Tried resetting Zidoo but no help. Also I noticed jerk in audio files E-AC3 format. HT.4 issue is yet to be solved. So many issues I'm facing.

    In short "I regret buying Zidoo device".
    gymnos likes this.
  5. cucnz

    cucnz Active Member

    its got to be the files played or something in setup
    i have ZERO playback issues with this Z9X pro or my older Z9X playing same files

    Maybe list out your full playback path ..ie components start to finish
    maybe try eliminate stuff by playing zidoo direct to tv and earc back to amp for audio just to see
    also check hdmi cables are actually 8k rated (ie able to carry 4k video DV and DA ,which lower quality cables WILL struggle with (i checked all mine with my denon amps hdmi cable tester)
    (ie the budget hdmi supplied with device may not be great)
    and if lan playback make sure lan is full cat 6
    ie someone just a few days back was positive they had giga lan all the way ,but once i got him to recheck he found a 100 switch /cat 3 cable was the issue for all his stutters etc
    misichavichus likes this.
  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    In that case something is very badly wrong somewhere.


    1. You haven't got auto frame rate switched on (I've asked you this before but you didn't answer)
    2. Your delivery method isn't up to the job (network/storage etc)
    3. The files are problematic
    4. The box is faulty

    Don't get me wrong, there are issues with this box, but apart from this occasional (and I mean occasional) issue detailed in this thread, they are all usability rather than stability issues.

    Your problem is something else entirely and not evidenced by the experience of other users.

    I usually dismiss the possibility of a faulty box, but you were complaining about your box overheating for no reason right? That's just not normal.

    Mine is on 24/7 and quiesces at about 25 degrees and in no way ever feels hot. It sits directly on top of a Vertex 2 which is warmer at 29 degrees and this in an ambient temperature of about 21 degrees.

    So in this case a faulty box is a real possibility.
    xskip likes this.
  7. KJC

    KJC Member

    I fixed the over heating issue by installing a cooling fan and now its about 29-30 Degree.

    1. You haven't got auto frame rate switched on (I've asked you this before but you didn't answer)
    Ans. Usually I set it "OFF" to avoid black screen issue but then tried setting it "ON" still no improvement.

    2. Your delivery method isn't up to the job (network/storage etc)
    Ans. I've been using WD 5TB external Hard drives which plays fine with TV.

    3. The files are problematic
    Ans. Not all the files can be faulty.

    4. The box is faulty.
    Ans. Might be but there is no good customer support in India, when asked the seller said about the issue he said it will need at least a month to get it repaired and there wont be any replacement.

    I tried recording the issue in my phone but its not that evident with the camera.
  8. Evangelos

    Evangelos New Member

    From your other posts it was evident to me that you basically burnt the USB port of your zidoo by making the mistake of connecting multiple UNPOWERED hard drives on an UNPOWERED usb hub and into the zidoo usb port. This is against the usb port specifications and probably fried something in there. The result is that now the usb port causes power dropouts or doesn't even have enough power for even ONE usb hard drive.

    You didnt solve the overheating, cause you cured the symptom of the disease but not the disease itself. Zidoo boxes don't overheat, the fact that yours overheats is because of the above USB port destruction.

    Ther is no point in asking for fw updates and software solutions fo your "problem". You need to "lie" to your supplier and hide the fact that your user errors broke the hardware.

    Finally, it is a matter of "when not if" you are going to burn the usb port of your TV as well.

    Don't mean to sound harsh, a lot of people have burnt usb ports like you (me included). Thats why in my latest purchase from amazon of an Anker unpowered usb hub, it explained prominently in the manual "only one hard drive can be connected to the usb hub before it reaches it's power limit."
    KJC likes this.
  9. blenky

    blenky Well-Known Member

    We need to be clear what issue this thread is for.

    As far as I'm aware its for when a video is playing smoothly, is paused and on un pause is jerky - but with OK sound. The fix is either skip back a few seconds with remote or stop\start. Playback is then fine. Only happens occasionally and always fixable as described

    This is not about jerky playback from the start or becoming jerky after a period of time.

    Please correct me if I'm wrong!
    Markswift2003 likes this.
  10. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Well kind of...

    I've also seen it happen on starting a video and also spontaneously (without pause etc) during a video, but I can only recall seeing that once.

    But it's a very specific symptom - playback is in realtime, audio is fine, but it's as if playback is at say 15 fps, and as you say, immediately and always fixable with a pause/resume or similar.

    But yes, an occasional problem only and as I said earlier, personally I had a gap of a couple of months between instances.
    Pete B likes this.
  11. KJC

    KJC Member

    I should have read the manual carefully before using my Zidoo device.

    @Markswift2003 How many hard drives can be connected to Z9X pro at a time?
    Since 3 ports are given I thought connecting at least 2 or 3 wouldn't cause any harm or damage.
  12. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I don't know what they're rated at, but they're really only designed to power USB sticks, not drives - I think I said this to you a while ago, the voltage regulators on the board are tiny and not designed to power anything substantial.
  13. cucnz

    cucnz Active Member

    mine (and my Z9X previously ) have 2 usb powered drives (4 TB max) permanently connected to them

    If you have damaged the usb port ,cant you just use Lan /wifi ( only if no lan) and bypass that issue ?
    KJC likes this.
  14. Pete B

    Pete B Member

    This is about the frequency with which I've experienced it too. Last time was back in Dec 2023 so I guess I'm about due for another soon.
  15. This just happend to me: started video, downloaded subtitle, jumped 10 min ahead to see if the subtitle is ok and choppy playback. Fixed it by pausing.
  16. Sanctrum

    Sanctrum Active Member

    Probably I am observing it too, randomly and quite rarely during the start of video... But if happening, then mostly just for the newly added movies into PW4 gallery. Then afterwards it is OK. So it is quite strange, as in my case it can't be replicated for the same files it occurred before. I can even risk the statement that in my case if it happened before then it is always just a single event per file never replicated again.
    So I think it suggests that the problem is triggered very rarely and by some background process that is triggered only once when the video is started for the very first time from the level of PW4.

    So looks like it's just about time to focus over PW4 and also optimize it with respect to big libraries 1000+ movies and fix other bugs with quite long beard.
  17. It is not a rare occurance. It happens for me daily on every 4k file. It happens once per hour. Its just hard to reproduce.
  18. joey_corleone

    joey_corleone Member

    I've been following along in this thread. So, is this specific issue different than the issue several folks including me seem to have intermittently only with VC1 encodes? I think they are similar issues but I am not sure. I can say that for me, sometimes VC1 encoded MKVs play back with a major noticeable lag. Full stop/start sometimes fixes it, sometimes doesn't. It's not readily reproducible either because sometimes it plays fine. I just watched a VC1 encoded blu ray rip the other night and it was flawless, but then some of them this bug pops up.

    Since VC1 is ancient and does not support multithreading from my understanding, I have seen issues with VC1 stuff pretty much across the board over the years I have been into this. Everything from Plex to Infuse Pro to Zidoo has had issues specific to VC1 at some point. It would be great to get that settled.

    If this is the wrong thread, I apologize, and maybe we should have a different place to track that one.

    I think it is similar but different because I have very occasionally seen the issue described on much newer stuff like 4k files that are obviously not using VC1, but a simple pause/play or 10s skip ahead/back fixes that whereas with the VC1 issue it doesn't. You have to stop and play again and hope it goes away.
  19. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    No, this is not related to VC1 (I have no VC1 encoded files), but that's not to say it doesn't affect VC1 - I don't think the codec matters. I've seen it on HEVC and AVC.
  20. KJC

    KJC Member

    "So you're all, (those who connect external drive) are using external power supply to power up the external drives?"

    Its actually "shocking" to me especially after knowing that Zidoo advertises this product as capable of supporting up to 14 TB (if I'm not wrong). I don't think they mean it saying Pen Drive.

    "Is there any official statement that says 'if one's connecting external drives to the Zidoo device then it must be powered up externally?"

Share This Page