New firmware v2.3.15_G(built-in google play) BETA version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by zidoo, Jan 17, 2020.

  1. tomtom

    tomtom New Member

    I'm finding this firmware extremely unstable. Playing mkv files lots of stops, crashes and restarts.

    I've tried to go back to 2.3.7 but it fails verification due to firmware version being older than the current one. Anyone know how to revert to an older firmware?

    Thanks.
     
  2. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Install a ROM image file via emergency recovery to downgrade and next upgrade to the FW level desired again.

    For me it is almost stable but I hardly play any MK, AVI etc at all just DVD, BD and UHD-BD from Folder or ISO.
    Seems something goes wrong playing MKV specifically. Added it to my overview.
     
    Last edited: Feb 3, 2020
  3. Schumy

    Schumy Member

    x2. Exactly my experience
     
  4. Markswift2003

    Markswift2003 Well-Known Member

    For those using the device for MKV playback (which is all I use it for) I'd suggest reverting to v2.2.96 as that version is completely stable in this respect.

    I haven't tried it because of all the bad reports, but it seems something fundamental has gone wrong in the dot release to v2.3.

    Unfortunately Zidoo have now seen fit to make downgrading as difficult as possible so you need to do a full USB reset to v1.7.8 (only because this is the only full ROM image available afaik) and then back up to v2.2.96, which means a full reset to factory (so a backup of HT2 is needed and noting down your video settings etc).

    A copy of this image is here along with instructions:

    https://mega.nz/#!kfQmTSKJ!q0C9dVtV8_iXvHjVdiUk9y8DDZeuauY3CdPHZnlCLXE
     
  5. Good morning,
    unlike some of you, I have all contained in MKV on NAS (for space reasons, since I don't know English, I only have 1: 1 content, audio and subtitles in Italian), well, the player has never stopped, stopped or stopped reading MKV.

    The only film that I can't see is Gemini Man in 4K HDR, the screen turns green.
    I note that the player is connected via HDMI directly to the TV (Sony KD-65XE93), with cable certified for HDMI 2.1 connections.

    If anyone has a solution, this is welcome.
    Thank you and good day.
     
  6. Nejiro

    Nejiro Member

    Hi, I am also Italian ;)
    I had your same problem with Gemini Man, just go to the menu and activate the "Ignore EDID" option, that way you see it, I don't know why you have to activate that option but so you see me ..... I have the firmware 2.3.15 beta
    Regards
     
  7. @Nejiro Prova già fatta, non funziona, farò qualche altro esperimento, se non riuscirò nell'intento, lo guarderò in 1080p.........

    Sono contento che ci siamo trovati, entrambi italiani....... Scrivi anche sul Forum di AV Magazine, giusto?
     
  8. metar

    metar New Member

    More than 90% of the material I watch with the Z9S are .mkv, and only with a little of them I have some problems, mostly regarding "holes" in the sound sometime.
    .avi files with video encoded in xvid are ok, but those encoded in divx are not played, I think for a 'patent denied' reason (solved installing Vlc app).
    Many improvements surely can be made, but for me this is the best firmware until now..

    I too have connected the Z9S with an optical cable to the AVR, and I have no problem playing music.

    PS: troppi italiani qui...;)
     
  9. @metar: Ti ringrazio del feedback sul collegamento ottico all'AVR, poi, per i troppi Italiani, bhee dai, meno male............
     
  10. AKELA

    AKELA New Member

    Hello to everybody,
    specially to italian people.
    I've had Z9S for a year but I'am a beginner user yet.

    Following my Hardware
    • Z9S used as a NAS (OpenWRT Samba) by sharing two HDDs connected to Z9S SATA ports and with W10 PC by LAN
    • LAN Ethernet cable cat5e
    • HDMI IN to external Aukey 2-switch HDMI 4k (Sony DVD blu-ray player+Wifi display Dongle)
    • HDMI OUT to Samsung TV
    • Samsung sound bar+subwoofer connected to Z9S through optical output
    • Tikigogo TK3 2.4G/IR Air Mouse+keyboard able to command Z9S, Sound Bar, TV, DVD player at once

    Highlights
    • Followed the procedure for USB and 2.3.15_G installed and rebooted correctly.
    • Respecting previous firmware upgrades I had no need to restore to the factory set (it was due to Google services instability). Good improvement!
    • 2.3.15_G seems stable for the time being.
    • Tested full HD resolution by VLC player (streaming through OpenWRT samba by two player at once: by host Z9S and client PC W10): no lag.
    • 4K not tested yet
    • Headphones bluetooth OK
    • "Native" System File explorer works well

    • Troubles with external apps from Google Store, as usual, due to "old" Android rev 7, I suppose
      • FX file explorer: not able to write on HDDs SATA (NTFS file system), message errors "this device does not appear to the Android Storage Acces Framework". By using the same app on Android 9.0 tablet through Samba Lan, I'am able to do it instead
      • A few of music/movie streaming services don't work well (in particular multi frame, picture in picture management etc... seem very critical)

    Do you have any suggestions for red issues? Do I have to make do with apk?
    Thanks in advance!
    AKELA (from Italy, as usual...;)
     
    Last edited: Feb 6, 2020
  11. Goodmorning everyone........

    I apologize but, I completely forgot how to start the player directly with the HT2 screen ..........

    If anyone could kindly remind me ......
    Thanks in advance and good evening to all of you ........
     
  12. Markswift2003

    Markswift2003 Well-Known Member

    Go to Apps, find the HT2 icon, long click and select "Launch on Startup"
     
    andreamusso.am likes this.
  13. Markswift2003 likes this.
  14. karipu

    karipu Member

    Firmware v2.3.15_G and Music Player v5.4.5.

    Horrible bug found!

    When playing SACD (.iso) files or DSD (.dsf) files you can hear at the same time pink noise and music.

    And when playing DTS (.flac) files one can hear only pink noise.

    Let's pray that this bug is fixed asap!
     
  15. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    I have listened a lot to both formats using this FW and can't confirm this. See my observations on page-2. DTS-CD's have a WAVE format not FLAC. But also MCH FLAC's play correctly.
    What are you audio settings?
     
    Last edited: Feb 13, 2020
  16. karipu

    karipu Member

     
  17. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Use the same but with USB Audio OFF. Never got that setting doing anything for me.
    Use HDMI output to my AMP myself. Heard about complains with SPDIF output though (never tried). You are not using that?

    Getting playback + Noise is very strange with digital sources. Getting pure noise instead of music can happen with unsupported formats. The only way I can imagine to get it combined is mixing sources in one way or the other. Distortions do happen and are mostly a consequence of playback resources/throughput hamperings.
     
    Last edited: Feb 13, 2020
  18. karipu

    karipu Member

     
  19. blenky

    blenky Active Member

    Same here. It either pauses and re starts or completely craps out. That's with bluray and MKV. Hopefully when the Zidoo team are back they can quickly release something without so many bugs!
     
  20. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Tried a factory reset. Played many BD's without any issue new, old and UHD/HDR
     

Share This Page