New firmware v2.3.15_G(built-in google play) BETA version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by zidoo, Jan 17, 2020.

  1. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    My experiences are that BD works fine via SMB but UHD with HDR produces glitches on many players occasionally. Using USB is better and SATA the best.
    For this and other reasons started using my Zidoo as my NAS with HDDs attached via USB and SATA.

    Good to hear some players do work via SMB with any source format. It also highly depends on the SMB mode as SMBv2 and above are optimised on throughput only. Be sure to disable SMBv1 on W10 or other NAS for that and also security reasons.
    Last edited: Jan 21, 2020
  2. karipu

    karipu Member

    Please note Zidoo cannot connect to macOS computers through SMB.
  3. Heavymetal

    Heavymetal Member

    I've played yesterday 3 movies,one with ethernet 4k mkv. trueHD the audio goes about 20 times out for a second and one time a few seconds black screen.
    And one with wifi,mkv trueHD,dare it happens the same.
    And one through sata,mkv.DTSand also the same,unbelievable.nothing works good.
  4. leonkoum

    leonkoum Active Member Beta test group

    No problems for my until now... :rolleyes:
    I used br & uhd remux rips with no problems using my Synology nas via SMB and Ethernet cable cat6.
    The only notice I have is that seemless branching seems not workings for me..
  5. Heavymetal

    Heavymetal Member

    I think it's solved,i took another hdmi cabel and for the moment everything works great,the hdmi cabel that came with z9s in the box is not good.
  6. Heavymetal

    Heavymetal Member

    Yesterday i played a movie with DTS-HD MA and several times i heard a sharp sound through my boxes,

    DELUCAS Well-Known Member

    sharp sound through your boxes i take it you mean speakers ?
    I always do several boot ups and unplugging the unit from the mains once i update firmware
    I do on all my media boxes .

    it may or may not resolve your issues .......
  8. Heavymetal

    Heavymetal Member

    Yes sorry i mean speakers,i did a reboot and now its gone,thanks.
  9. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Did an upgrade using FW 2.3.15_G and it worked just fine:

    - Followed the procedure for USB and it installed and rebooted correctly. Re-booted manually once more after the install as part of my own proven procedure.
    - No need to re-install GAPPs, It just worked as before the update including Play Store access and Eject (use Eject as a quick test for GAPP's related problems).
    This is really good news! I feel any stable release should include also a ROM emergency flash USB version to cleanup the player. Factory reset does not seem to do that job as it should.

    For problems specifically reported by me (including some reported as solved):
    - Volume Label length above 20 positions is confirmed as solved
    - Some DTS-CD not playing is partially solved only as almost all do play now but the previous problematic ones now play with 2CH not MCH sound. These are reported as 2CH in info too. Just a sporadic few (e.g. David Benoit - American Landscape) reported as 6CH and disc label says 20-bit 5.1) still don't play and just produce white noise.
    - Music Player Instabilities when playing DTS-CD's/2CH SACD are not seen thus far.
    - Playing the Stereo track of MCH SACD ISO's (with DST compression) often won't go smooth. As a bypass they can be converted (and implicitly decompressed) to DSF (or next to PCM). For playback of the MCH tracks conversion to PCM must be done prior to playback always.
    - Lost PCM MCH sound specifically with Music Player (tracks remaining silent then) twice requiring a reboot, but can't reproduce this on demand. Happened doing a lot of starting and interrupting playback of various music source formats (also using background for doing so).
    - DVD playback not reporting Title/File correctly confirmed as solved
    - KL (=Kino Lorber) BD releases are not handled OK. When choosing "Play Video" no subtitles are found despite being present. When choosing "Play with Blu-ray menu" an option for subtitles On/Off is present. When selecting On in that menu the movie is still starting playback without subtitles but selecting/deselecting them during actual playback works as expected. Used the movie Alphaville for testing but basically all KL BD releases have that exact same problem.In Europe KL releases many classic movies:

    Other remarks, problems and observations:
    - Seamless Branching is confirmed as still not working. In fact it got a lot worse as it now gets stuck on every jump. Used Toy Story 4 UHD/HDR BD ISO for testing.
    - Movies with Lionsgate Playlist Obfuscation copied disc detection won't play (correctly). With BD Menu BD players will run straight into the "copied disc detected" message displayed for 1 minute and return to the Main Menu as frankly all BD-J enabled players do. The BD-J Menu processing is not done correctly either with this FW and it will even remain stuck there. Without menu it falls into the obfuscation trap and plays a wrong playlist sequence. Used Lionsgate Knives Out UHD for testing.
    - Some MKV's with 4KP60 and 1080P25 cause a flickering green screen but the sound playing normally. When turning OFF Automatic Frame Rate and Resolution they do play though. It is a valid bypass and even stranger after doing this once I was unable to get it wrong again.
    - Music Player has an icon for playmode: List Cycle, Single Cycle and Shuffle play but the most common List play is absent. That should even be the default in my perception: Stopping at the end of the queued list.
    - Swedish and Swahili got mixed up for subtitles (unless they started to speak Swahili now in Scandinavia)

    Picture Player (included as it got attention after a very long time)

    - It can display pictures as a slide show with background music but pictures are not turned automatically then. Neither manual turning works with slideshow.
    - No thumb nails/picture gallery to find the right picture(s) quickly. This is one of the main function of such an APP in my view.
    - Picture player also works in 4K native resolution for gorgeous pictures on your TV or projector. Now works with slideshow too. Fix confirmed.
    - Pictures may be set here also to be used as wallpaper. No option to reverse this to get the original back here (must go to setup for undoing it).
    - I am missing a real zoom feature with panning around using the remote.
    This will be very useful with the extreme resolutions pictures are getting these days.
    - There is also the Image Player APP which I don't have a clue how to control it.
    It is started by the dedicated button on the remote control though, but seems to have been disabled now completely.
    - It would be nice if 4K would be used automatically if Auto Resolution Switching is enabled in Video Setup. Now I have to do this manually each time.

    Specific DVD playback related inconveniences:

    - DVD's are always played with DVD Menu processing if present (many rips stripped them). This in fact makes the next inconveniences worse as they can't be bypassed skipping the menu.
    - The DVD may be difficult to control settings with some Menu's as the color overlays for the setting fields may be shifted vertically (sometimes a lot or even gotten invisible).
    - If may be impossible to control the settings using a Zidoo BT remote as the cursor does not react on the cursor movements (it seems it uses other codes than the old simple IR is doing).
    - Using/jumping chapters does not work using the remote control.

    I call them inconveniences as the actual viewing still works and it has been always like this.

    Overall verdict: once more a quality update, regarded the best FW available thus far by me.
    But on the other side the player is still not fully stable yet:
    - Had to restart a video several times (jerky playback at start)
    - Saw several spontaneous reboots (when interrupting video playback)
    - Lost communication with Zidoo Controller once requiring a Z9S restart to get it going again
    - Got an error message multiple times that Google Services were stopped.
    Everything worked fine after these interruptions doing the same actions once more.

    I have the gut feeling that we really need a ROM image with the next FW update to get a clean fresh start. Obviously including also GAPPS.
    Later upgraded to FW 2.3.17 to test seamless branching, making things worse in general so did a clean restart and next upgraded to FW 2.3.10 which is running stable since I did that.

    For me it almost stable but I hardly play any MK, AVI etc at all just, Music, DVD, BD and UHD-BD from Folder or ISO.

    Seems something often goes wrong playing MKV specifically as reported by others.

    If the long list above makes you think it is a bad player which is not the case then please read my Full Review here:

    It will be updated again with the next stable release (not being a Beta).

    More to follow (added as updates here) when progressing my listening/viewing!
    Last edited: Mar 15, 2020
  10. arcazal

    arcazal New Member

    Forced subtitles in Blurays, when?
  11. chiquito3

    chiquito3 Member

    I managed to download the firmware, but now the upgrade is taking forever to finish. How long does it take?
  12. chiquito3

    chiquito3 Member

    Need URGENT advice! My Zidoo is stocked at the Android robot screen with the firmware update. It's been there for more than 20 minutes now. This is is the first time it takes that long.
    What do I do now?
  13. Schumy

    Schumy Member

    This firmware is working fine for me (mainly for playing 4K HDR mkv files), it seems to have fixed the wrong file (same movie with multi files) problem, no freeze/reboot so far. Also the VLC media app playback has been imporved, no more lag or skip frames.

    (BTW, a side tracked Q, with VLC media app, how to get audio to output multi channels instead of just PCM 2.0? Many thanks)
  14. chiquito3

    chiquito3 Member

    Well after 45 minutes I decided to turn off the Z9S and then turn it on again... to my surprise, it was updated.
    DELUCAS likes this.
  15. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Yes this can be really scary but is not a reason for instant panic fortunately. I have seen this happening on some occasions too. It is a real Android thingy as it happened to me on multiple players from different brands randomly without a clear reason.

    If after half an hour it still remains stuck there is no other remedy than pulling the power plug. This despite the explicit warning not to do so. In most cases it will then just update after powering it on again. In rare cases the emergency flash procedure may be needed to get it going.

    Good to hear the mentioned problems introduced with previous recent updates were removed again.

    Now just seamless branching needs to be tackled finally to get a very nice general update! :cool:

    A lot to be done remains for Music Player but progress is steady.
    Last edited: Jan 26, 2020
  16. Schumy

    Schumy Member

    I celebrated too early, it freezes and reboots just now while playing a mkv movie.
  17. 7SN

    7SN New Member

    If you mean accessing Zidoo from MacOS using SMB, you can, there is a fix for it that worked for me.

    just create a file named "nsmb.conf" in the "etc/" folder contains the following:

    that should do it.

    If the other way around, I couldn't find a fix for it
  18. Boccolone

    Boccolone New Member

    I played several mkv movies yesterday, and all dolby d the audio goes off about 20 times for a second. Before the update occurred with the dts
  19. karipu

    karipu Member

    That’s what I meant.
  20. Good morning,
    I apologize for both the inconvenience and the English, in fact I am writing with Google Translate.
    Among the various interventions, one thing I would like to kindly understand .......
    I have the Z9s with the latest beta firmware, maybe soon I will be able to get hold of a receiver that for HDR reasons, I will be forced to connect it to the Z9s with an optical cable .....
    Clearly, only the standard multichannel encodings will pass through it (and I am aware of this), what I would like to know is if with this connection, someone has had problems, both a multichannel and in Stereo 2 Channels for music.

    I end my question by saying that the Z9s is connected via CAT 6 LAN cable to the QNAP NAS that I have .......
    All of my content is on the NAS, so I don't connect any other HDDs to the Z9s.

    Thanks in advance and best regards.

Share This Page