New firmware v2.1.40 beta version for ZIDOO Z10 released

Discussion in 'ZIDOO Z10' started by mirror, Jan 27, 2019.

  1. DIKKE

    DIKKE Member

    Nope, not here. The internal HD on the Z10 ( WD BLUE 6TB) is running fine? Are you talking about internal, or a external USB drive? btw running .30 fw, not his beta.
    Last edited: Feb 12, 2019
  2. Bogusław

    Bogusław New Member

    The problem concerns external USB 3, I did not check if the error is also on the internal disk.
  3. fydo

    fydo New Member

    [QUOTE = "Bogusław, post: 84568, miembro: 30181"] Ahora el Zidoo Z 10 es inestable, el HDD ha perdido su conexión USB durante la película, necesita reiniciar o transferir a otro USB. ¿Alguien más ha tenido ese problema? [/ CITA]

    That happened to me when I connected a USB stick to the front. stopped detecting the main HDD. I removed the USB, switched off and turned on the power and left running. These Zidoo fail those that a shotgun of an amusement park or a fair.
    gymnos likes this.
  4. Big JW

    Big JW New Member

    Similar to other users I also came from Popcorn to Zidoo after contacting Popcorn and finding out they are no longer doing devices like this. What I love about Zidoo is the quality of the picture and sound and the fact it plays everything. What I really miss about Popcorn is when I turned it on it would start in the folder where I left it off. Also I loved the fact when Popcorn was off I could still send files to the hard drive on it over the network. Zidoo needs to implement these 2 features if they want to be competitive otherwise using it is a pain. Even my wife complains about the fact she had to do 6 different things just to get to the directory where we upload all our tv shows to every-time we turn it on.

    Another annoyance is that Zidoo does not remember the sort order for a folder. So every-time you go into your folders it sorts by date. For some folders I prefer it to always sort by name.
    gymnos and fydo like this.
  5. Aleale74

    Aleale74 New Member

    Hi everyone ,I come from a popcornhour c300.I noticed that this z10 is wrong at the refresh rate with DVD and bdisk, with single files instead it's Home Theater 3.0 I do not understand why I can not switch from one movie to another when I'm in view mode of a single cover (in the info of the film), some TV series does not insert correctly obliging me to insert everything by hand.The music player is still imperfect and the selection of the songs seems confusing, perhaps an alternative music app for android would be better, excellent instead the lyrics of the songs downloaded online, a great feature.
  6. Zigourney

    Zigourney Active Member

    Any news when the next firmware update is likely to land?
    Hoping Zidoo are focusing on getting the 10 bit blank screen issue fixed :(

    My Z10 is gathering dust in the meantime......
  7. Miguel Ramos

    Miguel Ramos Member

    Have you already tested the latest firmware to check if the issue was solved?
  8. kestasm

    kestasm New Member

    I have z10 and lag more movies with 1920 resolution
  9. Paul Levy

    Paul Levy New Member

    Loaded the new beta firmware..."HELLO" permanently on Z10 display , no clock or movie time countdown. Other than that played 99% of what I have thrown at it from an internal hdd
  10. Zigourney

    Zigourney Active Member

    Hi - Yes installed latest beta, but player just hangs and comes to a pause a few mins into any 4k hdr movie, it also becomes unresponsive to remote commands. Only way to bring it out of the hung/crash status is to power off at mains. Firmware totally makes the box un-useable.

    Zidoo have removed the latest beta link thread.
  11. kestasm

    kestasm New Member

    I installed the 2.2.55 firmware. Zidoo removed link.

    Some Problems:

    - The LED display is always "Hello".
    - Lag 1920x1080 movies, also some 4k. (TV old Panasonic plazma and only shows 1080p). < Me sad.
    - When loading z10, the zidoo logo black screen flashes with color artifacts. should this be?
    mtwaldman likes this.
  12. Paul Levy

    Paul Levy New Member

    kestasm , half way through The Outlaw Josey Wales tv screen flickered and "HELLO" was replaced by the usual movie runtime , hope the same happens to all who updated. I will let the film complete then see if the clock is restored
  13. mtwaldman

    mtwaldman New Member

    I also installed the 2.2.55 firmware, ugh. now nothing plays right. tried following all instructions on how to downgrade firmware, and NOTHING works. ugh. Sucks
  14. mtwaldman

    mtwaldman New Member

    Did you try to downgrade the firmware? I have had zereo success and now nothing works!!!! ugh.

  15. kestasm

    kestasm New Member

    How to downgrade 2.1.30?
  16. kestasm

    kestasm New Member

    I find tutorial. iMac dont format usb flash to fat32
  17. kestasm

    kestasm New Member

    does not work downgrade...
  18. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Follow the emergency flash procedure using the install.img file first next install target FW. Procedure can be found on the forum with all detailed steps.
  19. kestasm

    kestasm New Member

    How to emergency with install.img?
  20. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Install on USB stick and press the reset pin during power on next release it. It is in help and on this forum.[ld]3ulg==.html
    The same procedure for all models only the reset hole is in different places.

    You may also wait for the fix which should not take ages. Personally moved back to my Egreat A11 for the time being. ;)
    Last edited: Apr 2, 2019

Share This Page