New firmware v2.1.22 version for ZIDOO X9S release

Discussion in 'X9S Official Firmware Releases' started by mirror, Jan 16, 2019.

  1. lucabis

    lucabis New Member

    I have done other tests here and there and it seems to work. When I have more time I will watch a whole movie and see if the problem will be solved with the suggested settings.
     
  2. highonthehog

    highonthehog New Member

    Anyone know how to change the language for the time played for movies in the Home Theater 2.0 under the history tab?

    It only shows in Chinese, and unable to change the language to English.

    Anyone has the solution to this?

    Thanks
     
  3. x9suser

    x9suser Member

    Could be a bug.
     
  4. Gordon888

    Gordon888 New Member

    DVD menu cannot play
     
    monsak.zidoo.x9s likes this.
  5. x9suser

    x9suser Member

    All DVD menus working . No problems.
     
  6. monsak.zidoo.x9s

    monsak.zidoo.x9s New Member

    In media player some DVD nenu need to select (language) before play (no count down number to auto play) is not work.

    choice can choose but can not enter.
     
    Last edited: Feb 12, 2019
  7. vman

    vman Member

    After the latest firmwire update, my home theater is not working. I scanned my hard drive and it does not recognize any of my movies.
    For example, Incredibles 2, AntMan and the Wasp, The Meg, etc.,. It recognized them on the prior firmware.

    I tried typing in the IMDB ID number and that didn't work either.

    Any suggestions?
     
  8. lucabis

    lucabis New Member

    I watched a movie with the settings you recommended: 10 bit color space yc 444 and hdmi range 16-235 but the problem recurs there are 2-3 holes where the screen turns black.
     
  9. lucabis

    lucabis New Member

    No one knows how to solve this annoying problem that sometimes the screen turns black randomly?
     
  10. SaskMedia

    SaskMedia Member

    That’s usually an HDMI handshake issue. Only time I’ve ever had that is when using an poor quality HDMI cable or using one that was too long. Does it only happen with HDR or with all videos?
     
  11. lucabis

    lucabis New Member

    With all.
     
  12. SaskMedia

    SaskMedia Member

    What model of TV? How long of cables are you using and what brand?
     
  13. Deano86

    Deano86 New Member

    And I assume you have at the very least, reseated the cable? If that doesn't work, swap cable with another....
     
  14. lucabis

    lucabis New Member

    My tv is: lg65b6v. The brand of cables sincerely do not remember. Between the tv and the x9s there is a soundbar yamaha ysp2700
     
  15. Deano86

    Deano86 New Member

    Reseated all cables then? And if all else fails, technically you can update firmware on your soundbar too.... something to consider even though it appears the latest update shouldn't have anything to do with your symptom... but you never know..
     
  16. lucabis

    lucabis New Member

    The soundbar is already updated
     
  17. lucabis

    lucabis New Member

    Do I have to change the cables? What brand do you recommend?
     
  18. FrobozzWiz

    FrobozzWiz New Member

    Has anyone upgraded to this release from the 2.1.1 version? I was forced to reflash my X9S and ended up on 2.1.1. It was then that I discovered that people were bricking their devices when trying to downgrade from that version. So this release seems different than previous ones and I just wanted to ensure that it was working ok in the normal upgrade path.
     
  19. SaskMedia

    SaskMedia Member

    I’ve used monoprice cables without issue. However I have had issues with working brands when they get over the 6 foot length.
     
  20. 3DBuff

    3DBuff Active Member

    Why don’t you try one cable directly from Zidoo to the TV to see if you have a problem.
     
    Deano86 likes this.

Share This Page