New firmware v1.5.0 version for ZIDOO X10 release

Discussion in 'X10 Official Firmware Releases' started by mirror, Dec 8, 2017.

  1. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Model: ZIDOO X10

    System:
    1, optimize the effect of HDR to SDR
    2. Repair on some TV, some HEVC 10bit MKV files shows the problem of gray(Range issue)
    3. When the resolution is set automatically, the priority 4K resolution
    4, frame rate switch increase can correspond to film switching resolution function

    Player:
    1, repair some sup subtitles display abnormal problem
    2, repair the problem of downloading wrong subtitle language
    3. The optimization of the Bluray titles shows
    4. Repair the problem that MTS can't repeat all
    5. Optimization of frame rate switching mode
    6,Optimization some srt subtitles display effect.Added color #9c9c9c #b5b5b5 #cfcfcf.
    7,solved some SAMBA error(about Path contains space)
    8,solved some SRT subtitles show the excess of ’1‘


    Blu-ray navigation:
    1, repair the problem of downloading wrong subtitle language

    Music player:
    Add a new version ZIDOO Music 2.0
    Support SACD ISO,DFF,DSF file playback.

    Download:http://ota-cloudfront.zidoo.tv/X10/OTA/OTA-X10-v1.5.0-201712182057.zip
    MD5:487240934212565718cf5efa7c4b45da

    How to upgrade
     
    Last edited: Dec 21, 2017
    budahom and DELUCAS like this.
  2. DELUCAS

    DELUCAS Active Member

    Thanks mirror :)
     
  3. 6gex

    6gex New Member

    Installation done, while installing only got a black screen with hello for 10-15 min.
    I ve set the resolution and frame rate on auto and my 4k hdr demo and movie are played in 4k. Was not the case in previews firmware.
    Will need more time to test for now seems to work. :)
     
  4. OlivierQC

    OlivierQC Active Member Beta test group

    thanks mirror,


    Great job of the zidoo team

    the auto frame rate / resolution works perfectly.

    I no longer have a loss of signal when the zidoo switches to the right frequency

    etc....

    I will look more deeply but it is already positive

    about the 10bit problem with banding and compared with other box, the auto mode (12bit signal) does the job well, so I will not talk about this little problem that disappears using the auto mode.


    I'm going to update my X10 review with the 1.4.20 beta


    see you
     
  5. Melgon

    Melgon New Member

    Thank you, mirror.
    I seem to have lost Dolby TrueHD, and consequently Atmos, on my connected Denon AV receiver after the v1.4.20 update.
    I have tried it with 1080p Blu-Ray content and 2160p UHD Blu-Ray content.
    Also, tried both, the Auto and RAW audio setting in the Quick Settings. I even did a complete system reset.
    Other than that, as OlivierQC has stated, auto frame rate and resolution works perfectly.
    TrueHD and Atmos works fine from my OPPO UDP-203 player (connected to the same AV receiver).
    When I select the TrueHD track in content playing on the X10, the AV receiver only "sees" regular Dolby Digital.
     
  6. OlivierQC

    OlivierQC Active Member Beta test group

  7. OlivierQC

    OlivierQC Active Member Beta test group

    Hello Melgon,


    Atmos : it seems to work for me.



    True HD : it does not seem to work for me, there is a downgrade to DD



    -----------------

    I checked with my X9s (FW 1.4.12) and there was already the same problem with the True HD and DD +.

    it may be a limitation of the realtek chipset

    see you
     
    Last edited: Dec 12, 2017
  8. 6gex

    6gex New Member

    If i put the color mode on auto i get a black screen, but if i put it to ycr 422 the i get the image.
    Im connected to a marantz sr7010.
     
  9. Pilli

    Pilli New Member

    I wanted to know if the firmware is stable enough and it's better to install it thanks
     
  10. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    works fine for me, but i can't test for all functions ( like pass trough )
     
  11. Pilli

    Pilli New Member

    thanks you
     
  12. DELUCAS

    DELUCAS Active Member

    Tested Movie in 1080p 5.1 DTS passthrough Receiver reconised DTS sound format .
    So no issues at moment .
     
  13. ton_dahlia

    ton_dahlia Member

    Still have some error for playing BD menu (such as MIB 3 iso)

    Hope to be better next version , and also think that please give almost 100% BD menu before develop 4K Menu.

    Thanks
     
  14. OlivierQC

    OlivierQC Active Member Beta test group

    what is the problem with the BD menu ?
     
  15. muzafferg

    muzafferg New Member

    I loved the improvements Zidoo music 2.0 , subtitle download corrections and picture quality. Thanks
     
  16. ton_dahlia

    ton_dahlia Member

    I just found some ISO movie that zidoo cannot play BD menu such as MIB III , but now the other things is improve well

    thanks
     
  17. ton_dahlia

    ton_dahlia Member

    Now I have some problem

    After update to 1.4.20 then factory reset, it cannot play BD and 4K menu every files.

    Please suggest
     
  18. DELUCAS

    DELUCAS Active Member

    Have you done a complete power off cycle ?
     
  19. ton_dahlia

    ton_dahlia Member

    Yes, and now I just re-install this FW again but the result is the same.

    Please suggest
     
  20. ton_dahlia

    ton_dahlia Member

    Now I just flash X10 to 1.4.12 , but the same result on this version

    cannot play every files with BD menu

    please help
     

Share This Page