New firmware v1.2.7 for ZIDOO X9S released

Discussion in 'ZIDOO X9S' started by mirror, Nov 19, 2016.

Thread Status:
Not open for further replies.
  1. kayama728

    kayama728 Member Beta test group

    hi Freroc

    i mean this:
    DSCN0476.JPG DSCN0484.JPG
  2. panther7

    panther7 New Member Beta test group

    Sometimes, if devices wake up from stand by mode, reset language to English (from Czech).
    Sometime lags video from Youtube (1080p+)
    Playing video via Kodi is not cleary smooth.
  3. Mike-zidoo

    Mike-zidoo New Member

    About Youtube lags.
    There are two type of lags: sound lags and video lags.

    Using official Youtube client (from google) or using ZDMC with youtube extenstion:

    Sound and video lags appears on ANY video at ANY quality. Internet connected via cable. Internet connection speed ~ 100 Mbit/sec. Zidoo X9S with firmware 1.2.7 (previous firmware versions have this issue too). Video lags appears only using official youtube client.
    Video lags:
    Video playing is not smooth. Video lag appears approx every minute (sometimes more then minute, sometimes less). Video stops for about 0.5 sec, then skips small part of video and then continues. At the same time sound disapearing too and continues with video.
    Sound lags:
    One type of lags was mentioned above. Second type of lags appears ~ every 3 - 7 min and can be described as "bzzzzzzzzz sound" for about 0.5 sec.

    Using Youtube for Android TV:
    Common description:
    No video lags at all. ANY video plays smoothly on ANY quality.
    Sound lags - same as second type of lags mentioned above: every 3 - 7 min "bzzzzzzzzz sound" for about 0.5 sec.
  4. dennys84

    dennys84 Member

    Used both versions of youtube client, both of them has sound and video lags. If its a caching issues related to internal memory, then why does twitch client running flawlessly? The uses different mechanism, or what?
    When i say videos lags, i meant micro-freezes, but there are another things like absense of smoothness, hard to say, but if try to download the video and watch it for example in zidoo player, and then compare to youtube, the differense is huge! Its important that that not autoframerate thing. Tv is in 50p mode all time.
    Last edited: Dec 10, 2016
  5. tomeeli

    tomeeli Member

    Dear developers! Please answer on my question. Were you able to reproduce the problem with switching resolution to 720p after turning off the TV?
    Once again I want to describe how it happens. Firmware 1.2.7. LG TV 55EG920V. Settings-screen-resolution. When setting the "auto" mode X9S sets resolution max 1080p@60, respectively, all 4K video downmixed in FHD. When you manually select the resolution in X9S 3840×2160@60 4K video plays in the correct resolution, but when you turn off the TV and translation X9S to sleep or if you leave it on then after a while after turning on the TV set-top box resets the resolution to 720P. If X9S off together with the TV and then turn on both the resolution is not reset, it remains something that is manually set in settings.
    Subspecies total. Resolution resets to 720P if you turn off TV without turning off X9S. The resolution is not reset to 720P if you turn off the TV along with X9S and then together enable.
    I beg you, fix this problem tired of every time you turn on the TV to go into the settings and set again the desired resolution.
    I hope that you understand me. Thank you!
  6. Mario Johnson

    Mario Johnson New Member

    As for struggling to play normal files from a USB stick this has got to be a bug in the firmware. A friend of mine has just bought this box and after i put the latest firmware on for him his box is also struggling to play these files.
  7. kayama728

    kayama728 Member Beta test group

  8. wolfrick

    wolfrick Member

    It happened to me exactly the thing, with the same TV. I couldnt fix it, and at the end i did a factory reset. It solved the problem, although i dont know why. It doenst matter which setting i am using, the resolution problem doesnt come up anymore.
    Good luck!
  9. freeroc

    freeroc Active Member

  10. freeroc

    freeroc Active Member

    For this , Please close the HDMI CEC
  11. tomeeli

    tomeeli Member

    A factory reset on X9S and TV is the first thing I did was flashed at on a purely img file. Dealt with build.prop that does not help!
    Why support Zidoo about this problem silent?
    I know people in your community who have similar problem too, but on other TVs.

    I should add that there is a Beelink MiniMX and it is 4K resolution displayed and is not reset after turning off the TV!
  12. wolfrick

    wolfrick Member

    I am not sure, that i understood you correctly. Factory reset does not involve re-flashing.
    The problem is a bit more complicated, since I cannot reproduce that phenomenon since I did the factory reset. Until that it happened every morning when I switched on the TV. So i think that there is a faulty settings, which is eliminated (at least at my device) by the factory reset.
  13. Mak

    Mak New Member

    I have X9S>Onkyo TX-NR646>Samsung UE65JS8500T
    Set up: hdmi 3840×2160 60, HDMI CEC off, all over settings- default. F/w 1.2.7
    1. At first Internal and external players in Zdmc works fine. If you turn off the TV and receiver and then turn them on again, the screen resolution is changed to 1280x720. In system settings are available only modes until 1280. The language is also changed from Russian to English. When starting any player, the screen resolution is changed to correct for the film. In over apps, like file explorer, resolution still incorrect and picture don't fitt in screen.
    2. YouTube from google market shows only the first frame of video and stop. Cable Internet is working good. (Upd: Began to play fine after reboot. If AceStreamMedia or ZDMC had run before YouTube staying at first frame of video)
    3. Zdmc internal player with activated "pass through" don't give any sound playing numerous *.m2ts files ripped from dts demo blu-rays. Sound appears only after after a short rewind.
    4. Playing Atmos and dts:x tracks internal and external Kodi players and onkyo shows dts-hd 6ch. Tracks is good.

    I hope that you will be able to fix this issues
    Last edited: Dec 16, 2016
  14. Mak

    Mak New Member

    Every new day gives a new surprise from x9s.
    When I select in zdmc list "movies " video in ISO file any player (int/ext) starts to play the first following in list non-ISO file. (Upd: in list "videos " ISO files play fine with bly-ray menu)
    Please fix this problem
    Last edited: Dec 16, 2016
  15. kayama728

    kayama728 Member Beta test group

    no but it shows wrong, " and ' are not the same
  16. panther7

    panther7 New Member Beta test group

    If CEC funtions are enabled/disabled, then this issue is same.
  17. screwdriver072000

    screwdriver072000 New Member

    I'm having problems with my x9s firmware 1.2.7. If I set the HDMI out (audio and video) to auto, and all other settings to auto, 4k movies are outputted to 1080p only. But if I set it to 3840 x 2160 60hz, which is the native resolution of my tv, there are audio dropouts in DolbyAtmos soundtracks. So, will you please help me, what are the recommended settings in order the player to output the correct resolution without having problems with the soundtracks.
  18. DaMacFunkin

    DaMacFunkin Active Member

    10 bit
    24hz force playback yes
    HDMI audio output raw.

    You are right, these things are annoying and Zidoo need to get on with fixing them instead of playing about with the front vfd or that stupid z theater or whatever it is.
  19. freeroc

    freeroc Active Member

    The problem is ,that when the system occur a error by reading the EDID of TV,it is forced to 720P to assure the display instead of black screen.
    The programmers will revise the code of this part.
  20. freeroc

    freeroc Active Member

    Yes,it seems the issue still remains.
    We'll revise the code of CEC language.
    Have you tried switch your TV and receiver to your local language? The TV or receiver sent a EDID signal of language to X9S, it caused X9S change itself .
Thread Status:
Not open for further replies.

Share This Page