New firmware v1.2.7 for ZIDOO X8 released

Discussion in 'ZIDOO X8' started by mirror, Nov 24, 2016.

  1. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Version 1.2.7 of Zidoo X8
    Updatelist:

    System:
    1,A download tool aria2 added in OpenWrt system.
    2,The brightness of VFD can be adjusted now in the setting of system.VFD stands for vacuum fluorescent display which is in the front panel.
    3,3D library of skia been improved,subsequently scores of Antutu exceed 40000.
    4,Green screen appears occasionally when play 3D movie, this issue has been fixed.
    5,RAW out of sync when play some TrueHD and DTSHD HRA movies, this issue has been fixed.
    6,After HDR playback exit,HDR status don't back to normal status, this issue has been fixed.
    7,The setting of Force downmix audio can't be saved after restart the box,this issue has been fixed.
    8,Optimized audio option.If the settings is RAW and playing AAC audio,The audio output will be temporarily auto changed to PCM
    9,Enable the statusbar

    Launcher:
    1,More tips added in the desktop interface.
    2,The mouse cursor style changed into a better one.

    Player:
    1,The offset of subtitle will only valid for once.
    2,AutoFrameswitch added 30fps and 60fps.
    3,If the movie is paused,press the menu key will not resume the playback.
    4,When searching the subtitles,the system will make it a priority to search the subtitles in default subtitle language setted in system advanced settings.The lower priority is system language.The lowest is English.
    5,Removed Force SD audio setting.
    6,Removed the auto-identify of MKV's MVC.(We now rewriting this part)
    7,Bookmarking function is open as default.
    8,Press OK to play from the beginning when resuming playback from bookmark.
    9,3D playback tips added.

    Filemanager:
    1,Immediately sync after copy or delete.
    2,A button to return to top added.
    3,A wrong error report when add&remove the directory in Russian language fixed.

    Full_OTA_Packageļ¼š
    Mediafire mirror:http://www.mediafire.com/file/k7b0y21hq8g3kjq/ZIDOO_X8_OTA_v1.2.7.zip
    Amazon mirror:http://ota-cloudfront.zidoo.tv/X8/ota/v1.2.7/ZIDOO_X8_OTA_v1.2.7.zip

    md5:86cfae0820c5cf00c5850162d28879b8

    How to upgrade: http://www.zidoo.tv/Support/guide/guide_target/7kv1voas1D1KKmVViAFMcQ==/guide_faq/CN6lY0XMyIg=/faq_page/9nCdOWqz+dw=.html
     
  2. OlivierQC

    OlivierQC Active Member Beta test group

    Thanks Mirror,

    @spring

    i will check the CEC this evening.

    and the issue with TrueHD and ATMOS (audio dropouts)
     
  3. Movie78

    Movie78 Member Beta test group

    Thanks!
     
  4. Robynet73

    Robynet73 New Member

    When played 4K 24hz 10bit HDR files video the screen is black
     
  5. Thanks for the update. Looked at the improvement list and wanted to know where 3D MKV lack of depth and HDMI CEC issues are on the list of things to address. I know the 3D MKV issue was a longer term issue to address in the future. I also know that there have been efforts to address HDMI CEC issues that have not fully solved the problem.

    I have both a X8 and a X9s and both have HDMI CEC issues. I have to keep the X9s on a CEC less adapter because of the problems that it causes. I tested each version of the firmware (excluding those put out in the last 24 hours) by removing the CEC less adapter and end up having to put it back on once I discover it still has issues. Even turning off HDMI CEC on the X8/X9s doesn't help. I got to use the CEC less adapter.

    What are the CEC problems? They have been reported on the X9s forums. The X9s is connected as follows:

    X9s --> Marantz NR 1606 --> Samsung UN55JS8500
    Samsung UBD-K8500--> Marantz NR 1606 --> Samsung UN55JS8500
    --OR--
    X9s --> Sony STR-DN1070 --> Samsung UN55JS8500
    Samsung UBD-K8500--> Sony STR-DN1070 --> Samsung UN55JS8500

    Why do I mention the UBD-K8500? Because the X9s causes all CEC devices that normally play nice with each other to no longer do so. I tried both the Marantz and Sony AVRs to see if it was just an issue with a particular receiver and the X9s. It wasn't. The issues include:

    1) Turning on when it isn't set to do so.
    2) Causing CEC control to fail with other connected devices.
    3) Causing connected devices to become non-responsive or respond when they shouldn't.
    4) Turning off the X9s HDMI CEC alone doesn't fix the issue.
    5) Significant delays between start up of the X9s and when CEC actually does occur.

    It sometimes it even requires unplugging the receiver and/or TV before adding the CEC less adapter back to the X9s and plugging it back in. When the X9s is out of the chain or the in the chain with the adapter, everything else in the chain is happy.

    Now lets take a look at the X8. I tried the following:

    X8 --> Sony HT-Xt1 --> Samsung UN46JES7100
    Samsung BD-E5900--> Sony HT-Xt1 --> Samsung UN46JES7100
    --OR--
    X8 --> Sony HT-Xt1 --> Samsung UN46F8000
    Samsung BD-E5900--> Sony HT-Xt1 --> Samsung UN46F8000

    1) Turning on when it isn't set to do so.
    2) Turning off the X8 HDMI CEC alone doesn't fix the issue.
    3) Significant delays between start up of the X8 and when CEC actually does occur.

    Again, these devices played well together before the introduction of the X8.

    I speculate if I were to swap the X8 where the X9s is installed, the issues would be identical to the X9s.

    I've seen this type of issue before with a Channel Master DVR (it doesn't support HDMI CEC) causing the same havoc. The problem went away only when I installed a CEC less adapter on it. Later, Channel Master fixed the issue with a firmware but never should've had an issue since their device doesn't even support HDMI CEC.

    Any insight on what you guys at Zidoo know would be greatly appreciated. I know HDMI CEC is sketchy on a lot of Android boxes but I did have one that worked perfectly. It was replaced by the X8.
     
    Last edited: Nov 24, 2016
  6. Robynet73

    Robynet73 New Member

    I can confirm Movie with 1080p/23.976 stutters every 20-30 minutes only audio dts-mstr please check you fix it thanks
     
  7. spring

    spring Well-Known Member Zidoo TECH Supporter

    please try to set the deep color to "auto",and the color mode to "auto", to test it.
     
  8. OlivierQC

    OlivierQC Active Member Beta test group

    @Robynet73,

    is this a demo 4K ? if yes could you tell me what is the title.
     
  9. Robynet73

    Robynet73 New Member

    Now it works(video is tarzan)thanks
     
  10. Robynet73

    Robynet73 New Member

    hi, i have a problem with a player the maximum resolution is 1080p 60 hz, in the configuration menu, there are no other resolutions
    I did the factory reset but nothing, I reinstalled the firmware anything, do not know anymore what to do.
     
  11. Robynet73

    Robynet73 New Member

    Sorry it all Okay
     
  12. jcetg

    jcetg New Member

    Hello, thanks I successfully upgraded to 1.2.7 yesterday.
     

Share This Page