NAS service

Discussion in 'ZIDOO X9S' started by francishe, Sep 30, 2016.

  1. HaoSs

    HaoSs Well-Known Member

    sure. i will try it. post away
  2. francishe

    francishe Member

    aria2 for Android devices
    aria2 is a lightweight multi-protocol & multi-source download utility operated in command-line. It supports HTTP/HTTPS, FTP, BitTorrent and Metalink. aria2 is not an ordinary Android Java application. It is a C++ native application and operates in command-line. You don't have to 'root'
    your device to use aria2. Because aria2 is a command-line program, you need a terminal emulator.
    aria2 is not self installed but only an executable. So before installing, you will need two apps, ES explorer and Terminal Emulator.
    First install Android Terminal Emulator and ES explorer. Then

    1. Copy aria2c executable to /mnt/sdcard on your box, which you can download from its website

    2. Run Android Terminal Emulator.

    3. mkdir /data/data/jackpal.androidterm/aria2

    4. cat /mnt/sdcard/aria2c > /data/data/jackpal.androidterm/aria2/aria2c

    5. chmod 744 /data/data/jackpal.androidterm/aria2/aria2c

    6. Add the following commands to the initial command of Android Terminal Emulator:

    export HOME=/data/data/jackpal.androidterm/aria2; cd $HOME;

    7. Save and exit Android Terminal Emulator.

    8. Run Android Terminal Emulator again.

    9. See whether aria2c actually works by invoking ``./aria2c -v``. If you see the version information of aria2c, it is properly installed.

    10. Return to initial command of Terminal Emulator. Add after "export HOME=/data/data/jackpal.androidterm/aria2; cd $HOME;" "./arai2c --conf-path=/mnt/sdcard/aria2.conf" if you put the conf file in that folder. The conf file contains all settings of aria2, which at least contains the following

    dir=/mnt/xxx /(downloads location)

    Save and exit the Terminal Emulator.

    11. You will need to create a blank file named aria2.session and put in /mnt/sdcard/ too along with the conf file.

    12. Open the Emulator and aria2 should work now. Each time when you need to run aria2, just open the Emulator.

    13. Download a web UI from its website and open it on Chrome. Click the spanner on the rigth upper side to open the setting. In json-rpc enter your ip:6800/jsonrpc. Now you control aria2.

    There are many conf file composed by the user on the web. You can download.
    sjn01 likes this.
  3. HaoSs

    HaoSs Well-Known Member

    did not have time to try it . but i can tell you torrents app from market report same thing. " location not writable "
  4. francishe

    francishe Member

    Can you give me the address of the threads reporting the same thing?
  5. HaoSs

    HaoSs Well-Known Member

    The app reports it. There are no threads. Install vuze and see
  6. HaoSs

    HaoSs Well-Known Member

    fix for transmission config load:
    connect to openwrt with putty
    "vi /etc/init.d/transmission"
    add sleep 30 in start script ( )
    use keyboard arrows to navigate to the line. press "I" to enter insert mode. write "sleep 30" . press escape to exit insert mode. write ":wq" enter, to write the file and quit, reboot

    can also be done if you have FTP set up. just navigate to the set file and edit it .
    extral likes this.
  7. francishe

    francishe Member

    Sorry, @ChaoSs. I am now talking about aria2 installed on Android instead of transmission which is now so far so good but far from perfect. After adding the torrent, aria2 on android 6.0.1 fails to make the download directory on the external HDD saying permission denied. But the HDD is writable.
  8. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    We will add aria2 in Openwrt
    HaoSs likes this.
  9. francishe

    francishe Member

    A million thanks. So I don't have to try and test myself. Would be in the next release?
  10. francishe

    francishe Member

    Given my experience of using them for years, aria2 is a lot better than transmission in every aspects and the author is very active improving it from time to time.
  11. HaoSs

    HaoSs Well-Known Member

    i know. but the permission problem is not just for aria2. vuze and utorrent report same thing, so its a android thing. So there is no point on trying to install it. I uset transmission in openwrt till aria2 gets implemented. What i posted was a test for transmission bug ( not loading the config at startup )

    Also zidoo don't give time for updates. I suspect 1 week to 1 month for next update
  12. francishe

    francishe Member

    Ok, waiting in hopes. I have stopped testing aria2 on the box till zidoo does it.
  13. alexpopov78

    alexpopov78 New Member

    Hello everyone
    Why connect so slowly with NAS (smb OpenWrt)?
    Sometimes I fail to connect. And having to try to connect again and again and again ..... and finally connected.
    Try a computer, phone, tablet, but the situation is always the same.
  14. inji75

    inji75 New Member

    Dear all,
    Thanks so much for these great advises and support.
    I received my X9S this week and I'm so far super happy with it.
    I installed new FW 1.2.4 but I've still the problem with transmission as discussed here.
    I followed Wolfrick instruction and don't know what I did wrong:
    1) I changed the resolv.conf in /etc/
    2) I changed the config path to : /storage/XXAA11BB[the alphanumerical chain of my Sata drive]/transmission
    3) I changed the download path to : /storage/XXAA11BB[the alphanumerical chain of my Sata drive]/
    It's still not working (no downloading nor uploading), did I miss something?
    Thanks for your help and best wishes,
    sjn01 likes this.
  15. HaoSs

    HaoSs Well-Known Member

    don't need to do that.
    in openwrt in transmission settings :
    config path to : /mnt/sda1 ( need to see what mount path it appers in openwrt )
    download path to /mnt/sda1/Download

    the /storage/blablabla is the mount path under android. you need to use the mounth pat under openwrt.

    sugest reset openwrt to default.
  16. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Does the old NAS package APK still work with this box next to OpenWRT? That one was much easier to use.
    This till all OpenWrt problems are solved and a good tutorial is available. For me it is (too) complex also.
  17. inji75

    inji75 New Member

    Thanks a lot for your help.
    Still not working. I may have some something wrong somewhere that I need to identify.
    Anyway, that's a pity because with that working the X9s would be just perfect...
  18. inji75

    inji75 New Member

    Dear all,
    Actually, the torrent download and upload is working for me thanks to the help of @HaoSs
    But the connection problem remains for private tracker and I still have the message "cannot connect to tracker". I still need to identify why and will come back to post here if I find a solution. Any help is welcomed.
  19. Sarco

    Sarco Active Member Beta test group

    I also had problem but leaving torrent going somehow fix by itself.
  20. HaoSs

    HaoSs Well-Known Member

    this option works for me. No problem so far.

    i only use private tracker. zero problems. Make sure you have only 1 external ip working with that tracker.

Share This Page