Issue between Z9X and HDMI ARC

Discussion in 'HDD Media player(RTD 1619DR)' started by Guzo, Jan 24, 2021.

  1. Guzo

    Guzo New Member

    Hello,

    I have found a bug with the Z9X and I am wondering if this has been raised before and if the team in charge of the FW is aware and working on a fix.

    When connecting the Z9X to an AV Receiver, the HDMI ARC will stop working on any other devices even if ARC is turned off in the settings of the Zidoo and the box is off.

    The only solution to get the ARC back (on my TV for example) will be to cut off the power to the Zidoo with the button in the back or unplug the HDMI, then the sounds returns instantly on the other device.

    I think it could be the way the box goes into Sleep mode, it must still be sending info on the HDMI ARC channel when it should be completely turned off.

    Thanks for your help with this issue.

    Kind Regards,
    Guzo
     
  2. Vinny4K

    Vinny4K Member

    OMG that's it.

    I'm the whole day busy trying to fix my arc on my Samsung QLED and can't get it fixed.
    After watching a movie it was gone.

    Zidoo was in standby.
    After reading your founding, I turned off the power with the button on the back and my arc works again.

    Thank you man! I was already shopping for a new audio system.

    @zidoo, please fix
     
  3. mattmarsden

    mattmarsden Member

    Yes I can confirm this as well.
     
  4. djslmft

    djslmft New Member

    i turned CEC on and has no issues with ARC, try that
     
  5. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    For the record I've never seen this - my test box is mostly switched on 24/7 - connected to a Denon amp on to a Samsung TV. I use ARC for Netflix etc from the TV and have never had an issue. CEC is off on all devices.
     
  6. djslmft

    djslmft New Member

    i just posted a possible solution, i have multiple devices on my AVR (Apple TV, Nintendo, BDP) and I usually use CEC to control them (don't have any smart remotes) and that made usage easy and comfortable
     
  7. Guzo

    Guzo New Member

    @djslmft I use a Harmony Remote and so I would rather leave CEC off on my devices but thanks for the tip it might help others, still think this bug should be addressed.
    Issue is happening on a Denon AVR X2200w and a LG OLED C9 for me. No way to get any sound in the Netflix apps or any others apps on the TV. @Markswift2003 maybe it could be due to eArc or the fact that I have an older AVR than you? It would be interesting that people affected list their devices here.
     
  8. Markswift2003

    Markswift2003 Moderator Beta test group Contributor

    Agreed - CEC is a bloody nightmare!

    My test amp is a Denon 7200 so (I think) older than your 2200 - it is ARC and not EARC..

    The Samsung TV is from 2017 and has 3 HDMI ports but only one is ARC and as I say, ARC just works regardless of what the Zidoo is doing - I've never even given it a thought
     
  9. matty2k

    matty2k New Member

    Can confirm the no sound output issue as long as z9x is connected via HDMI. I have already posted this to the bug list. Probably the issue is related to z9x CEC config. If you start z9x and shut down again while other devices switched on, sound output works again! I also tried to switch of CEC function inclusive all sub functions on z9x, That seemed to work a while but now fell back to the old situation. Using LG C7, Denon X1400H and Z9X. C7 sound with ARC channel via HDMI.

    kind regards
     
  10. DaMacFunkin

    DaMacFunkin Active Member

    It’s been covered plenty of times before, there have been versions of this boxes firmware where CEC is permanently on even if you switch it off and asa result ARC (in mycase Denon) doesn’t pass sound.
    I always have a Lindy CEC filter attached to my Z9X which fixes the problem.
     
  11. rozel

    rozel Active Member

    Over the past month or so I too have been messing around with ARC on my Samsung ARC enabled TV to try and get some output from its native apps, in particular Netflix and Amazon Prime. I agree wholeheartedly that Anytime+(CEC) on the Samsung TV is screwing up my system and have given up trying. However when I did get an ARC connection I did get a beautiful picture but absolutely no sound.

    My Zidoo is connected to a Vertex2 which then splits the signal to the TV and to my AVR. Given the issues in this thread am I also exposed to this issue and would turning off the Zidoo's power switch on the rear, restore the sound? Or does this issue only affect Zidoo's actually connected directly to the AVR? I too use a Harmony (Elite) Hub / Remote to control my setup so I have CEC switched of on all my kit. I'm waiting for eARC to be enabled on my TV (I'm probably living with false hope) as I've read enabling CEC isn't required for eARC.

    I would appreciate comments - thanks
     
  12. John7

    John7 New Member

    I've got HDMI CEC issues as well. With the Z9x in standby and CEC (in the Zidoo) turned OFF, my AVR is not switching ON my AVR (it turns off OK).

    If I enable CEC in the Zidoo, whenever I turn the TV ON the Ziddo powers up and my receiver switches to Ziddo input.

    The only way to cure this is to physically disconnect the HDMI from the Zidoo. I bought the Lindy CEC blocker but that doesn't work?

    I never had this problem with my "old" X9s. Any suggestions guys, this is frustrating (I know I can turn CEC off globally but I need ARC and have a technically challenged other-half that gets confused if it doesn't work right!
     
  13. AKI

    AKI New Member

  14. blenky

    blenky Active Member

    Well blow me down with a feather. I've had loads of issues with using ARC to my TV. Sometimes it works sometimes it doesn't.

    So reading this I tried watching TV Netflix app - and no sound via ARC as its been for about a week. Turned off the Z9X via the off switch not just off to red light . I then restarted the AV and TV. Boom! ARC working again!

    Never would have thought of that.
     
  15. blenky

    blenky Active Member

    Tried this - didn't work for me. Got ARC working as described in post above and disabled HDCP. After watching TV Netflix app with ARC I went to Z9X and back to TV ARC app - no sound. Did a reboot but still no sound via ARC. Repeated process in previous post and ARC sound back.

    So far me ARC will work until I next use my Z9X - unless I power off by the power button.

    Hope Zidoo can sort this
     
  16. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Yes, HDMI-CEC works only reasonable with no AMP in-between. The point is HDMI-CEC is integral part of the Android OS and works badly on all Android based players.
    I recommend using an HDMI-CEC blocker adapter when having an AMP.
     
  17. rozel

    rozel Active Member

    @Nice Monkey I'm reading all these posts, in particular "with no AMP in-between". I've not had a response to my above post #11 and so would be grateful if you could confirm if the way I've wired up my Zidoo "fits" within this scenario please. I am loathe to mess about again right now to try for myself as it means messing about with my hidden wiring and Anytime+ (CEC) and CEC on my AVR screws up my connections, resulting in a lot of work to restore. However if you or someone could say "it's probable your setup fits with this scenario and is the reason why you don't get sound when turning ARC on", then I will give it another go. I just want to see and hear what the TV's native Apps are like, as I think they will be the best way to get Netflix and Amazon etal.

    What is a HDMI-CEC blocker adapter and would this be applicable in my setup do you think? If so, where exactly should I fit it to work please?

    Cheers
     
    Last edited: Jan 27, 2021
  18. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Just do a search on "HDMI-CEC blocker" and you will find multiple to buy (around € 10,-). It is a M/F HDMI plug with the CEC pin not connected.
    Insert this plug directly into your Zidoo HDMI Output port and it won't participate in HDMI-CEC communication anymore.

    The fact these plugs are manufactured already indicates the problem is not unique nor recent.
     
    Last edited: Jan 27, 2021
  19. rozel

    rozel Active Member

    @Nice Monkey - yes thank you so much. But does my wiring setup fit within this "no sound" scenario?
     
  20. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    If it works when you disconnect your Zidoo then it will work too with Zidoo plugged in (being on/off) using such an adapter.
     
    Last edited: Jan 27, 2021

Share This Page