X9S HOW TO FLASH ZIDOO X9S UNIT

Discussion in 'ZIDOO X9S' started by HoneCharles, Oct 8, 2016.

  1. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    Worked fine for me. Hold the reset button longer ? Try other usb stick ?
     
  2. blicht10069

    blicht10069 New Member

    I've held the button for several minutes and I can tell that is working because it doesn't proceed to boot up normally. The usb stick works fine when I plug it into other machines.
     
  3. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    A) You don't need to press that long. Above lets say 5 seconds won't help.
    B) The stick must be formatted with 512 byte physical sectors and FAT32 is my experience with other players. The physical sector is determined by the manufacturer and can't be changed in any way. An USB stick may be working with other boxes and even work with Egreat to play media from or even to do an OTA with and still can be unsuitable for Emergency Flashing. Try multiple as HaoSs already recommended.
    The reason is that the boot-loader is a very simple program accepting only the layout which it exactly expects to find without looking at any valid variables accepted by Windows, Android or any other OS.
     
    Last edited: May 14, 2017
    sjn01 likes this.
  4. bodyzen

    bodyzen Member

    I agree. Everything went well to me.
    But before the flash I did a factory reset.
     
    Last edited: May 14, 2017
  5. blicht10069

    blicht10069 New Member

    Hi Nice Monkey,

    First, thank you for your information. I did find another USB stick which worked. A few points I would mention:

    1) The boot loader can be as complex or simple as the developers desire. I do realize there is a balance that they are trying to strike, but have a required type of USB stick on that is based on a property of the USB stick that is difficult to determine prior to purchase is a issue, which brings me to point #2
    2) I fail to understand why makers of Android boxes that are connected to the TV (as opposed to Andriod TV which is a different operating system) don't either: a) Make a recovery partition or b) hard wire in a small amount of read-only memory to flash the system from a known baseline. Zidoo is NOT the only vendor that is negligent in this area, almost all manufacturers are. I understand there is a cost involved in this, but that cost is fairly small and you could pass it on to your consumers. Given the fact, that almost all vendors do a lousy job or updating their system (this is a very difficult thing to do, I am NOT throwing shade, I'm just stating that reality is that this process leads to very unhappy customers all around) it behooves them to make the reset process as simple and painless as possible.
    3) I realize I didn't need to hold the button down longer than when the main display showed "UP__" but since I had documented that in a prior email, and the support answer was still a suggesting I hold the button down longer, I wanted to give an answer that would kill that rather useless line of thought.

    Thank you again for your help.

    Ben
     
    sjn01 likes this.
  6. xerxes

    xerxes New Member

    i could not agree more, the small amount of RAM that is required to hold a BASELINE image is tiny and the cost to the customer would be minimal given that the Zidoo x9S its self is Over Priced compared to other vendors who IMO offer far superior support and dont rely on the community to provide the help. that's not saying anything bad about the support the guys and gals here provide .

    if any one is looking for a USB Stick that works correctly I used a SANDSK Cruzer 4GB
    model sdcz36-004g formatted to FAT32 in windows 10, a quick format worked setting up the drive
     
    sjn01 likes this.
  7. alon hershko

    alon hershko New Member

    Hi
    I now on firmware 1.4.6
    If i want to downgrade to 1.4.4 can i flash the X9s to 1.2.3 and then use the OTA of 1.4.4 to update the device?
    Thanks
    Alon
     
  8. bodyzen

    bodyzen Member

    Yes.
     
  9. alon hershko

    alon hershko New Member

    So i download the 1.2.3 install.img from the tutorial move the file to root udisk
    plug it to one of the 2 usb ports press on the restore using pin and power up the device?
    I asking cause i read other people brick their device.
    I saw there is 1.2.3 img file and 1.2.7 what is better?
    all i want is lower version to update after to 1.4.4
     
  10. bodyzen

    bodyzen Member

    1.2.3 img file is perfect!
     
  11. cool_cat

    cool_cat New Member

    Tried to flash. The display shows "UP.." for hours. The tv does not show anything. It seems nothing happens. I've turned off the unit.
     
  12. HDMax

    HDMax New Member

    I have the same problem.
    When trying to flash (press the reset button and turn on the power), the box starts with "boot" and immediately goes to "up--".
    Nothing appears on the tv.
    Without pressing the reset, the box powers into "boot" and stays like that for hours.
     
  13. spawn_lmg

    spawn_lmg Active Member Beta test group

    Unpack this file https://drive.google.com/file/d/0B_3w7N84Ful-d0ZhU0w4OXJlWW8/view?usp=sharing
    copy install.img on USB Flash with FAT32
    Unpack this file https://drive.google.com/file/d/0B_3w7N84Ful-T0phemdnSFpvLUU/view?usp=sharing
    copy four files:
    bluecore.audio
    emmc.uImage
    rescue.emmc.dtb
    rescue.root.emmc.cpio.gz_pad.img

    to the same USB Flash with FAT32
    Turned off TV box, unplug all connected in USB and SATA devices, insert the USB flash into the box
    turn ON TV box, but NOT PRESS RESET
    wait...
     
    Tony77, sjn01, slavensiz and 7 others like this.
  14. HDMax

    HDMax New Member

    @spawn_lmg , Thank you so much !
    You've saved my box :)
     
  15. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    spawn_lmg, precious instructions! Thanks So Much!
     
  16. Sarco

    Sarco Active Member Beta test group

    It will be nice to change topic name by adding something like revert back to previous, downgrade to previous firmware... I am tire of that question in every topic. Tank's spawn!
     
  17. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Or complete the FAQ and let people point to it when a question is already thoroughly answered there.
    I think a FAQ must be one for each device. A collection of all devices FAQ is not the best for newbie (and for lazy people :p )
    (what about a Wiki ???)
     
    videobruce likes this.
  18. bodyzen

    bodyzen Member

    Perfect! Thanks! :)
     
  19. Tashman

    Tashman New Member

    Hi.
    Just in time. I already wanted to throw out this brick. Thank you.
     
  20. emre

    emre New Member

    Hello friends. I installed the wrong software through the device. now the device is sending the message that the system software is being installed at boot time. I tried all the ways but it never happened.
     
    sjn01 likes this.

Share This Page