1. Dear Users, Happy New Year! In order to celebrate the traditional Chinese Spring Festival, Zidoo company is scheduled for a holiday from 18th Jan to 15st Feb. We will be back to work on 16st Feb. If there is urgent message, pls contact service@zidoo.tv Your understanding will be highly appreciated if our holiday brings you any inconveniences.We are looking forward to your support in the coming new year and hope you have have a happy and joyful time in 2020! Best regards, ZIDOO Team
    Dismiss Notice


Discussion in 'ZIDOO X9S' started by HoneCharles, Oct 8, 2016.

  1. spring

    spring Well-Known Member Zidoo TECH Supporter

    i has updated.
  2. francishe

    francishe Member

    Many thanks. But the link can't be opened. Download error. Please repair.
  3. spring

    spring Well-Known Member Zidoo TECH Supporter

    i test it, and it can download well
  4. francishe

    francishe Member

    How can? Still can't open.

  5. francishe

    francishe Member

    Sorry. Have tried other browsers. None of them can visit, showing the website you are visit is wrong, nor can Thunder (xunlei) download.
  6. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    francishe, I'm sorry, but is a problem related to you and your environment.
    Tested both links few second ago, and both starts a download perfectly.
    Maybe your provider has "something wrong" with DNS resolution?
    You may try to change your DNS using Google ones, or OpenDNS ones (that I'm using to avoid censorship)
    No more ideas...
  7. francishe

    francishe Member

    ok, will try when home. thanks.
  8. francishe

    francishe Member

    Funny, the link works now on my office network, which did not before.
  9. spawn_lmg

    spawn_lmg Active Member Beta test group

  10. Tashman

    Tashman New Member

    I have a problem - http://forum.zidoo.tv/index.php?threads/factory-reset-recovery-problem.3260/
    Probably my player is damaged Bootloader.
    How can this be understood?
    How can I restore the Bootloader?
  11. screwdriver072000

    screwdriver072000 New Member

    Hi. Kindly provide also .img file of the 1.2.10 firmware.
    Last edited: Jan 14, 2017
  12. Cliquot

    Cliquot New Member

    Just updated from 1.2.9 to 1.2.10 and ZDMC won't run anymore - i tries to start and after a couple of seconds i'm reverted back to the main dashboard screen. Any thoughts on how to fix? thx a lot!
  13. Cliquot

    Cliquot New Member

    well... backup settings, uninstall and reinstall ZDMC, restore settings is working of course
  14. Cristian Topala

    Cristian Topala New Member

    I updated to 1.2.10 and the subtitles have missing letters in the internal media player, zdmc works just fine.
    I made also a factory reset but the problem persists and after that.
    I like the internal media player and I don`t wanna to rely on zdmc or kodi.
    Is there a way to fix this?
  15. screwdriver072000

    screwdriver072000 New Member

    I agree, letters at the beginning of sentences are missing.
  16. nemeth

    nemeth New Member

    Just opened the case and found that the reset button wasn't soldered to the board.
  17. azwina

    azwina New Member

    may i know it is use this method to downgrade firmware ??
  18. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    this is the only way to downgrade, flash older .img,
  19. donny

    donny Member

    Hi all,
    I take the v.1.2.3 file img.zip. on usb,
    Do I have to extract the file?or rename?
    Last edited: May 2, 2017
  20. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    please read the guide on first post

Share This Page