HOW TO FLASH ZIDOO X8 UNIT

Discussion in 'ZIDOO X8' started by mirror, Nov 14, 2016.

  1. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    There is some risk for flashing your ZIDOO_X8 BOX, please be quite careful to make it.(It will clean out user data entirely, if you are not professional,please be cautious to do it.)

    The following Flashing Process is about ZIDOO X8, attaching ZIDOO X8 TV BOX:

    First, do some preparation:

    ① A ZIDOO X8 TV BOX, one HDMI cable, A TV set (You kept surely, do not say any more);

    ② a quite fine needle, you can use other finer tools instead of it, such as toothpick, etc. ( In order to hold down the Reset button );

    ③U disk, ensuring that it is as below the format of FAT32;

    ④A Needle, which can access to reset button

    [​IMG]

    At the beginning, you need to download the zip ROM and Unzip to install.img (make sure the ROM named "install.img",If not,

    please correct it link of the version v1.2.6: http://ota-cloudfront.zidoo.tv/X8/img/v1.2.6/v1.2.6_img.zip) , then copied to the Root Directory of the Udisk you’re ready, not other files.

    Then, insert U disk into one of USB2.0 port, as shown below red line mark.

    [​IMG]

    Flash your box now: First,press the reset button then turn on the power by the same time,

    [​IMG]

    while you have connect to TV, the TV will show the schedule,

    proved that you are flashing now

    [​IMG]

    this flash process about two minutes ) , after finishing flashing will showed you install completed,

    [​IMG]

    then it will enter the system automatically(It will be a little longer for the first

    time, about 2 minutes),

    [​IMG]
     
  2. agmarco

    agmarco Member

    Is this for recovering the box, normal firmware update or to flash rooted FW? Sorry nOOb here. Thanks.
     
  3. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    is to recover the box.
    updates are OTA. root is not possible at this time.
     
    agmarco likes this.
  4. agmarco

    agmarco Member

    The like is for your response but not for Zidoo being unable to give us root option. :-(
     
  5. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    well. there is no android out there unrootable. so there should be a option soon.
     
  6. zwspore

    zwspore New Member

    I have ordered a Zidoo X8 and will be receiving it soon, and would like to clarify the process of flashing the X8.

    In the description, it was mentioned a "U Disk" is needed to connect to one of the USB 2.0 port. May I know what is a "U Disk"? Is it provided in the box together with the X8? Would I need to insert an SD card to the "U Disk" and plug that in to the USB port for the flashing?

    Thanks for any help and clarification.
     
  7. Simongnz

    Simongnz New Member

    It's a USB key/memory stick etc.
     
  8. diddyrgs

    diddyrgs New Member

    hi there,

    i got same problem. my zidoo device x8 stuck on zidoo logo.

    i try same step as you mention upper. i put usb stick then i press the reset button then turn on the power by the same time

    but my zidoo x8 not detact that usb. then i put usb stick on another usb port. but still cannot.

    for your infomation i use fat32 @ default allocation size on my usb stick @ i also have rename that file to "install.img" and also "install" . i have use more then 3 usb stick. but still not working.

    now more then 2 weeks i try again n again. please give me hope.

    any way can i restore sir?

    tq
     
  9. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

  10. pandoukht

    pandoukht New Member

    Hi, my X8 won't start, so I decided to give re-flashing it a try. I follow the procedure described in the FAQ here, using the ROM they link there: http://www.mediafire.com/file/0unurattiey4h82/install-ZIDOO_X8-v1.4.12-201708191533-USB.img. (Also, the "save brick" method described for X9s here, but using the ROM for x8).
    Both methods fail, standard flash gets stuck with "UP__" displayed and red power led, save brick stalls at "boot". My suspicion is a corrupt download, but I can't find checksum info for the image linked above in the forum.

    Can anyone help by posting an MD5 of the linked image? Mine is: 322BA88B033B83EA16CE04700DC23260

    (I also tried the image 1.2.6 in this post, that got me to a flat green screen with the save brick method, but nothing more, and I waited for hours.)
     
    Last edited: Dec 23, 2018
  11. pandoukht

    pandoukht New Member

    All right, now that I am not on a metered and spotty connection, I re-downloaded and the checksum is: A6A05727C9E58D4B1A7D074FAC7A40CC. Extracted image and created my save brick volume. Unfortunately the results are similar: standard flash gets stuck with "UP__" displayed and red power led, save brick stalls at "hello", nothing displayed.
     
  12. szefo

    szefo Member

  13. pandoukht

    pandoukht New Member

    Thanks, @szefo, I've done just that. Quoting my original post from Dec 23rd (awaiting moderator approval ever since) without the links:

    So, it was a corrupt download, but flashing with the proper image didn't help either. I'll give 1.2.6 another shot now and then I give up.
     
  14. szefo

    szefo Member

  15. pandoukht

    pandoukht New Member

    Thanks, szefo, that is something I was not willing to make, already too many wasted hours trying to save the brick, but in a way, it was my bad. Finally got back to the topic, replaced my pendrive as I just realized the previous one was corrupting the image when copied! So a word of advice to everyone struggling to make it work, check the hash after copying / disconnecting / reconnecting the USB drive too. Learned it the hard way.
    A good incentive to do this would be to actually include the hash in these postings and tutorials.
    Anyways, I got my ZX8 back after all via the Save Brick method. Thanks for the support.
     

Share This Page