Google Play Services problem solved

Discussion in 'ZIDOO H6 Pro' started by vitocorl, Nov 13, 2018.

  1. vitocorl

    vitocorl New Member

    I have found a way to solve the problem of Google Play Services crashing, by replacing the apks inside system\priv-app\ with their newer versions (inside the attached zip file) .
    1. I stopped, disabled & cleared cache & data of Google Play Services, Google Framework & Google Playstore
    2. Replaced PrebuiltGmsCore.apk, Phonesky.apk, GoogleServicesFramework.apk, GoogleLoginService.apk inside system\priv-app\ with the ones in the zip file.
    3. Run each of the above apk in order to install the new versions.
    4. Go into settings and clear again cache & data of Google Play Services, Google Framework & Google Playstore
    5. Reboot or shutdown & start the box.

    You can also try replacing the above apks into the firmware update zip file and then update zidoo normally.

    Please report here if you have success and/or any problems after performing the above procedure.

    Zip file with the required apks:
    https://www.dropbox.com/s/9yhsmk4rsnv62st/Fix Google Play Services.zip?dl=0
     
  2. Mike Kay

    Mike Kay New Member

    whilst i am sure you are just being kind and helping the community........ is it wise to randomly install apps which are supplied from an unknown.... esp apps which we put our credit card details into.

    (no offence meant and maybe i am just being ignorant of how google play works... but if this works properly i think zidoo should release it in a new update)
     
  3. vitocorl

    vitocorl New Member

    You may be right to be cautious, but instead of downloading my zip file you can download all the files (Google Play Services, Google playstore, google framework and google account manager) from apkmirror.com, then rename them (Google Play Services to PrebuiltGmsCore.apk, Google playstore to Phonesky.apk, google framework to GoogleServicesFramework.apk and Google Account Manager to GoogleLoginService.apk) and then replace the files in the directory as described.

    That is the procedure i did, i only renamed the files
    (i downloaded https://www.apkmirror.com/apk/googl...gle-play-services-android-tv-14-7-88-release/, https://www.apkmirror.com/apk/google-inc/google-play-store/google-play-store-12-4-14-release/, https://www.apkmirror.com/apk/googl...oogle-services-framework-7-0-3037786-release/, https://www.apkmirror.com/apk/googl...r/google-account-manager-7-0-3037786-release/) and uploaded them to dropbox for the convenience of the community.

    It is up to you, i give you the links above to download them if you like, or you can try to find these files anywhere you feel comfortable to download. Just remember to download for Android version 7.0 and Google Play Services for Android TV....
     
    Mike Kay and chu like this.
  4. jjjackson

    jjjackson Member

    Unfortunately the fix didn't work for me. Always open to new ideas.
     
  5. vitocorl

    vitocorl New Member

    You have to clear cache and data to Google Play Services, Google Playstore and google framework before and after you install, did you already do that?
     
  6. jjjackson

    jjjackson Member

    I did
     
  7. vitocorl

    vitocorl New Member

  8. jjjackson

    jjjackson Member

    I says my device has it already installed.

    It did work for awhile, but now it's not working
     
  9. baro

    baro New Member

    How do you replace the files? Using Root Explorer? Can you help with overview of the right order?
    Thanks.
     
  10. vitocorl

    vitocorl New Member

    Yes i used root explorer, but you can also use ES file explorer (after you enable root access at the menu on the left side of ES). There is no right order, the problem lays at Google Play Services which is the PrebuiltGmsCore.apk, so you may want to do this first. Remember to stop all the services from running, disable them and clear cache and data BEFORE you replace the files. Then, replace each file and run the new one (so that it will be installed). After you replace and run all of them, clear cache and data again and reboot (or shutdown and power on) zidoo.
     
  11. Duane

    Duane New Member

    Thanks Vitocorl.

    Hi Baro, does this solution be ok for you?
     
  12. Jubair

    Jubair New Member

    I think you are taking a hard way to fix the problem.
    Vitocorl's method should work, although I haven't tried yet but I fixed my problem in similar way -

    1. Download bellow apk files and copy them to ziddo box:
    i. Google Play services (Android TV): https://www.apkmirror.com/apk/googl...4-7-99-080306-223214910-android-apk-download/
    ii. Google Play Store: https://www.apkmirror.com/apk/googl...8-22-all-0-pr-223903645-android-apk-download/
    iii. Google Services Framework: https://www.apkmirror.com/apk/googl...s-framework-7-0-3037786-android-apk-download/
    iv. Google Account Manager: https://www.apkmirror.com/apk/googl...e-account-manager-7-1-2-android-apk-download/
    2. Reset your device first, do not connect to internet, do not use any google account.
    3. Go settings>apps. force stop all the four mentioned apps and disable them (play services might not get disabled and stopped. If it does not, leave it). Clear cache and data of these apps.
    4. Install downloaded apks sequentially Google Account Manager>Google Services Framework>Google Play services>Google Play Store
    5. Restart your device and configure your google account after connecting to internet.

    Luck is also a factor in this solution. If this does not fix the problem try again after a hard reset (using button inside AV port) and a firmware upgrade to 1.0.36.
    I am using almost a month and so far no problem. Thought it doesn't fixed the problem with automatic frame sync, the box is working much better now and disgusting play services error is not popping up.
     
  13. vitocorl

    vitocorl New Member

    All of the above are right, except that if you do not copy the apks inside system\priv-app\ (into their respective directory, as i describe in the first post), then, when you reboot or shutdown the unit all of Google Play services get reverted to their old versions and the problem appears again. That is because every time you reboot or shutdown all the apks get installed again from the ones residing inside system\priv-app\....

    You can check the versions by downloading an app called "play services info" and checking the versions after reboot. If you have copied the files in system\priv-app\...., then the versions should look like mine, see attached pictures
     

    Attached Files:

    Last edited: Dec 7, 2018 at 5:54 AM
    Jubair likes this.
  14. Jubair

    Jubair New Member

    I have checked. Mine was not changed for some reason after update (may be I was just lucky). However, after your comment, I tried to update again with latest version and after restart, both play store and play services revert back to stock version!!

    So it seems you are right and I also tried your way and it worked! This method can be devastating, in first attempt I f***ed my box, it was rebooting automatically after a minutes and I had to make a hard reset. So I changed your method a little:

    1. I downloaded all the apks from the links I provided before, renamed Play Store apk to Phonesky.apk and Play services apk to PrebuiltGmsCore.apk. I didn't changed google account manger and google services framework and kept as before.
    2. after a reset, (do not connect to internet and do not configure google account), I disabled these apps from settings>apps, cleared cache and data, and stopped them.
    3. I update both google account manger and google services framework by running the apks manually because after restart these does not revert back to stock version.
    4. after installing, I disabled and stopped google account manger and google services framework again.
    5. I copied Phonesky.apk and PrebuiltGmsCore.apk to "system\priv-app\Phonesky" and "system\priv-app\PrebuiltGmsCore" accordingly using Root Explorer.
    6. Ran both apks to update
    7. Restarted the box

    So far no problem. You did a hell of a job Vitocorl. Respect+
     
  15. vitocorl

    vitocorl New Member

    Well, i am happy i have helped, since Zidoo is not providing any useful information on the matter. I do not know why your unit was rebooting, i have tried this solution to over 10 zidoo H6 Pro units and i did not have this symptom, neither i had to reset the units. Anyway, problem solved and the unit is stable again...
     
  16. PROXIMO

    PROXIMO New Member

    Wow I came to the same conclusion by myself. It worked for me only with Google Play Services renaming it to PrebuiltGmsCore.apk and overwriting system\priv-app\PrebuiltGmsCore. I wrote about it without seeing this topic.
    Its good what we have such a community. I have some other issues with the box, if someone can help please be welcome.
    Frame drops / Stuttering
     
  17. PeterCrouch

    PeterCrouch Member

    @vitocorl @PROXIMO @Jubair what if the next version of youtube update, it require update new Google Play Service version? We need download the APK files update and make this way again?
     
  18. PeterCrouch

    PeterCrouch Member

    This firmware is so "stupid"...Why after reset, it come back to stock version? WHY @mirror @zidoo @spring...do not support us?
     

Share This Page