EDID thread (RTD1619BPD players)

Discussion in 'HDD Media player(RTD 1619BPD)' started by Markswift2003, Oct 23, 2023.

  1. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    No idea what's going on there, but all the EDID does is tell the box what the display is capable of - so in your case it tells the box it can do HDR10, HDR10+, TV Led DV and Player Led DV.

    It can't "force" any of those modes, it just tells the box they're available.

    So let me get this right:

    1. You have HDR set to Auto
    2. You play an HDR10+ file and that plays correctly in HDR10+
    3. When you stop the file the GUI does not return to SDR - instead it remains in HDR10+
    4. If you then play a 1080p SDR file, that plays in HDR10+
  2. Staff49

    Staff49 New Member

    yes exactly and regarding the dv settings, they change by themselves and in auto it is the setting that I prefer certain files are not played dv, forced to restart the box
  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Ok - let's forget about DV for a moment.

    So after playing and stopping an HDR10+ file, how do you know that the GUI remains in HDR10+?

    (as far as I know, that's not possible with the SOC)
  4. Staff49

    Staff49 New Member

    my tv still indicates hdr10+ the logo is still present if I use the remote control of my tv, but I notice it by eye because the contrast and brightness remain the same even though the file is in sdr
  5. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Ok - try this:

    1. Make sure HDR is set to Auto
    2. Play an HDR10+ file
    3. Stop HDR10+ file
    4. Now play a 1080p SDR file and confirm the TV reports HDR10+
    5. While the 1080p SDR file is playing, press "Info" on the Zidoo remote and tell me what the "Output Mode" line at the bottom says:

  6. cucnz

    cucnz Active Member

    If it helps , i have pana g1000z and l1500z OLED models
    The g1000z is in the bedroom with an older Z9X .....it runs in HDR /VS10DV for all
    The L1500z is in the lounge with the new Z9X pro ...it runs HDR /VS10 for all as well

    For the rare HDR10+ stuff i just manualy change HDR to Auto and back to forced VS10 afterwards

    Zero issues with stuff as DV will play correctly this way ,and sdr hdr stuff looks way better in VS10 DV
  7. misichavichus

    misichavichus Member

    Hello Markswift2003!
    Any recommendations for VS10 settings on UHD5000? Samsung Q7F QE55Q7F connected via onkyo TX-RZ50 receiver
    Are there any differences in settings from 9x pro? Do you have any personal recommendations based on your experience?
    Everything works fine for me after resetting and installing the firmware and resetting again.
    The image disappears for a few seconds when starting the movie, this is annoying, dont like the blank screen for the 1st few seconds when playing a file. Installed VS10 for HDR and edid which is in the menu of the Samsung set-top box
    Please look at my EDID. Thanks for the help!!

    Attached Files:

    Last edited: Apr 19, 2024
  8. Earthkeeper

    Earthkeeper Member

    The blank screen at the start of the video is caused by your tv changing mode to the video's frame rate. For example, if your screen is at 60fps and you start a video that has a frame rate of 30, the tv will blank for a few seconds (changing mode to 30fps) to ensure flawless playback without stutters.

    It works that way for everyone and also a very welcoming feature. If most of your videos are of a certain frame rate, you can change your "default" frame rate to that. There'll not be any blanking if the frame rate is the same.
    misichavichus likes this.
  9. misichavichus

    misichavichus Member

    And you can’t get rid of this? Or do you need to change the settings? Which? Thank you.
  10. Earthkeeper

    Earthkeeper Member

    You can get rid of that by turning off auto frame rate. But the video may stutters because the tv frame rate does not match.

    Settings :: Playback :: Auto frame rate
  11. misichavichus

    misichavichus Member

    I turn it off - it freezes and jerks. I turn it on - black screen. No more options?)) When the new firmware comes out, will this be fixed, do you think?)

    Everything was installed according to the instructions of the respected Markswift2003
    Playback/Automatic frame rate/Frame rate mode: Match frame rate and resolution

    Display/Resolution: 3840x2160p 23Hz

    4K 50~60Hz: Priority YUV420 10BIT - It seems to me that the picture is better with (422)!!
    4K 23~30Hz: Priority YUV444 10BIT
    Non-4K: Priority YUV444 10BIT

    only changed Display/HDR: VS10 Engine (Output HDR)
    It seems to me that the picture is better with VS10

    Perhaps me still need the correct EDID. I hope Mark can help me with this.
    Last edited: Apr 19, 2024
  12. theory

    theory New Member

    No, it will not be fixed. This is expected behavior when streaming devices try to match the television's frame rate. I have tried just about every streaming device on LG, Samsung, and Sony OLED and they all do the same. The only way it'd be fixed is if there is some tech/standard breakthrough that most likely only new devices would be able to take advantage of.
    misichavichus likes this.
  13. misichavichus

    misichavichus Member

    Why then if I plug the disc directly into the TV does this never happen? Does any movie start immediately without a black screen?

    black screen at the start is the price to pay for smooth playback?
    Last edited: Apr 19, 2024
  14. Sanctrum

    Sanctrum Active Member

    TVs are set to some standard refresh rate. Movies are encoded in many different refresh rates since the standard refresh rates in TVs are different in the different world regions. Zidoo player is doing what should be done and tells the TV to adapt it's refresh rate first to Zidoo GUI and later to the specific movie - which always force any TV to resync HDMI handshake = short blank screen. No escape from this. If you are connecting via Onkyo AVR it can add it's own delay to the resync handshake time, since it is also in the HDMI chain (as man in the middle).

    But to minimize the number of black screens you should set your video settings at Zidoo to match most of your collection refresh rate:
    1. Review your movies collection to see what is the most common refresh rate of your movies. It might be 23.976, 24, 50, 60. Pick the most common. It's probably 23.976
    2. Set Playback/Automatic frame rate/Frame rate mode: Match frame rate only. Since your current setting makes things worse as is forcing HDMI hanshake resync even for different resolutions of your movies. So you can benefit of Zidoo upscaler instead of Onkyo or TV upscaler. Your call. P.S. Your Onkyo could also be set to impact / force resyncs which is always the case when output/input resolutions and refresh rates do not match in all 3 devices you have in the HDMI chain.
    3. Go to Settings/Dislpay/Resolution and change from Auto to 3840x2160p 23Hz only if most of your collection refresh rate is 23.976. I know, it is not obvious that actually 23 = 23.976 :). Set 24 if most common is exactly 24 and so on. And check the output resolution and refresh at Onkyo too.
    Last edited: Apr 20, 2024
    misichavichus likes this.
  15. Unclejoshc

    Unclejoshc Member

    You can also have the video pause for however long the normal handshake resync takes so it does not start playing before the screen is set correctly I think
    misichavichus likes this.
  16. misichavichus

    misichavichus Member

    all "improvements" in onkyo are disabled
  17. Sanctrum

    Sanctrum Active Member

    OMG. 3rd screen. Your Ziddo is downscaling to 1920x1080. Set all resolutions to 4k as your TV is.
    Zidoo is 4k capable, TV is 4k capable, Onkyo is 8k capable... And you set Ziddo to 1920x1080? Start reading manuals of your devices and check what resolution is actually displayed at TV - using TV remote somehow. etc.
    Last edited: Apr 20, 2024
    misichavichus likes this.
  18. misichavichus

    misichavichus Member

    I don’t know why this screenshot shows this resolution, I have it set to 3840x2160p everywhere

    I just turned on the player, indeed, for some reason unknown to me, the resolution in the settings changed, although it was always 3840x2160p! I don’t know how this happened)

    Yesterday you wrote "Match framerate only", I changed this setting and played with EDID. I don’t understand why the resolution was reset - that’s a different question now)))

    Your answer shows that you are attentive to the problems that are voiced on the forum and notice problems and do not just scroll through messages. Thank you!!!
    Last edited: Apr 20, 2024
  19. Visconti12

    Visconti12 Active Member

    This is HDMI resyncro issues that Zidoo can’t avoid. Set it as “Match frame rate only” to minimize it.
    misichavichus likes this.
  20. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I might get this tattooed - HDMI will resync on a change of resolution and/or HDMI mode and/or frame rate. How this manifests is down to each display - some do it quickly and elegantly, some make a right arse out of it.

Share This Page